
. . . . .

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Table Of Contents
Chapter 1. Safety Information
Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1 - 1
Safety Precautions. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1 - 2
Safety Labels And Terms . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1 - 3
Safety Features . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1 - 6
Material Handling. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1 - 9

Chapter 2. System Components
Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  2 - 1
Process Overview  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  2 - 2
Software Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  2 - 3
Major Assemblies  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  2 - 7
The UPS System . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  2 - 8

Chapter 3. Controls And Indicators
Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3 - 1
Front Panel Controls  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3 - 2
Rear Panel Controls . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3 - 4
Light Tower  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3 - 5
Trackball  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3 - 5

Chapter 4. Startup And Shutdown
Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  4 - 1
System Startup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  4 - 2
Safety Door Lock/Unlock  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  4 - 6
System Shutdown . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  4 - 7
E-Stop And Recovery . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4 - 10
Routine Maintenance . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4 - 11

Chapter 5. Conveyors And Heated Chucks
Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5 - 1
Adjusting Conveyor Hard Stops . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5 - 3
Adjusting Conveyor Width  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5 - 4
Setting Conveyor Speed . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5 - 5
Loading Boards Onto The Conveyor . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5 - 5
Setting The Heated Chuck Temperature . . . . . . . . . . . . . . . . . . . . . . . . . .  5 - 7
XyflexPro Operation And Programming Guide, Benchmark 4.2 i



TA BLE  OF  CONTENTS
Chapter 6. Calibration And Offsets
Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6 - 1
Camera Calibration  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6 - 3
Manual Calibration Of Camera-To-Needle Offset  . . . . . . . . . . . . . . . . . . . . . 6 - 8
Calibration Of Camera-To-Needle Offset (Automatic) . . . . . . . . . . . . . . . . . 6 - 16
Setting Dispense Head Park Position  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6 - 18
Teaching Fixture Position Offset  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6 - 19
Setup Of The Pre-Dispense Station  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6 - 21
Teaching The Camera-To-ZSense Offset. . . . . . . . . . . . . . . . . . . . . . . . . . 6 - 25
Setting The Location Of The Weight Scale (Option) . . . . . . . . . . . . . . . . . . 6 - 29
Teaching The Needle Calibrator Sensor Position  . . . . . . . . . . . . . . . . . . . . 6 - 33
Conveyor Speed Calibration  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6 - 35
Teaching The Purge Cup Position  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6 - 37
Teaching The Syringe/DU Change Position . . . . . . . . . . . . . . . . . . . . . . . . 6 - 41

Chapter 7. Toolbars And The Process Program Grid
Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7 - 1
Main Machine Toolbar  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7 - 2
Configurable Toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7 - 3
Process Program Grid. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7 - 6
Process Program Commands Toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7 - 6
Process Program Grid Fields . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7 - 11
Block Editing. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7 - 14

Chapter 8. Creating And Managing Process Programs
Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 1
Creating A New Process Program  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 3
Assigning Properties  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 5
Importing Files  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 7
Inserting Program Commands . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 9
Saving The Process Program. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 10
Editing An Existing Process Program  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 11
Assigning Units Of Measure . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 12
Creating And Assigning Fiducials . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 13
Creating A Taught Fiducial . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 13
Configuring Synthetic Fiducials . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 17
Creating One Snap Fiducials . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 19
System Templates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 21
Creating A Template  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 22
Dot, Line And Move Templates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 23
ii XyflexPro Operation And Programming Guide, Benchmark 4.2



. .
 . 

. .TA BLE  O F  CO NTENTS
Chapter 8. Creating And Managing Process Programs (Cont.)
Weight Scale Templates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 24
Filled And Unfilled Rectangle Templates . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 28
Creating A Diamond Shape . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 30
Pre-Dispense Templates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 33
Array Templates  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 35
Renaming A Template  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 36
Editing Or Copying A Template . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 37
Running A Process Program  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 39
Optimizing A Process Program (Xyflex). . . . . . . . . . . . . . . . . . . . . . . . . . . 8 - 41
Optimizing A Process Program (XyflexPro)  . . . . . . . . . . . . . . . . . . . . . . . . 8 - 43

Chapter 9. System Administration And Security
Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  9 - 1
User Groups . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  9 - 2
Privileges . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  9 - 2

Chapter 10. Bad Mark Sensing
Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10 - 1
Identifying A Bad Mark In The Process Program Grid  . . . . . . . . . . . . . . . . . 10 - 2
Setting The Vision System For Batch Mode. . . . . . . . . . . . . . . . . . . . . . . . 10 - 4
Creating And Naming The Bad Mark File . . . . . . . . . . . . . . . . . . . . . . . . . . 10 - 6
Inserting The Bad Mark Template Into The Process Program . . . . . . . . . . . 10 - 10

Chapter 11. SPC Data
Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11 - 1
Setting The SPC Data Log  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11 - 2
Viewing SPC Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11 - 4
Downloading SPC Data  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11 - 5

Chapter 12. Network Communications
Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12 - 1
Networking Configurations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12 - 3
Benchmark® Software  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12 - 5
Configuring The Benchmark® Software For Remote UI’s . . . . . . . . . . . . . . . 12 - 9

Chapter 13. Dispensing SMT Applications
Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13 - 1
SMT/SemiConductor Process Program Grid . . . . . . . . . . . . . . . . . . . . . . . . 13 - 2
Typical SMT Application. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13 - 6
Optimizing A Process Program (Xyflex). . . . . . . . . . . . . . . . . . . . . . . . . . . 13 - 9
Optimizing A Process Program (XyflexPro)  . . . . . . . . . . . . . . . . . . . . . . . 13 - 11
XyflexPro Operation And Programming Guide, Benchmark 4.2 iii



TA BLE  OF  CONTENTS
Chapter 14. Dispensing Underfill And Encapsulation
Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14 - 1
Underfill Applications . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14 - 2
Creating Chip Definitions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14 - 5
Chipline Start And End Offsets . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  14 - 10
Underfill Sample Program . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  14 - 12
Encapsulation Applications . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  14 - 14
Using The Weight Scale For The Underfill Process . . . . . . . . . . . . . . . . . .  14 - 16

Glossary
Index

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  Index - 1
iv XyflexPro Operation And Programming Guide, Benchmark 4.2



1
. . . . .

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Safety Information

Overview

Introduction Many safety features have been incorporated into the design and manufacture of 
the XyflexPro system. This chapter describes the safety features, cautions and 
warnings associated with the day to day operation of the XyflexPro system.

All personnel responsible for operating the system must read and understand the 
provided documentation, before attempting to run the system. Safety must be 
considered and practiced at all times.

Failure to adhere to the recommendations and procedures could expose personnel 
to potentially hazardous conditions.

In This Chapter This chapter contains the following topics.

Topic Page

Overview 1-1

Safety Precautions 1-2

Safety Labels And Terms 1-3

Safety Features 1-6

Material Handling 1-9
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Safety Precautions
Safety Precautions

List of Safety 
Precautions

The following general safety precautions must be considered and practiced at all 
times:

• All personnel must read all instructions carefully. Failure to comply with the 
instructions could result in injury or property damage.

• Lift and move the system using only equipment with adequate weight capac-
ity and only at designated lift points.

• Be sure that the system is operating properly. The system will not operate 
with the safety door open.

• Keep hands away from heads, needles, belts, etc. during operation and 
whenever electrical power and air are on.

• Do not attempt to operate the system with any doors open or covers 
removed.

• Do not attempt to defeat safety interlocks.
• Should any malfunction occur, press the white MACHINE OFF push button or 

one of the red E-Stop switches.
• Never reach for parts in progress or a fixture that has become loose. Press 

one of the red E-Stop switches.
• Never put fingers or objects into the openings of the system.
• Always wear eye protection.
• Wear proper apparel. Do not wear loose clothing or jewelry.
• Maintain a clean working environment.
• Disconnect the air and electrical power when handling, moving or servicing.
1-2 XyflexPro Operation And Programming Guide, Benchmark 4.2
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Safety Labels And Terms
Safety Labels And Terms

Usage Safety labels are used to identify potentially hazardous conditions or materials 
that are encountered during system setup and operation. International symbols 
(pictograms) are used to identify the hazard type. Labels are affixed to the 
equipment in the vicinity of the potential hazard and appear throughout this 
manual. Labels appearing in the manual are accompanied by a “signal” word that 
indicates the severity of the hazard.

SEMI S13-0298 classifies hazard severity via specific signal words.

Classification of 
Hazards

Caution - Indicates a potentially hazardous situation which, if not avoided, may 
result in minor or moderate injury. It may also be used to alert against unsafe 
practices.

Warning - Indicates a potentially hazardous situation which, if not avoided, could 
result in death or serious injury.

Danger - Indicates an imminently hazardous situation which, if not avoided, will 
result in death or serious injury.

Definitions The following pictograms are used on the labels that are affixed to the machine. 
Each label contains a “signal” word which indicates the type and/or severity of 
consequences associated with the exposure or operation.

Some or all of the following labels may be used depending on optional equipment 
supplied.

Attention
Attention - Indicates a practice or recommendation which, if ignored, could cause 
damage or malfunction of the system.
Is also used to provide supplementary information or clarification of a specific 
statement or procedure.

Caution
Caution - General caution statement

Hand Cut Hazard
Moveable axes or sharp edges are present
XyflexPro Operation And Programming Guide, Benchmark 4.2 1-3



1
SA FETY  INFO RMA T ION

Safety Labels And Terms
Keep Hands Clear
Keep hands clear - Moving parts.

Pressurized Device
Release air pressure before servicing.

Consult Manual
Consult manual before performing this operation.

Eye Protection Required
Eye protection required.

Chemical Hazard
Chemical hazard - Consult Material Safety Data Sheet (MSDS) for hazards listing.

Laser Hazard
Laser in use.

Protective Gloves Required
Protective gloves required.

Burn Hazard
Burn Hazard - Hot surface -Allow to cool before servicing.
1-4 XyflexPro Operation And Programming Guide, Benchmark 4.2
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Safety Labels And Terms
Poison
Hazardous materials.

Hazardous Voltage
Danger of electrical shock or burn - Disconnect power before servicing.

Exposed Belt Drive
Exposed belt drive - Lockout and Tagout before servicing.

Equipment Starts Automatically
Equipment starts automatically. Lockout and Tagout before servicing.
XyflexPro Operation And Programming Guide, Benchmark 4.2 1-5
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Safety Features
Safety Features

Introduction The following safety features are intended to protect personnel from injury, while 
protecting the machine from damage. See Figure 1-1 and Figure 1-2.

Protective Covers Protective covers have been designed to fully enclose the machine (except the 
conveyor openings). The covers restrict access to any moving parts, dangerous 
voltages, pneumatic pressures, or dispensing materials used in the machine. 

Safety Relay Circuit This circuit is directly hard wired to the controllers that drive all axis and conveyor 
motion and will disable any and all motion on the machine if the safety door is 
opened.

Safety Door Interlock 
Switch

The Interlock switch prevents the safety door from being opened while the 
machine is operating. The control system continuously checks the status of the 
door closed and door locked signals.

The interlocks are spring loaded; even in a machine power-off condition, the door 
remains locked. A reset must be performed, and power applied to the machine, 
before the operating system will permit the door to be opened. 

Emergency Stop Palm 
Switches

Emergency stop (E-Stop) palm switches are the fastest and most effective 
method of halting machine operation in the event of a malfunction. E-Stop 
switches are located at the front and rear of the machine. All electrical power and 
pneumatic pressure to the machine is terminated when an E-Stop switch is 
pressed, except the uninterruptible power supply (UPS). This allows the computer 
to remain on until the operator shuts it down or until the automatic shutdown 
feature of the computer activates. 

Main Power Switch
(Lockout/Tagout)

The Main power (Lockout/Tagout) switch allows service personnel to disable all 
electrical power and pneumatic pressure to the machine for repair or 
maintenance. A long-stemmed padlock can be inserted to ensure that power 
cannot be inadvertently applied to the machine. 

Safe Touch Controls The lower access panel on the front of the machine does not require interlocks or 
access panel locks. The layout of components has been designed such that no 
voltages or other hazards can be reached without manually removing covers 
within this compartment. 

Access Panel Locks Access panel locks are designed to eliminate casual opening of panels wherever a 
dangerous condition can exist.
1-6 XyflexPro Operation And Programming Guide, Benchmark 4.2
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Safety Features
Pneumatic Dump Valve The pneumatic dump valve (located behind the rear access panel) (Figure 1-2) 
works in conjunction with the three emergency stop palm switches. Whenever an 
E-Stop switch is pressed, the spring-loaded dump valve opens, discharging all 
pneumatic pressures safely within the machine.

Figure 1-1

Machine ON

Machine OFF

Reset

E-Stop

Main Power Switch
(Lockout/Tagout)

Syringe Air Pressure
Gauge and Adjustment
Knob

E-Stop
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Safety Features
Figure 1-2

Air Regulator
and Filter

A/C Power
Cord

E-Stop

Pneumatic Dump
Valve

Upstream and Downstream

Light Tower

SMEMA Connections
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Material Handling
Material Handling

Introduction Many materials used in the dispensing process, during cleaning and lubrication 
are potentially hazardous. 

Dispensing Material 
Disposal

Used (empty) syringes and dispense material that was deposited onto a rag or 
wipe during the dispense unit purging process should be fully cured and then 
disposed of in accordance with National and Local regulatory requirements. 

Material Safety Data 
Sheets (MSDS)

Material Safety Data Sheets (MSDS) are provided by manufacturers and 
distributors of hazardous substances. There is no single standard MSDS form, 
therefore many different types of MSDS forms may be used. What is consistent, 
is the type of information included on each MSDS form.

It is required that all personnel have ready access to the MSDS.

A table is provided in the Maintenance and Repair Guide for identifying potentially 
hazardous materials. We have listed materials supplied in the machine support kit 
for you and inserted the appropriate MSDS sheet(s) following the table for your 
convenience.

In order to keep the table current, you will need to add all other materials that are 
present in your environment and insert the appropriate MSDS.
XyflexPro Operation And Programming Guide, Benchmark 4.2 1-9
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Material Handling
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System Components

Overview

Introduction This chapter explains the function of the various major components of the 
XyflexPro system. The process sequence that occurs during the running of a 
dispense program is also described.

The operator should understand and become familiar with the function of all the 
components before attempting to startup or operate the system.

Attention
When performing any calibration procedure in this section, the command word 
“Select” refers to clicking the left trackball button.

In This Chapter This chapter contains the following topics.

Topic Page

Overview 2-1

Process Overview 2-2

Software Overview 2-3

Major Assemblies 2-7

The UPS System 2-8
XyflexPro Operation And Programming Guide, Benchmark 4.2 2-1
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Process Overview
Process Overview

Description The board is accepted into the XyflexPro system on the conveyor when a 
SMEMA (Surface Mount Equipment Manufacturer’s Association) signal is sent 
(board available) from the upstream machine to the XyflexPro computer.

As the board enters the system the leading edge of the board is sensed by a 
sensor located on the base plate. The signal from the sensor raises the hard stop 
and slows the conveyor belt down after a predetermined period of time. The 
leading edge of the board is stopped by the hard stop at the dispense station and 
the board is clamped and raised to the dispense position by edge clamps. The 
conveyor stops running until the dispense program is complete.

Two types of dispensing processes are available SMT (Surface Mount 
Technology) or Underfill and Encapsulation. The dispensing process is set by the 
software in the Properties screen. Refer to the Chapter titled - Creating and 
Managing Process Programs. 

If the SMT process is chosen, the software has an option available to optimize 
the process program (refer to Chapter titled - Toolbars And The Process Program 
Grid) to achieve the maximum throughput. This will also vary if different size dots 
or materials are used.

If Underfill and Encapsulation process is chosen, all dispensing is accomplished 
when the head is available. This is to prevent time sensitive dispensing material 
from aging in case the upstream machine cannot accept a board.

A Dispense Unit or Multi-Piston Pump (mounted on the Z-axis) will dispense the 
loaded dispense program onto the board clamped at the dispense station. Upon 
completion of the dispense program in the dispense zone, the conveyor starts 
running and the edge clamps and hard stop are lowered and the board continues 
downstream. 

The board remains at the dispense station until the downstream machine sends a 
signal (machine ready) to the XyflexPro computer. This signal allows the board to 
be released from the dispense station and continue downstream exiting the 
machine.
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Software Overview
Software Overview

Introduction The XyflexPro system utilizes a Windows NT® based software called Benchmark®. 
Benchmark software allows the user two different screen views with the ability 
to toggle between them using the View menu at the top of the screen.

Machine Screen The first view upon startup is of the Machine screen. At machine startup the 
Benchmark software is launched automatically requiring only that the user log in 
and initialize the machine. The Machine screen appears as in Figure 2-1. 
Alternatively, the Machine screen can be displayed by selecting View> Machine 
from the menu bar at the top of the screen or the machine icon . 

It contains several tool tips that enable the operator to control or monitor 
standard functions without the need to view numerous menus and dialogs. The 
controls become visible when the screen arrow (cursor) passes over their “hot” 

location on the screen. 

Figure 2-1

B

C

D
E
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Software Overview
On Screen Controls The controls are identified on the Machine screen as follows (See Figure 2-1):

b Dispense Head Status and Syringe Level

c SMEMA Signals

D Heat Controller Switch

E Door Lock / Unlock 

Machine Status 
Display

Machine Status- This displays the current condition of the machine. The possible 
conditions are as follows:

• Running (machine is running the loaded process program)
• Running with Err (machine is running with an Error)
• Running with Acked Err (machine is running with an acknowledged Error)
• Running with Warning (machine is running with a Warning)
• Running with Warning Acked (machine is running with an acknowledged 

Warning)

• Paused (machine is paused from dispensing the process program) 
• Paused Error (machine is paused with an Error)
• Paused Err Acked (machine is paused with an acknowledged Error)
• Paused Warning (machine is paused with a Warning)
• Paused Warn Acked (machine is paused with an acknowledged Warning)
• Paused Not Ready (machine is paused, not ready for operation)

• Resuming (machine is continuing its original operation)
• Aborting (machine is stopping the operation it is running)
• Diagnostics (machine is being diagnosed using the I/ O of the system soft-

ware)
• Error (the system encountered an error while in operation)
• Idle (machine is stopped waiting for the next operation)

Dispense Head 
Indicator

This is a visual indicator (located in the lower right-hand corner of the screen) 
which will display how far the head has progressed into the dispensing program. 
The display box will fill as the head moves along into the process program.

Conveyor Mode This displays (located at the lower right-hand corner of the screen) the mode of 
the conveyor. Three modes are available, Off, Automatic, and Pass Through. To 
change the selection, right click over the field and a drop down menu will appear.

Dispense Head Mode This displays (located at the lower right-hand corner of the screen) the mode of 
the dispense head. Three modes are available, Dry Run, Dispense, and Camera. 
To change the selection, right click over the field and a drop down menu will 
appear.
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Software Overview
Alarm Information 
Display

This will display all the alarms which have occurred during a dispensing 
process.The alarm information (located at the lower right-hand corner of the 
screen) may be displayed as a half screen or a single line. To change the 
selection, left click over the desired display.

Process Operation 
Buttons

The Start Operation, Pause and Abort Process buttons allow the operator to 
control the dispensing of a process program from the Machine screen. The 
buttons are identified as follows on the right side of the screen:

The Start Operation button (top button) is green in color when the machine is idle 
and ready to run a dispense process program. When the machine is running a 
process program the button will be gray in color.

The Pause button (middle button) is yellow in color when the machine is running 
a dispense process programprocess program. When the machine is idle, not 
running a process program, the button will be gray in color.

 

The Abort Process button (bottom button) is red in color when the machine is 
running a dispense process program. When the machine is idle, not running a 
process program, the button will be gray in color.
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Software Overview
Configurable Toolbar
(large icons)

The Configurable Toolbar (located at the top of the Machine screen) is used to 
perform various system calibrations, and offsets. Additionally, it gives the 
operator the ability to change syringes and clean predispense plates. When the 
cursor is placed over the icon a pop-up display appears to identify the function or 
title of each icon. See Figure 2-2.

Figure 2-2
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Major Assemblies
Major Assemblies

Introduction The XyflexPro system consists of a gantry, with a single or optional dual head Z-
axis, and a single or optional dual lane conveyor system with a customized 
graphical user interface.

Gantry Assembly The XyflexPro Gantry assembly is designed for high-speed high-precision 
positioning. Its base is constructed of a cast polymer composite. It is a 
formulation of a high strength epoxy, mixed with a scientifically blended quartz 
aggregate filler. In addition, the system includes chemical additives to improve 
the strength and durability of the composite. This serves as the support structure 
to which precision guideways are attached and support the Y-axis of the 
machine. A high strength aluminum casting forms the moving Y carriage. To it 
another pair of precision guideways are attached. These rails form the X-axis of 
the system. Accurately machined features in the casting assure that the X and Y-
axes are perpendicular to each other. To these X-axis guideways an X axis 
carriage is attached. This is the mounting platform to which the Z axis housings 
attach. 

The force to move the X and Y carriage elements is provided by powerful iron 
core linear motors.  Position feedback to the motion controller is by 1-micron 
linear encoders.  This arrangement provides a true closed loop servo system by 
utilizing a DSP based motion controller.  

Care has been taken in the design to minimize the size and amount of cables 
required to run the system. 

Conveyor Assembly The XyflexPro Conveyor system can transport parts on a single lane up to 10 
inches in width on a small format machine (7100), and up to 22 inches in width 
on a large format machine (7200). This varies based on whether the machine is 
set up for Surface Mount or Semiconductor applications.

Parts ride on static dissipative rails and belts. The rails are constructed such that 
belt surface exposure can be adjusted down to.101” part edge clearance by 
moving the top cap of the rail. Standard part underboard clearance is 30 mm.

Conveyor belt speed is controlled by encoded DC servo motors. Part positioning 
along the rails is accomplished by using optical sensors and pneumatically 
actuated hard stops.

Part positioning can be done with either a board edge clamping mechanism or 
with chuck assemblies. Additional support for large parts in an SMT application is 
achieved using pneumatically actuated board supports which can be randomly 
dispersed under the component.

Chuck assemblies may have heat, vacuum or a combination of both.

The conveyor width opening is adjusted using DC-servomotors.
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The UPS System 

Introduction XyflexPro is equipped with a UPS (Uninterruptible Power Source). The UPS,   
illustrated in Figure 2-3, provides a temporary source of power for the XyflexPro 
computer in the event of any power failure or electrical disconnect such as the 
use of an E-STOP. The UPS is located behind the front door underneath the 
computer and amplifiers in the lower front bay of the system.

Figure 2-3

Under normal conditions, the operator would perform a shutdown sequence as 
part of the standard power down procedure. This shutdown procedure is required 
to avoid corruption of the system software or user files. 

A battery in the UPS is constantly charged during normal system operation. In the 
event of an unexpected power failure or E-STOP the UPS switches it’s battery 
power to the XyflexPro’s computer, and initiates a controlled shutdown of the 
computer so as to avoid damage to the computer and corruption of important file 
data.

UPS System

System Amplifiers

System Computer
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The UPS System
UPS Indicators Figure 2-4 illustrates the UPS front control panel which contains several LED 
displays and buttons.

The UPS controls function as follows:

Figure 2-4

Line Input Indicator - Monitors the line voltage entering the UPS. The center LED 
indicates a normal (correct) voltage. The upper LED indicates that the UPS is 
compensating for a higher voltage. The lower LED indicates that the UPS is 
compensating for a lower voltage.

Power ON Switch - Turns UPS power ON.

Battery Condition Indicators - Indicates level of charge on the UPS battery. All 
LEDs illuminated indicates a full charge.

Power OFF Switch - Turns UPS power OFF. Power is still supplied to the 
computer as long as there is sufficient charge remaining in the UPS’ battery.

Load Indicators - Indicates the percentage of the UPS’ rated capacity is being 
utilized by the computer.

Load Indicators

Line Input
Indicator

Power ON
Switch

Power OFF
Switch

Battery State
Indicators

Battery Condition
Indicators
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The UPS System
Battery State Indicators - Normally all LEDs are off.

The top LED indicates an overload (power consumption exceeds the UPS’ 
capacity).

The middle LED indicates that the UPS’ battery is being utilized to power the 
computer.

The bottom LED indicates that the battery needs replacement.

For detailed information concerning the functions and operation of the UPS, 
consult the UPS users guide that is supplied.
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Controls And Indicators

Overview

Introduction The XyflexPro system is operated using a combination of mechanical operator 
controls and menu/dialog settings within the Benchmark software interface. 

This section shows the locations and explains the function of the various push 
buttons and operating controls on the XyflexPro. 

The operator should understand and become familiar with the function and 
location of all system operating controls and major assemblies before attempting 
to start-up or operate the system.

In This Chapter This chapter contains the following topics.

Topic Page

Overview 3-1

Front Panel Controls 3-2

Rear Panel Controls 3-4

Light Tower 3-5

Trackball 3-5
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Front Panel Controls
Front Panel Controls

Introduction The following Front Panel Controls are illustrated in Figure 3-1.

Emergency Stop 
Switches

There are two red Emergency Stop (E-STOP) palm switch located on the front 
panel. The entire system is shutdown when an E-STOP is pressed. If the 
emergency situation is not cleared, the uninterruptible power supply (UPS) will 
begin a controlled computer shutdown. Refer to Chapter titled- System 
Components for a detailed description on the UPS.

Machine ON 
Push-button

The green MACHINE ON push button is used to start the system. The button has 
an indicator light that is illuminated when power is supplied to the system. The 
button is identified with the international symbol l.

Machine OFF
Push-button

The white MACHINE OFF push button is used to shut down the system at the 
end of an operation. Be sure to follow the proper shut down sequence of the 
system. The button is white and is identified with the international symbol O.

Machine RESET
Push-button

The blue MACHINE RESET push button is used to reset the safety relay circuit 
after:

• An E-STOP button has been pressed
• A circuit ground fault has occurred
• Power has been lost
• The Main Power (Lockout/Tagout) switch has been turned off. 

The button is identified with the international symbol of a dot and a circular 
arrow .

Syringe Air Pressure 
Gauge and Adjustment 
Knob

The dispense bay is equipped with an air pressure adjustment knob and air 
pressure gauge used to set the pressure on the syringe. Adjust the knob as 
desired based on the current reading on the gauge. Turning the knob clockwise 
increases the air pressure. Turning the knob counterclockwise decreases the air 
pressure.

Main Power Switch
(Lockout / Tagout)

The Main Power Switch is used to disconnect the entire system from any external 
electrical power source. The switch is used primarily during maintenance or in the 
event of a system down condition. The switch is also referred to as a Lockout/
Tagout switch, because in the OFF position, it can be fitted with a padlock, to 
perform maintenance and prevent power from being applied to the system.
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Front Panel Controls
Figure 3-1

Machine ON

Machine OFF

Reset

E-Stop

Main Power Switch
(Lockout/Tagout)

Syringe Air Pressure
Gauge and Adjustment
Knob

E-Stop
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Rear Panel Controls

Introduction The following Rear Panel Controls are illustrated in Figure 3-2.

Emergency Stop 
Switch

There is one red Emergency Stop (E-STOP) palm switch located on the left-hand 
side on the back of the system. The entire system is shutdown when an E-STOP 
is pressed. If the emergency situation is not cleared, the uninterruptible power 
supply (UPS) will begin a controlled computer shutdown. Refer to Chapter titled- 
System Components for a detailed description on the UPS.

Air Regulator and Filter The Air Regulator/Filter controls the incoming air pressure. XyflexPro works with 
a recommended 80 PSI (5.6 kgf/ccm2). To adjust the pressure pull up on the black 
adjustment knob until it “snaps”. Rotate the knob clockwise to increase the inlet 
air pressure or counterclockwise to decrease the inlet air pressure. When the 
desired pressure is shown on the gauge, push the black adjustment knob down 
until it snaps into place. This locks in the current setting.

Figure 3-2

Air Regulator
and Filter

A/C Power
Cord

E-Stop

Pneumatic Dump
Valve

Upstream and Downstream

Light Tower

SMEMA Connections
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Light Tower
Light Tower 

Introduction
The light tower (located on the top of the system, see Figure 3-2) features 
different colored lights which are used as visual indicators to identify the 
system’s operating status.

Light Indicators Blue Light (CE systems) - Flashes when operator attention is needed, such as a 
material low condition. This light can be On with the amber and/or green lights.

Red Light (Non-CE systems) - Flashes when operator attention is needed, such as 
a material low condition. This light can be On with the amber and/or green lights.

Amber Light - Flashes when the safety door is open or there is a system error 
such as a motion control error.

Green Light - On constantly while the system is dispensing. Flashes when idle. 
Will not go On if Amber light is On.

Trackball

Introduction The XyflexPro system uses a trackball pointing device to provide easy access to 
menu controls, software loading, and PC operation. It is used extensively in 
programming and running process programs.

Controls Ball - The ball controls cursor movement. 

Left Button - The left trackball button is used to execute commands, to make 
menu and dialog selections, and to select entries.

Right Button - The right trackball button is used to bring up a secondary dialog 
window that will be used to: Select a head to move, a camera, or perform a 
process program offset or close boxes.

The right button is also used to lock an axis (X or Y) for precise placement. This is 
accomplished by pressing the right button while moving the head. The axis which 
has moved the least is zeroed to the coordinate of the previous command.
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Startup And Shutdown

Overview

Introduction This chapter details the procedures for routine start-up and shutdown of the 
XyflexPro system. A procedure is included on how to recover from a power 
failure or E-STOP condition. A brief description is also included of daily 
maintenance and cleanup prior to shutting down the system.

The operator should be familiar with the location and function of all system 
operating controls before attempting to startup or operate the system. See 
Chapter titled - Controls and Indicators for further information.

Attention
When performing any procedure in this section, the command word “Select” 
refers to the operator to use the trackball and click the left button.

In This Chapter This chapter contains the following topics.

Topic Page

Overview 4-1

System Startup 4-2

Safety Door Lock/Unlock 4-6

System Shutdown 4-7

E-Stop And Recovery 4-10

Routine Maintenance 4-11
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System Startup
System Startup

Introduction Routine start-up of the XyflexPro system involves a combination of mechanical 
and software tasks.

Equipment Starts Automatically
Use extreme caution if the system is reset without a full Power Down. Motion 
from the Lift Chuck and Edge Clamping can result during a partial system reset. 

Refer to section titled - System Shutdown for a complete procedure on Powering 
Down the System.

Attention
This procedure is for normal system startup of the XyflexPro. It is assumed that 
the system was powered down using the standard shutdown procedure. If the 
blue light on the front panel indicator is flashing, refer to section titled - E-Stop 
and Recovery for instructions on restarting the system.

Procedure The following procedure is for daily system startup:

Check to be sure that the inlet air supply is at least 80 PSI (5.6 kgf/cm2). Adjust 
the air/filter regulator on the back of the XyflexPro if necessary.

Remove any loose articles (clothing, tools, fixtures, etc.) from the work area.

Ensure the safety door is closed and locked.

1. Push the green Machine On push-button (identified by an I)(located on the 
right front panel) to turn On the system. 

2. Open the front door to gain access to the Uninterruptible Power Source 
(UPS) and Computer. See Figure 4-1.
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System Startup
Figure 4-1

3. Press the round Power On push-button (identified by an I) on the front panel 
of the UPS.

4. The computer starts up. If the computer does not start up, press the 
Power On push-button located on the front of the computer to turn it On.

The computer goes through a standard boot sequence and eventually a screen 
prompt appears:

5. Press Ctrl + Alt + Delete keyboard keys together when prompted. A login 
window appears.

Attention
All users must be assigned a user name and password in order to access the 
Benchmark software. If you are unable to login, see your system administrator.

6. Type your user name and password and press Enter. The Benchmark Main 
screen will appear. See Figure 4-2.

UPS Power ON/OFF
Push buttons

Computer Power ON/OFF
Push button
XyflexPro Operation And Programming Guide, Benchmark 4.2 4-3



4
STA RTUP  AND  S HUTDOWN

System Startup
Figure 4-2

7. Select File >Connection. The Connection dialog box appears. See Figure 4-
3.

Figure 4-3

8. Select the following: Connect as Local - Master radio button and the Enable 
automatic connection during startup box.

9. Select OK.
The Initialize screen appears. See Figure 4-4.
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System Startup
Figure 4-4

10. Select the Initialize button.
If the XyflexPro system is equipped with a weight scale and is enabled, the 
Replace Weight Scale cups(s) message screen appears. See Figure 4-5.

This message only appears once, until the system is shutdown and restarted.

Figure 4-5

11. Unlock the safety door and remove and replace the purge cups at each head 
as described on the on screen message.

12. When all the purge cups have been replaced and the safety door is down and 
locked, press the Finish button.

The system will continue its normal initialization process and will also zero out the 
weight scale automatically. When the system has finished its initialization the 
XyflexPro is now ready for operation.
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Safety Door Lock/Unlock 

Introduction In order to gain access to the dispensing area it is necessary to deactivate the 
safety door lock. The XyflexPro door lock is operated from the padlock icon 
located on the Main toolbar. 

Additionally, the safety door has an access hole to insert a tool to open the door 
manually in case of a power failure.

Door Lock/Unlock Icon When the system is running and you need access to the dispense area, select the 
padlock from the Main toolbar. This will Lock or Unlock the safety door. See 
Figure 4-6.

Figure 4-6

Unlocking the Safety 
Door Manually

The safety door may be opened manually in case a power failure or during initial 
installation of the system.

Open the safety door manually as follows:

1. Insert the tapered end of the manual release tool into the access hole in the 
right side of the safety door. See Figure 4-7.

Figure 4-7

2. Push the tool straight in until the end engages the lock mechanism.
3. While lifting the door, move the tool straight down until the lock releases.
4. Raise the safety door.

Safety Door Lock/Unlock icon

Main Toolbar

Door Release Tool
Door Latch

Access Hole
in Safety Door

right side view
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System Shutdown
System Shutdown

System Disconnect The following procedure is for normal daily shut down:

1. Make sure safety door is closed and locked.
2. Select File>Disconnect from the Machine screen.

The CAMALOT BENCHMARK screen will appear with the word Disconnected at 
the top right-hand side of the screen. See Figure 4-8. 

Figure 4-8

Attention
The operator has a choice at this point either to leave the system alone (idle) at 
this screen for the next operator or to continue powering down the system. Refer 
to section titled - Powering Down the System.

Powering Down the 
System

This procedure assumes the system has already been Disconnected, with the 
CAMALOT BENCHMARK on the screen. See Figure 4-8. 

Power down the system as follows:

1. Exit the Benchmark software by clicking on the X in the upper right-hand 
corner of the screen.

2. Select the Windows NT® Start menu (located in the lower left-hand corner).
3. Select Shut Down from the menu.
4. Select Shut down the computer? radio button from the list. See Figure 4-9.
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System Shutdown
Figure 4-9

Equipment Starts Automatically
If the computer is reset without having fully powered down the machine, motion 
from the Lift Chuck and Edge Clamping can result.

Follow the complete System Shutdown procedure to avoid this condition.

Select the Yes button and wait for the message: It is now safe to turn off your 
computer. If Restart is selected, the computer will not get powered down. See 
Figure 4-10.

Figure 4-10

5. Press the white MACHINE OFF push button on the right front panel. See Fig-
ure 4-11.

6. Turn Off the UPS with the round Push button. See Figure 4-1.
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System Shutdown
Figure 4-11

Machine ON

Machine OFF

Reset

E-Stop

Main Power Switch
(Lockout/Tagout)

Syringe Air Pressure
Gauge and Adjustment
Knob
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E-Stop And Recovery
E-Stop And Recovery

Introduction There are three red E-STOP palm switches located on the XyflexPro system. Two 
on the front and one in the rear. When any one of the palm switches is pressed, 
or a power failure occurs, all electrical power and pneumatic pressure is 
terminated with the exception of the XyflexPro computer which is automatically 
switched over to the UPS’s battery power. 

Attention
If the UPS is not turned off, the battery will gradually discharge until normal 
system power is restored.

In the event that the XyflexPro is powered down with an E-STOP switch, you 
need to log out, shut down the computer and the UPS system. Refer to section 
titled - System Shutdown.

The blue light indicator on the front panel will be flashing following an E-STOP 
occurrence or power failure.

Recovery Procedure To restart the XyflexPro after a power failure or E-STOP occurrence:

1. Turn the E-STOP switch clockwise while pulling it out.
(If E-STOP was used.)

2. Press the blue Reset button on the right front system panel. See Figure 4-11.
3. Startup the XyflexPro normally. Refer to section titled - System Startup.
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Routine Maintenance

Dispense Units Prior to shutting down the system, you should clean the dispense material that 
may have spilled or leaked onto the system according to the applicable MSDS 
sheet. Remove all loose tooling and dispense units. Refer to the appropriate 
dispense unit option for the proper daily cleaning procedure.

Chemical Hazard
Be sure the applicable Material Safety Data Sheet (MSDS) Warnings are 
observed.

Conveyor Rails Once a month apply a thin coat of Rust Preventive to all slide rails. Refer to 
Chapter titled - Preventive Maintenance.
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Routine Maintenance
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Heated Chucks

Overview

Introduction Conveyor hard stops are used on XyflexPro models configured for semiconductor 
and SMT applications. Systems configured to SMT applications will have the 
sensor attached to the hardstop. Systems configured to semiconductor 
applications will have the sensor(s) mounted on the rear conveyor rail. 

The hard stops are adjustable from front to back on a slide mounted on the base 
plate. The stop is positioned between the conveyor rails and is mounted on the 
slide at the extreme right in the dispense zone. The sensor reacts to the leading 
edge of the board as it passes by the sensor, this slows the conveyor belt down. 

Heated chucks are an option used to heat the substrate to a set temperature. The 
chuck heat is set and maintained using system software which is set through the 
Temp Control screen. The software monitors the temperature and will trigger an 
Alarm condition when the temperature either drops below or goes above the set 
temperature range. Heated chucks may be placed and used at Predispense, 
Dispense, and Postdispense stations.

Equipment Starts Automatically
Use extreme care when working around Conveyor Hard Stops, Lift Chucks, and 
Edge clamps. These components will cycle if the system was partially reset 
during system shutdown.

Refer to Chapter titled - Startup And Shutdown for a complete procedure on 
Powering Down the system properly to avoid this condition.

Attention
When performing any procedure in this section, the command word “Select” 
refers to clicking the left trackball button.
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Overview
In This Chapter This chapter contains the following topics.

Topic Page

Overview 5-1

Adjusting Conveyor Hard Stops 5-3

Adjusting Conveyor Width 5-4

Setting Conveyor Speed 5-5

Loading Boards Onto The Conveyor 5-5

Setting The Heated Chuck Temperature 5-7
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Adjusting Conveyor Hard Stops
Adjusting Conveyor Hard Stops

Procedure Adjust the conveyor hard stops as follows:

1. Loosen the socket head cap screw and position stop along the slide. Position 
stop so that the board does not become skewed when conveyor is in motion. 
See Figure 5-1.

2. Tighten the cap screw after the stop is set at the desired location between 
the front and rear conveyor rails. See Figure 5-1. 

Figure 5-2 shows a typical board sensor mounted on the conveyor rear rail.

Figure 5-1

Figure 5-2

 Slide (front to back)

Socket Head
Cap Screw

Typical Board Sensor
(viewed from the rear)

Conveyor Rear Rail
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Adjusting Conveyor Width
Adjusting Conveyor Width 

Procedure The conveyor width can be adjusted to handle different board sizes. Adjust 
conveyor rail width to match the process board width as follows:

1. Select View > Diagnostics or select the Diagnostics  icon. 

Select the Conveyor Maintenance tab. See Figure 5-3.

Figure 5-3

2. Place the process board onto the conveyor belts. Determine whether or not 
the conveyor rail width needs to be adjusted to match the process board 
width.

3. Select the Jog Increment field. Enter a value that will jog the rear rail either 
open or close.

4. Press the Jog button until the conveyor width opening matches the process 
board width.

5. Select the Close button to close the Diagnostics screen. 
The conveyor rail width is now set.
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Setting Conveyor Speed

Introduction Setting the Conveyor Speed is part of the system calibration, refer to Chapter 
titled - Calibration and Offsets for this procedure and more detailed information.

Loading Boards Onto The Conveyor

Conveyor Modes There are three modes of conveyor operation - Off, Automatic, and Pass Through.

When the Off mode is selected, the conveyors do not operate. A dispense 
program can be created and fiducials taught without concern of boards being 
moved through the system.

When the Automatic mode is selected, a loaded process program can be 
dispensed. This mode is used when the XyflexPro machine is operating in a 
production process.

When the Pass Through mode is selected, a board enters the system and moves 
to the predispense or dispense position where the board stop sensor is made. The 
board briefly remains at this position until the Upstream Board Available signal is 
received. The board then exits the machine as another board enters the system. 
The process of boards entering and exiting the system is continuously repeated 
as long as the Pass Through Mode is selected. This mode is used when the 
XyflexPro system has no function in the overall production process. The boards 
are ignored by the system and pass through to the downstream system.

Procedure Load boards onto the conveyor as follows:

1. Select Operations>Conveyor Mode>Automatic from the Machine screen. 
See Figure 5-4. 

2. The conveyor mode may also be selected as follows:
a. Move cursor from the Machine screen down to the Conveyor Status win-

dow, located in the lower right-hand corner of the screen. See Figure 5-5.
b. Click the right button on the trackball and a pop-up list of conveyor modes 

will appear.
c. Click the left or right button to select the Automatic mode.
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Loading Boards Onto The Conveyor
Figure 5-4

Figure 5-5

 3. Select View > Diagnostics or select the Diagnostics

 icon from the Machine screen.

4. Select the Conveyor Maintenance tab. See Figure 5-3.
5. Select the Heads to which you want to load boards by placing a check in the 

Hold/Release Board list box 	 . 
6. Place a board onto the conveyor upstream of Head 1 so that the upstream 

(input) sensor is made.
7. Select Upstream Board Available from the Conveyor Message To Send list 

box.

Attention
The Motor On button may be pressed at any time to activate the conveyor. This 
is normally used to clear a board from within the machine.

8. Select the Send Message button.
The board will enter the system and be clamped at the dispense station.
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Setting The Heated Chuck Temperature

Introduction Temperature controls are used to set and regulate heated chuck temperature 
using system software. There is no physical push button for the temperature 
controllers located on the front of the system.

Go to the Machine screen, place the cursor over to the TEMP CONTROLLER 
button shown on the right front panel of the machine. This button either turns the 
power ON or OFF to all of the temperature controllers. See Figure 5-6.

Figure 5-6

The button will be colored Green if the POWER is ON to all of the temperature 
controllers.

The button will be colored Red if the POWER is OFF to all of the temperature 
controllers.

To change the temperature controllers condition, place cursor on the Temp 
Controller button and click the left button on the trackball. The button will change 
color according to the desired condition.

Temperature Controller 
(only visible through 

system software)
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Setting The Heated Chuck Temperature
Procedure Set the temperature for each heated chuck as follows:

1. Select View>Configuration>Temperature tab from the Machine screen. 
Each heated chuck temperature is set from this screen. See Figure 5-7.

Figure 5-7

2. Select the arrow next to the Controllers drop down box. Scroll down the list 
until the desired chuck appears. Select the chuck.

3. Check the Enable Communications box	 to supply heat to chuck in the Con-
trollers field. 

If the Enable Communications box is blank, the chuck selected in the Controllers 
field is disabled.

4. Select the Setpoint field. Using the keyboard enter the desired temperature.
5. Select the Alarm Range field. Using the keyboard enter the desired tempera-

ture deviation from Setpoint field to alert an Alarm Condition.
6. Select the OK button.
7. Repeat step 2 through step 6 for the remaining heated chucks.
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Setting The Heated Chuck Temperature
Heated Chuck Alarm 
Condition

The Alarm Info field displays a color coded box under the Alarm Status. The color 
indicates the condition of the chuck. If an Alarm condition occurs, review the 
table below and troubleshoot accordingly. 

The following is a chart indicating a Color Display and Message indicating what 
caused the Alarm Condition.

To clear an alarm condition, refer to Chapter titled - Alarms and Troubleshooting.

Color Display Message

Black Controller disabled

Black Power is off

Black Communication failure

Green In temperature range

Yellow Ramping up to operating temperature

Red Out of temperature range
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Setting The Heated Chuck Temperature
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Overview

Introduction This chapter contains several calibration and offset procedures which are required 
prior to a running a process program. The various calibrations are not always 
required every time the machine is ready to run a process program. Read each 
calibration description to determine when the procedure should be performed.

Attention
Only those individuals assigned privileges are allowed to perform or change 
system calibrations and offsets. Refer to Chapter titled - System Administration 
and Security.

Attention
When performing any calibration procedure in this section, the command word 
“Select” refers to placing the pointer on an object and clicking the left trackball 
button.

In This Chapter This chapter contains the following topics.

Topic Page
Overview 6-1

Camera Calibration 6-3

Manual Calibration Of Camera-To-Needle Offset 6-8

Calibration Of Camera-To-Needle Offset (Automatic) 6-16

Setting Dispense Head Park Position 6-18

Teaching The Fixture Position (Offset) 6-19

Setup Of The Pre-Dispense Station 6-21

Teaching The Camera-To-Zsense Offset 6-25

Setting The Location Of The Weight Scale (Option) 6-29
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Overview
Teaching The Needle Calibrator Sensor Position 6-33

Conveyor Speed Calibration 6-35

Teaching The Purge Cup Position 6-37

Teaching The Syringe/DU Change Position 6-41

Topic Page
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Camera Calibration
Camera Calibration

Introduction Camera Calibration is used to teach the system the relationship between the 
camera’s measurement of distance and actual physical movement of the dispense 
unit. The camera uses individual picture elements called pixels to measure size 
and distance.

Accurate Camera Calibration is essential in order for the vision system to:

• Accurately compensate for misaligned programs.
• Provide the operator with an accurate view of the exact dispense location.

Camera Calibration is required during initial installation. This process does not 
need to be repeated unless the camera position or focal length is altered.

Procedure

Attention
Selecting the Cancel button at any point aborts the procedure.

Perform the Camera Calibration as follows:

1. Be sure that the safety door is closed and locked.
2. Select Calibrate>Camera.

The Camera Calibration screen appears. See Figure 6-1.

Figure 6-1
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Camera Calibration
3. Read the on-screen notes regarding the calibration and select the Next> 
button.
A selection box appears within the Camera Calibration screen.
See Figure 6-2.

Figure 6-2

4. Select Head 1 in the selection box, and select the Next> button.
A vision window appears in the Camera Calibration screen.
See Figure 6-3.

Figure 6-3

Model Size

Search Area
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Camera Calibration
5. Select the Trackball button.
6. Using the trackball, move the crosshairs in the Vision window to the center 

of a unique reference mark on the board such as a fiducial mark. Be sure that 
the reference mark is in focus and has proper illumination. This determines 
the quality of the image.

7. If necessary, adjust the camera focus and lighting to desired settings as fol-
lows:
a. Select the Camera Settings button. The Camera Settings screen appears.

See Figure 6-4.
b. Adjust the Zoom, Brightness, and Contrast as desired by selecting the 

applicable up or down arrow for each field.
c. After desired settings are complete, select the Close button. 

Figure 6-4

8. If necessary, adjust the Model Size and/or Search Areas as follows.
See Figure 6-3.

Attention
The Model Size and Search areas are represented in the vision window by green 
bounding boxes. The bounding boxes have square handles at each corner which 
are used to resize them.

a. Place the pointer on any one of the square handles at the corners of the 
bounding box.

b. Click on a handle (a double headed arrow appears).
c. Using the trackball change the size of the box to properly surround the ref-

erence mark.
d. Click the left trackball button to accept the change.

9. Select the Next> button.
The system attempts the Camera Calibration with the above information.
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Camera Calibration
Calibration Successful If the Camera Calibration was a Success, the Camera Calibration screen displays 
a “successful” message, a new set of scale factors, and how many degrees the 
camera is inclined from zero.
See Figure 6-5.

If the Camera Calibration encountered an error, an error message and vision 
window are displayed.

Refer to the section titled - Calibration Error.

Figure 6-5

Select the Save button to accept the X/Y pixel count.

The saved pixel count replaces the previously stored values in the database.

You are returned to the Machine screen.
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Calibration Error If a calibration error occurs, an error message and a vision window are displayed 
in the Camera Calibration screen. See Figure 6-6.

Figure 6-6

Select the Cancel button and repeat the Camera Calibration procedure.

Check the following prior to repeating the calibration.

• Loose camera mounting
• Loose Lens
• Benchmark Server
• Vision Processor
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Manual Calibration Of Camera-To-Needle Offset

Introduction In order for the software to determine the distance (offset) between the camera 
and the dispense needle, the Camera-to-Needle Offset must be taught.
The Camera-To-Needle Offset must be taught whenever the needle or dispensing 
unit is moved or changed.

During the calibration, three test dots are dispensed on the dispense pad or some 
other user taught location. The center of the middle dot is used by the vision 
system to establish the offset.

The Manual procedure is used when dispensing parameters or the dispense 
process is changed.

Head Selection And 
Dispense Properties

Calibrate the Camera-to-Needle Offset for each needle as follows:

Attention
Selecting the Cancel button at any point aborts the process.

1. Select Calibrate>Camera-to-Needle Offset or select the Camera-to-Needle 

Offset icon  (if enabled) on the Machine toolbar.

Attention
If the Camera-to-Needle Offset icon does not appear on the Configurable toolbar, 
refer to chapter titled - Toolbars And The Process Program Grid, for a detailed 
procedure on enabling and arranging buttons.

The Camera-to-Needle Offset screen appears. See Figure 6-7. 
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Manual Calibration Of Camera-To-Needle Offset
Figure 6-7

2. Read the on-screen notes and select the Next> button.
A selection box is displayed in the Camera-to-Needle Offset screen.
See Figure 6-8.

Figure 6-8

3. Select the Head you wish to calibrate from the list or select the check box 
below the list if you want to cycle through all heads consecutively.
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Manual Calibration Of Camera-To-Needle Offset
4. Select the Next> button.
Two buttons are displayed in the Camera-to-Needle Offset screen.
You have the choice of dispensing test dots on the dispense pad or at a 
taught location of your own choosing. See Figure 6-9.

Figure 6-9

5. If you want to use another location, see the section titled - Teaching An 
Alternate Test Dot Location; Otherwise select the Use dispense pad button.

6. Select the Next> button.
A group of dispense properties fields is displayed in the Camera-to-Needle 
Offset screen as shown in Figure 6-10.

Figure 6-10
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Manual Calibration Of Camera-To-Needle Offset
7. Adjust the dispense properties values for the Dot Size, Lift Height, Dispense 
Height (0 if using a footed needle), Dot Dwell, and RPM if desired.

8. Verify the modified dispense properties by selecting the Dispense a Test Dot 
button.

9. Repeat steps 7-8 until the test dot is acceptable.
10. Select the Next> button.

The Dispensing Test Dot screen appears. See Figure 6-11.
The test dot dispense location must be clean in order for the vision system to 
properly evaluate the camera image. If the test dot area needs cleaning, fol-
low the on-screen instructions before proceeding.

Figure 6-11

11. Proceed to the next section titled - Performing The Calibration.
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Performing The 
Calibration

Perform all steps as outlined in the previous section titled - Head Selection And 
Dispense Properties.

1. From the Dispensing Test Dot screen, select the Next> button to start the 
calibration.
The needle height is calibrated, and three test dots are dispensed at the dis-
pense pad or user taught location. The vision system then attempts to find 
the center dot.

2. Refer to the sections titled - Calibration Successful or Calibration Error.

Calibration Successful If the calibration was successful, a vision window is displayed with the camera 
crosshairs centered over the reference mark. See Figure 6-12.

Figure 6-12

1. Select the Next> button to display the newly calculated X and Y Camera-to-
Needle Offset values. See Figure 6-13.

2. Select the Save button to accept the new calibration coordinates.
You are returned to the Machine screen.
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Manual Calibration Of Camera-To-Needle Offset
Figure 6-13
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Manual Calibration Of Camera-To-Needle Offset
Calibration Error If a calibration error occurs, the Camera-to-Needle Offset screen displays an error 
message and a vision window. See Figure 6-14.

Figure 6-14

The following procedure will allow you to manually locate the center test dot:

1. Select the Find Dot Manually button.
Camera Settings and Trackball buttons are displayed in the Camera-to-Nee-
dle Offset screen. See Figure 6-15.

Figure 6-15

2. Select the Trackball button and align the crosshairs in the vision window 
over the center of the middle dot.

3. When the crosshairs are properly aligned, click the left trackball button.
This teaches the X and Y coordinates.

4. Select the Save button.
You are returned to the Machine screen.
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Teaching An Alternate 
Test Dot Location

The following procedure is used to teach an alternate location for dispensing the 
test dots during the Camera-to-Needle Offset calibration.

1. Select the Use other location radio button from the Camera-to-Needle Offset 
screen. See Figure 6-9.
A vision window appears in the Camera-to-Needle Offset screen.

2. Select the Trackball button.
3. Position the camera crosshairs over the desired location.
4. When the crosshairs are positioned correctly, click the left trackball button.

This teaches the X and Y coordinate.

5. Select the Next> button.
The test dot dispensing parameters are displayed in the Camera-to-Needle Offset 
screen.
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Calibration Of Camera-To-Needle Offset (Automatic)

Introduction In order for the software to determine the distance (offset) between the camera 
and the dispense needle, the Camera-to-Needle Offset must be taught. Camera-
To-Needle Offset must be taught whenever the needle or dispensing unit is 
moved or changed.
The Automatic Camera-to-Needle Offset procedure is used when the established 
dispense properties are known to be acceptable. This version saves setup time by 
eliminating the need to set the parameters for the dispensed dot. The Automatic 
Calibration uses default settings for dispensing the three test dots onto the 
dispense pad.

If your test dispense dot requires the parameters to be adjusted, refer to section 
titled - Manual Calibration of Camera-to-Needle Offset.

Procedure 1. Select Calibrate>Camera-to-Needle Offset Auto or select the Camera-to-
Needle Offset Automatic icon  on the Machine toolbar. 

The Camera-to-Needle Offset screen appears. See Figure 6-16.
2. The test dot dispense location must be clean in order for the vision system to 

properly evaluate the camera image. If the test dot area needs cleaning, 
select the Clean Dispense Location button and follow the on-screen instruc-
tions.

Figure 6-16

3. Select the Next> button to perform the calibration.
A vision window is displayed briefly while the vision system is aligning with 
the test dot. See Figure 6-17.
If the calibration is successful, you are returned to the Machine screen.
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Calibration Of Camera-To-Needle Offset (Automatic)
Figure 6-17

If the calibration encountered an error, refer to section titled - Calibration Error.
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6
CA LI BR A TI ON  AND  O FFS ETS

Setting Dispense Head Park Position
Setting Dispense Head Park Position

Introduction Setting the Dispense Head Park Position allows the dispense head to move to a 
“park” position at the end of a dispense cycle. This increases throughput by 
allowing a park position which is in close proximity to the next dispense 
operation. The Park position is taught in the Properties screen. See Figure 6-18.

Figure 6-18

Procedure

1. Create or load a process program.
2. Navigate to the Properties screen:
• Select the Next> button when creating a new program.
• Select the Properties tab from the Process Program Grid within a loaded pro-

gram.

The Properties screen appears. See Figure 6-18.

3. Select a head from the Select Head field.
4. Select a Dispense Unit from the Dispense Unit Type field.
5. Select the Trackball XY button, the vision window appears next to the prop-

erties screen.
6. Using the trackball, position the cross-hairs to the desired position and click 

the left trackball button to teach this coordinate.
If the Use default park position box is checked, the system automatically 
places the park position at the default setting for the Head chosen in step 3.

7. Select the Save button.
8. Select the Close button.

The system returns to the Machine screen.
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Teaching Fixture Position Offset

Introduction In order for the software to know the distance (offset) between the camera and 
the fixture (process board), the fixture position must be taught.  This procedure is 
done during initial setup and only needs to be performed if the hardstop or sensor 
is moved.  The following procedure is used to teach the fixture position for each 
dispensing head.

Procedure Teach the Fixture Position as follows:

1. Load a board onto the conveyor into the dispense zone.
2. Select View>Diagnostics

The Diagnostics screen appears.
3. Select the Motion Control tab.

The Motion Control screen appears. See Figure 6-19.

Figure 6-19

4. Select Head 1 from the Moveable Part field.
5. Select Fixture Position from the Set Commanded Position field.
6. Select the Trackball X and Y button. A vision window with a set of 

crosshairs appears. The trackball is active at this point.

Attention
The X and Y coordinates are shown in the Actual Position column and change 
when the head is moved using the trackball.
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Teaching Fixture Position Offset
7. Using the trackball, align the intersection of the crosshairs with the front-
right corner of the clamped board. See Figure 6-20.

Figure 6-20

8. When the crosshairs are aligned properly, click the left button on the track-
ball (this teaches the X/Y coordinate).

9. If further adjustment is required, select the Trackball button in the vision win-
dow and repeat steps 6-8.

10. Select the Close button in the vision window.
11. Select the Save Actual Position as Commanded Position button.

The new Fixture Position is stored with the program.
12. Select the Close button to close the Diagnostics screen.

Vision Crosshairs
(Front-right corner)

Leading edge of board
against Hard Stop
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Setup Of The Pre-Dispense Station

Introduction The Pre-Dispense Station may contain one or more ceramic dispense plates. The 
coordinates of the left-hand plate and the coordinates of the right-hand plate 
must be taught to give the system software a starting point.

The setting of the X/Y coordinates for the Pre-Dispense station are normally only 
required on initial setup or whenever the Pre-Dispense station is moved.

Procedure Setup the Pre-Dispense Station as follows:

1. Select Calibrate>Pre-Dispense Plate(s).
The Pre-dispense plate calibration screen appears as shown in Figure 6-21.

Figure 6-21

2. Read the on-screen notes and select the Next> button
3. Using the keyboard, enter the number of dispense plates (1 or 2) in the box 

provided.
4. Select the Next> button.

A vision window appears in the Pre-dispense plate calibration screen.
See Figure 6-22.
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Setup Of The Pre-Dispense Station
Figure 6-22

Attention
The starting point for the Pre-Dispense Station is always set on the Back-Left 
corner of plate 1. See Figure 6-24.

5. If necessary, adjust the camera focus and lighting to desired settings as fol-
lows:
a. Select the Camera Settings button.

The Camera Settings screen appears. See Figure 6-23.

Figure 6-23

b. Adjust the Zoom, Brightness, and Contrast as desired by selecting the 
applicable up or down arrow for each field. After desired settings are com-
plete, select the Close button.
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Setup Of The Pre-Dispense Station
6. Select the Trackball button.
7. Using the trackball, move the crosshairs to a position near the Back- Left cor-

ner of plate 1. The crosshairs must be on the plate as shown in Figure 6-24.
8. Click the left trackball button to teach this point. If further adjustment is 

required, select the Trackball button and repeat step 6 and 7.

Figure 6-24

9. Select the Next> button.
10. Using the trackball, move the crosshairs to a position near the Front- Right 

corner of plate 1. The crosshairs must be on the plate as shown in Figure 6-
24.

11. Click the left trackball button to teach this point. If further adjustment is 
required, select the Trackball button and repeat step 10.

12. Select the Next> button.
13. Using the trackball, move the crosshairs to a position near the Back-Left cor-

ner of plate 2. Click left to teach this point. This point must be on the plate. 
See Figure 6-24.

14. If further adjustment is required, select the Trackball button and repeat step 
13.

15. Select the Next> button.
The current and newly calculated Pre-dispense coordinates are shown in the 
Pre-dispense plate calibration screen. See Figure 6-25.

16. Select the Save button to accept the new Pre-dispense coordinates. 
You are returned to the Machine screen.

Plate 1 Plate 2

Placement of Back Left
X-Y coordinate

Placement of Front Right
X-Y coordinate

Pre-Dispense Station (configured left to right)

Placement of Back Left
X-Y coordinate
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Setup Of The Pre-Dispense Station
Figure 6-25
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Teaching The Camera-To-ZSense Offset

Introduction In order for ZSense program commands to be executed at the correct board 
location, an offset must be taught between the camera and the sensing device 
(touch probe or laser). This procedure is completed during initial setup and only 
needs to be performed if the Camera or ZSense (touch probe) is removed.

Camera-to-ZSense 
Offset

Teach the Camera-to-ZSense offset as follows:

1. Load a sample board at the dispense position on the conveyor.
2. Select Calibrate>Camera-to-ZSense Offset.

The Camera-to-ZSense Offset screen appears. See Figure 6-26.

Figure 6-26

3. Read the on-screen notes, and select the Next> button.
4. A vision window appears in the Camera-to-ZSense Offset screen.

See Figure 6-27.
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Teaching The Camera-To-ZSense Offset
Figure 6-27

5. If necessary, adjust the camera focus and lighting to the desired settings as 
follows:
a. Select the Camera Settings button. The Camera Settings screen appears. 

See Figure 6-28.

Figure 6-28

b. Adjust the Zoom, Brightness, and Contrast as desired by selecting the 
applicable up or down arrow for each field. After the desired settings are 
complete, select the Close button.
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Teaching The Camera-To-ZSense Offset
6. Select the Trackball button.
7. Using the trackball, center the crosshairs over a reference mark such as a 

fiducial on the sample board.
8. Click the left trackball button when the crosshairs are properly positioned.
9. If further adjustment is required, select the Trackball button and repeat steps 

6 and 7.

Equipment Starts Automatically
When the Next> button is selected the head moves over and fires the ZSense 
device. The safety door must be closed otherwise the head will not move. 

10. Select the Next> button.
The system attempts to align the ZSense with the reference point you estab-
lished in step 7.

11. If the Zsense is not aligned properly with the reference mark:
a. Select the Trackball button in the Camera-to-ZSense Offset screen. See 

Figure 6-29.

Figure 6-29

b. Using the trackball, visually align the ZSense with the reference point.
c. Click the left trackball button.

12. Select the Next> button after the correct the ZSense location is taught.
The current and newly calculated offset values are displayed in the Camera-
to-ZSense Offset screen. See Figure 6-30.

13. Select the Save button to accept the new calibration offset. 
You are returned to the Main screen.
XyflexPro Operation And Programming Guide, Benchmark 4.2 6-27



6
CA LI BR A TI ON  AND  O FFS ETS

Teaching The Camera-To-ZSense Offset
Figure 6-30
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Setting The Location Of The Weight Scale (Option)

Introduction The Weight Scale option incorporates a sliding glass cover. The cover is used to 
prevent drafts or other air currents from disturbing the pan and measurements. 
The cover has a hole cut through it which allows the dispense unit to dispense 
onto the scale. The location of this hole must be taught in the 
X, Y, and Z- axes.

The taught position settings are normally required only on initial setup or 
whenever the weight scale assembly is moved.

Procedure

Attention
Selecting the Cancel button at any point aborts the procedure.

Teach the hole position of the Weight Scale as follows:

1. Select Calibrate>Weight Scale Position.
The Weight scale(s) calibration screen appears. See Figure 6-31.

Figure 6-31
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Setting The Location Of The Weight Scale (Option)
2. Read the on-screen notes, and select the Next> button.
Trackball and TrackballZ buttons are displayed in the Weight scale(s) calibra-
tion screen. See Figure 6-32.

Figure 6-32

Attention
Prior to teaching any coordinates for the Weight Scale, be sure the sliding glass 
cover is in the closed position.

3. Select the Trackball button. 
4. Using the trackball, move the dispense unit over the sliding glass cover. The 

needle tip should be positioned over the center of the hole.
See Figure 6-33.

Figure 6-33
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Setting The Location Of The Weight Scale (Option)
5. When the needle tip is in the desired location click the left trackball button.
6. Select the Trackball Z button. Using the trackball, lower the needle of the 

dispense unit through the hole in the sliding glass cover until the needle is 
below the top surface of the sliding glass. See Figure 6-34.

Figure 6-34

7. Click the left trackball button.
8. Select the Next> button in the Weight scale(s) calibration screen.

The current and newly calibrated locations are displayed in the Weight 
scale(s) calibration screen. See Figure 6-35.
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Setting The Location Of The Weight Scale (Option)
Figure 6-35

9. Select the Save button to accept the new calibration coordinates.
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Teaching The Needle Calibrator Sensor Position
Teaching The Needle Calibrator Sensor Position

Introduction The Needle Calibrator Sensor position must be taught to identify its location.

This procedure is done during initial setup and only needs to be performed if a 
needle is changed.

Procedure Teach the Needle Calibrator Sensor Position as follows:

1. Select View>Diagnostics.
2. Select the Motion Control tab from the Machine screen.

The Motion Control screen appears. See Figure 6-36.

Figure 6-36

3. At the Moveable Part drop down list, select the head you wish to teach.
4. In the Set Commanded Position field, select Needle Calibrator Sensor Posi-

tion.
5. Select the Trackball X and Y button.

A vision window with a set of crosshairs appears and the trackball is acti-
vated.
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Teaching The Needle Calibrator Sensor Position
6. Using the trackball, move the head until the intersection of the crosshairs is 
aligned over the center of the Needle Calibrator sensor. See Figure 6-37.

Figure 6-37

Attention
As you move the head with the trackball, the current X and Y coordinates are 
updated in the Move To Position field on the Motion Control screen.

7. When the crosshairs are positioned correctly, select the left trackball button. 
8. If further adjustment is required, select the Trackball button in the vision win-

dow and repeat steps 6-7.
9. Select the Close button in the vision window.

10. Select the Save Actual Position as Commanded Position button.
The system saves the new sensor position.

11. Select the Close button to close the Diagnostics screen.
You are returned to the Machine screen.

Crosshairs centered
over sensor

Dispense Pad
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Conveyor Speed Calibration

Introduction The Conveyor Speed Calibration is required to ensure that the conveyor will slow 
down before parts reach a hard stop. The system software calculates the time as 
the board passes each sensor (at all stations) and adjusts the conveyor speed 
automatically.

This calibration is only required at initial setup or when the process board is 
changed.

Procedure Calibrate the Conveyor Speed as follows:

1. Select Operations>Conveyor Mode>Off from the Machine screen.
2. Load a board onto the output sensor of an upstream machine. 

The board waits for the system to give an available signal.

3. Close and lock the safety door(s).
4. Select View>Diagnostics.

The Diagnostics screen appears.
5. Select the Conveyor Maintenance tab.

The Conveyor Maintenance screen appears. See Figure 6-38.

Figure 6-38

6. Select the Start Speed Test message in the Select Conveyor Message To 
Send list box.
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Conveyor Speed Calibration
Attention
The Motor On button may be pressed at any time to activate the conveyor. This 
is normally used to clear a board from within the machine.

7. Select the Send Message button.
After approximately 2 seconds, the board that was placed in the Upstream 
machine is transported through the system and stops at the Downstream 
machine.

8. Select the Close button to close the Diagnostics screen.
You are returned to the Machine screen.
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Teaching The Purge Cup Position

Introduction The Purge Cup position must be taught to identify its location.

This procedure is done during initial setup and only needs to be performed if the 
position is moved.

This position is taught visually by looking into the machine as you drive the 
dispense head to the correct position.

Procedure Teach the Purge Cup Position as follows:

1. Select Calibrate>Purge Cup Position. See Figure 6-39.

Figure 6-39

A list of screen notes appear. See Figure 6-40.

Figure 6-40

2. Read the on screen notes and select the Next> button.
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Teaching The Purge Cup Position
A Head selection box appears. See Figure 6-41. This position must be taught at 
all heads.

Figure 6-41

3. Select the desired Head from the list and select the Next> button.
The purge cup procedure appears with Trackball and Trackball Z buttons. See 
Figure 6-42.

Figure 6-42
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Teaching The Purge Cup Position
Attention
Prior to teaching any coordinates for the Purge Cup, be sure the sliding glass 
cover is in the closed position (if equipped).

4. Select the Trackball button. 
5. Using the trackball, move the dispense unit over the sliding glass cover. The 

needle tip should be positioned over the center of the hole.
See Figure 6-43.

Figure 6-43

6. When the needle tip is in the desired location click the left trackball button.
7. Select the Trackball Z button. 
8. Using the trackball, lower the needle of the dispense unit as necessary to 

contact the cone style purge cup (if equipped) or to a height where you can 
wipe the needle if the flat style purge cup is used.

9. Click the left trackball button.
10. Select the Next> button in the calibration screen.

The current and newly calibrated locations are displayed in the Purge Cup(s) 
calibration screen. See Figure 6-44.
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Teaching The Purge Cup Position
Figure 6-44

11. Select the Save button to accept the new coordinates.
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Teaching The Syringe/DU Change Position

Introduction The position for changing the Syringe/DU is taught to make it convenient for the 
day to day operator to remove and replace hardware.

This procedure is performed at all heads during initial setup and may be changed 
to any desired location. 

This position is taught visually by looking into the machine as you drive the 
dispense head to the desired location.

Procedure Teach the Syringe/DU Change Position as follows:

1. Select Calibrate>Syringe/DU Change Position. See Figure 6-45.

Figure 6-45

A list of screen notes appear. See Figure 6-46.

Figure 6-46

2. Read the on screen notes and select the Next> button.
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Teaching The Syringe/DU Change Position
A Head selection box appears. See Figure 6-47. This position must be taught at 
all heads.

Figure 6-47

3. Select the desired Head from the list and select the Next> button.
The Syringe/DU Change procedure appears with a Trackball button. See Figure 6-
48.

Figure 6-48
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Teaching The Syringe/DU Change Position
4. Select the Trackball button. 

Attention
When moving and removing the dispense unit or syringe be careful not to damage 
the needle. Hold the gantry steady.

5. Using the trackball, move the dispense unit towards the front of the machine 
in a convienent location. Be careful not to place the DU in a location where 
the needle may be damaged.

6. When the DU is in the desired location click the left trackball button.
7. Select the Next> button.

The current and newly calibrated locations are displayed in the Syringe/DU 
Change Position calibration screen. See Figure 6-49.

Figure 6-49

8. Select the Save button to accept the new coordinates.
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Teaching The Syringe/DU Change Position
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Process Program Grid

Overview

Introduction The system utilizes three toolbars. Two on the Machine screen, the Main Machine 
toolbar and the Configurable toolbar. The third toolbar is located on the Process 
Program Grid, and is named the Process Program Commands toolbar. The icons 
contained on each toolbar may be used as alternate methods to perform system 
functions in place of the drop down menu selections (located at the top of the 
screen). The definitions for each icon are explained in this chapter.

The Process Program Grid is a spreadsheet-like display that allows you to specify 
values and/or settings for the many system dispensing commands. The Process 
Program Commands toolbar (located at the top of the grid) is used to insert 
commands into the grid for a process program.

Attention
When performing any procedure in this section, the command word “Select” 
refers to the operator to use the trackball and click the left button.

In This Chapter This chapter contains the following topics.

Topic Page

Overview 7-1

Main Machine Toolbar 7-2

Configurable Toolbar 7-3

Process Program Grid 7-6

Process Program Commands Toolbar 7-6

Process Program Grid Fields 7-11

Block Editing 7-14
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Main Machine Toolbar
Main Machine Toolbar

Introduction The Main Machine toolbar is always visible at the top of the screen and is used to 
navigate through various software screens. 

Toolbar Icons The icons shown below will be observed and are functionally described as 
follows:

Machine Screen-
Select to view the Main Machine screen.

Return To-
Select to return to the previous software screen.

Process Programs-
Select to Load, Name, Create a New, Edit, Save As, 
Rename, or Delete process programs.

Fiducials-
Select to Load, Name, Create a New, Edit, Save As, 
Rename, or Delete fiducial templates.

Templates-
Select to Load, Name, Create a New, Edit, Save As, 
Rename, or Delete system templates.

Door Lock / Unlock-
Select to Lock or Unlock the safety door.
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Configurable Toolbar
Configurable Toolbar

Introduction The large icons contained in the Configurable toolbar are used to perform various 
system operations. This toolbar is only displayed on the Main Machine screen. 

The icons may be arranged in a different order or not displayed at all. This is 
accomplished by selecting View > Configuration. At the Configuration screen, 
select the Buttons tab. See Figure 7-1.

Figure 7-1

The Buttons tab allows the user to display the Configurable Toolbar icons and 
arrange icons as desired.

Displaying Icons Display the toolbar icon(s) as follows:

1. Select the button(s) to be displayed and select the Add>> or Add ALL>> 
button.

2. Select the OK button.
You are returned to the Machine screen.

Removing Icons Remove the toolbar icon(s) from the display as follows:

1. Select the button(s) to be removed and select the <<Remove or 
<<Remove All button.

2. Select the OK button.
You are returned to the Machine screen.
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Configurable Toolbar
Rearranging Icons Rearrange the toolbar icon(s) as follows:

1. Select the button(s) to be rearranged and select the Move Up or Move Down 
button as desired.

2. Select the OK button.
You are returned to the Machine screen.

Toolbar Icons All icons contained on this toolbar are described below, however, only individuals 
assigned privileges are allowed to perform certain system functions. When a 
person does not have a particular assigned privilege that icon will not be 
displayed on screen. 

Attention
Only those individuals assigned privileges are allowed to perform or change 
system calibrations and offsets. Refer to Chapter titled - System Administration 
and Security.

The icons shown below will be observed and are functionally described as 
follows:

Change Syringe-
Select to bring dispense head to the front of the machine. 
This will allow you to remove and replace the syringe.

Camera to Needle Offset Automatic-
Select to perform a Camera to Needle offset Automatic. 
This method of calibration is a less detailed procedure 
than the Manual Camera to Needle offset in that the 
dispense parameters are not set during this procedure. 
Refer to Chapter titled - Calibration and Offsets for a 
detailed procedure.

Clean Pre-dispense Plate(s)-
Select to open the safety door to clean the ceramic pre-
dispense plate(s).
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Configurable Toolbar
Initialize Machine-
Select to initialize the machine.
This will zero out the dispensing head and weight scale.

Zero Weight Scale-
Select to open the safety door and replace full disposable 
purge cups with empty ones. This also zeros out the 
weight scale.

Configuration-
Select to display all configuration tabs which include: 
Head Syringe, Buttons, Weight Scale(s) Temperature, 
Display Settings, Process, Process Program Defaults, 
Security-1, Security-2, Process Program Commands, and 
SPC Data.

Diagnostics (Conveyor, I/O, and Motion)-
Select to display the Conveyor Maintenance, I/O Status, 
and Motion Control tabs.

Purge Needle-
Select to perform a purge. This allows the selected head 
to be purged by following the on screen notes. Typically 
used to remove air or aged material from the needle.

Camera to Needle Offset- (Normally not visible)
Select to perform a Camera to Needle offset. This method 
of calibration places three dispense test dots onto the 
dispense pad. The vision system then aligns itself with the 
center dot and establishes the offset. Test dot parameters 
may be modified (dot size, lift height, dispense height) as 
required. Refer to Chapter titled - Calibration and Offsets 
for a detailed procedure.
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Process Program Grid
Process Program Grid

Description The Process Program Grid (Figure 7-3) is a spreadsheet-like display that allows 
you to specify values and/or settings for the many system dispensing commands. 
The fields (at the top of the grid) that are visible are dependent on the commands 
entered on each command line. This narrows the display to only those fields that 
are applicable to each individual process program.

Vertical and horizontal scroll bars are provided at the bottom and right side of the 
screen since there are too many fields to display simultaneously. You may also 
alter the field display by dragging the vertical bar between the field column names 
to change the width of the field or hide it altogether.

Process Program Commands Toolbar

Description Process Program Commands (located at the top of the Process Program Grid, see 
Figure 7-3) are used to insert commands into the process program.

Toolbar Icons The icons shown below will be observed and are functionally described as 
follows:

Vision Window-
Select to display the vision window on the monitor. 

Trackball Z-
Select to move the dispense head in the Z-axis using the 
trackball.

Enable / Disable Selected Commands-
Select to disable or enable command lines. This is 
performed by selecting either a single or several lines in 
the command column. When the program is run the 
system will skip over this command line(s).
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Process Program Commands Toolbar
Edit-
Select to perform typical edit functions. The drop down 
box includes: Undo, Redo, Cut, Copy, Paste, Delete, Find, 
Replace, Grid Filter, Enable/Disable Command(s), Find 
Closest Command.

Tools-
Select to rotate a process program (90, 180, or 270 
degrees), Optimize, or Normalize New Coordinates.

Available Commands-
Select to display all available dispensing commands. The 
drop down box includes: Locate, Zsense, Dot, Line, Link 
Line, Filled Rectangle, Unfilled Rectangle, Array, Pre-
Dispense Dot, Pre-Dispense Line, New Coordinate, Old 
Coordinate, Move, Wait, End, Do Pass, Break, Pass, Chip 
Line, Timer, Weigh Selected Commands, and Bad Marks.

Locate-
Select to display the library of Fiducials or to create a new 
Fiducial. The Fiducial types available in the drop down list 
include: All, Taught, Chip Definition, and One Snap. 
Select the desired file and select OK to insert into the 
program.

Zsense-
Select to perform a Zsense. This will activate the trackball 
so you may move to the desired X, Y coordinate.

Dot-
Select to insert a Dot command line into the process 
program. System will default to values set from the 
previous Dot command.

Line-
Select to insert a Line command into the process program. 
System will default to values set from the previous Line 
command.
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Process Program Commands Toolbar
Link Line-
Select to insert a Link Line command into the process 
program. This command allows the head to draw a 
continuous line without raising the head. Link Line default 
values are set from the previous Link Line command.

Filled Rectangle-
Select to display the library of Filled Rectangle templates. 
This command allows the head to draw a continuous line 
without raising the head. The three types of fill routines 
are: Spiral In, Spiral Out, and ZigZag. Refer to chapter 
titled - Creating and Managing Process Programs for 
detailed description on Templates. Select the desired file 
and select OK to insert into the program.

Unfilled Rectangle-
Select to display the library of Unfilled Rectangle 
templates. This command allows the head to draw a 
continuous line without raising the head. Refer to chapter 
titled - Creating and Managing Process Programs for 
detailed description on Templates. Select the desired file 
and select OK to insert into the program.

Array-
Select to display the library of Array templates. This 
template is used to automate the programming of multiple 
dots that are equally spaced within a specific area. Refer 
to chapter titled - Creating and Managing Process 
Programs for detailed description on Templates. Select the 
desired file and select OK to insert into the program.

Pre-Dispense Dot-
Select to display the library of Pre-Dispense Dot 
templates. Allows dots to be placed onto the predispense 
plate. Refer to Chapter titled - Creating and Managing 
Process Programs for detailed description on Templates. 
Select the desired file and select OK to insert into the 
program.

Pre-Dispense Line-
Select to display the library of Pre-Dispense Line 
templates. Allows lines to be placed onto the predispense 
plate. Refer to Chapter titled - Creating and Managing 
Process Programs for detailed description on Templates. 
Select the desired file and select OK to insert into the 
program.
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Process Program Commands Toolbar
New Coordinate-
Select to insert a new X-Y coordinate command into the 
process program.

Old Coordinate-
Select this command to revert back to the original taught 
coordinate in the process program. This command must 
be placed after a New Coodinate in the program.

Move-
Select to insert a Move command into the process 
program. This moves the dispense head from one place to 
another between dispensing commands.

Wait-
Select to insert a Wait command into the process 
program. This will pause the head (for a set amount of 
time) before continuing.

End-
Select to insert an End command into the process 
program. This command signals the end of the process 
program. Any commands listed after this line will be 
ignored by the system.

Do Pass-
Select to insert a Do Pass command into the process 
program. This command is used to call out one or more 
groups of commands that are defined by the Pass 
command. The system will execute the commands based 
on the numbers in the First Pass Num and Last Pass Num 
fields.

Break-
Select to insert a Break command into the process 
program. This command is used as a timer to control the 
maximum time between passes. The primary purpose is to 
prevent application problems caused by premature curing 
of dispense material.
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Process Program Commands Toolbar
Pass-
Select to insert a Pass command into the process 
program. This command divides the individual segments 
of a process program. Each Pass command is identified 
with a sequential number. All commands following this 
command are considered part of the set, until the next 
Pass command is reached in the program.

Chip Line-
Select to insert a Chip Line command into the process 
program. This command is used to dispense individual line 
segments. Differs from a regular Line because there are 
no X-Y coordinates.

Timer-
Select to insert a Timer command into the process 
program. This will delay the execution of a program 
segment until a prescribed amount of time has elapsed. 
This is set in the Timer Timeout field.

Weigh Selected Commands-
Select to insert a Weigh command into the process 
program. This will place a Begin Weigh and an End Weigh 
command before and after the highlighted command lines 
to be weighed. The library of Weigh Templates will 
appear. Refer to Chapter titled - Creating and Managing 
Process Programs for detailed description on Templates. 
Select the desired file and select OK to insert into the 
program.

Bad Mark-
Select to insert a Bad Mark into the process program. The 
library of Bad Mark Templates appear. Refer to Chapter 
titled - Creating and Managing Process Programs for 
detailed description on Templates. Select the desired file 
and select OK to insert into the program. The Mark Level 
field on each Bad Mark command line must be labeled as: 
Global, Row, or Local.
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Process Program Grid Fields

Introduction The following are basic definitions of the process program grid fields shown in 
Figure 7-4. Detailed information for all process program grid fields, and use of, are 
found in the following Chapters - titled:

• Creating and Managing Process Program Files
• Dispensing SMT Applications
• Dispensing Underfill & Encapsulation

Field Definitions Command - Displays the command necessary to create a process program. 
New process program commands will always be inserted after the current 
highlighted step in the program and will be executed in the order specified.

X Position - Specifies the X-axis dispense position.

Y Position - Specifies the Y-axis dispense position.

X’ Position - Specifies the X end position for a Line or Linkline command.

Y’ Position - Specifies the Y end position for a Line or Linkline command.

Theta - Performs a rotation of a block of commands contained within a New 
Coord command.

Head - Specifies the head that will be used when dispensing a particular dispense 
process program command.

Valve - Specifies the valve used to dispense (Right or Left) when a dual dispense 
unit is mounted on the system.

Line Width - Specifies the volume of material dispensed in a line.

Dot Size - Determines the amount of dispense valve auger rotation, when a 
dispense command is executed. Measured in degrees of rotation.

Lift Height - Sets the height the head moves between dispense commands.

Dispense Height - The distance the needle just contacts the board and the tip of 
the needle (this is considered Board Zero). Dimension is established from Home 
position of the Z-axis. This is taught by just contacting the needle to the 
substrate.

Name - Displays the file name that is associated with a Locate or Template 
command.

Reference Designator - Identifies a specific component on the process board. 
Some examples of this are: C101, R203, and U7. These are normally printed on 
the board, provided there is space. The reference designator enables the user to 
search for a specific component.

Shape Code - Defines a generic component type. Each component has a shape 
code based on its physical configuration and dimensions. One example of this is 
for 1206 resistor. There is one part number for each resistor value.
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Process Program Grid Fields
Line Delay - Determines the amount of auger rotation that the system delays the 
XY motion prior to the start of dispensing a Line command. During the delay, air 
pressure is applied to the head and the dispensing unit motor turns. Line Delay 
allows time for higher viscosity materials to start coming out of the needle.

Line Off Advance - Determines the amount of travel distance to turn off material 
to the dispensing unit prior to the end of a Line command. Line Off Advance 
allows low viscosity materials time to stop flowing from the needles.

Dot Dwell - Determines the amount of time dispense unit stays in the down 
position after a dot is dispensed. This allows the dispense material time to finish 
flowing from the needle. The dwell starts when the Dot Size ends.

Transition Up Height - Sets the distance for which the head will run at slow speed 
when rising from a dispense operation. Used to eliminate tailing tendency of some 
dispense materials.

Transition Down - Sets the distance for which head will run at slow speed when 
lowering to a dispense operation. Used to eliminate overshoot in the Z-axis.

RPM - Determines the rotation speed (in revolutions per minute) of a dispense unit 
while dispensing.

Length Offset - Establishes how a line of material will be dispensed relative to the 
length of the part. A value of zero (0) would indicate a line equal to the length of 
the part (corner to corner). A positive number would indicate a line beyond the 
length of the part (offset from the corners). A negative number would indicate a 
line short of the length of the part (offset from the corners). This field is used 
with an underfill application.

Position Offset - Establishes how far away a line of material will be dispensed 
relative to the edge of a part.

Dispense On Down - Allows a dot to begin to be dispensed on the down stroke of 
the dispense unit.

Optimize - If the box is checked, the command will not be optimized. Dot 
command lines with checked boxes are dispensed first. Typically used for 
Predispense dots.

Link Line Last - Establishes when the cartridge in the dispense unit will lift after 
connecting multiple Linkline commands together.

First Pass Num - Indicates which Pass group will be executed first. A Do Pass 
command triggers a specific Pass group or groups. This field is used with underfill 
applications.

Last Pass Num - Indicates which Pass group will be executed last. A Do Pass 
command triggers a specific Pass group or groups. This field is used with underfill 
applications.

Pass Num - The specific number assigned to a Pass group of commands. This field 
is used with underfill applications.

Timer Timeout - The amount of time assigned to a system timer command. A 
Timer command assures that a specified amount of time has passed between the 
execution of one command and the execution of the next. This field is used with 
underfill applications.

Start Corner - Determines where dispensing will start in an underfill application. 
Values range from zero (0) to three (3) clockwise, with zero indicating the upper 
right corner. This field is used with underfill applications.
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Process Program Grid Fields
End Corner - Determines where dispensing will end in underfill applications. 
Values range from zero (0) to three (3) clockwise, with zero indicating the upper 
right corner. This field is used with underfill applications.

Mark Level - This is used to identify the type of Bad Mark for a command line. 
The options available are Global, Row, and Local. Refer to Chapter titled - Bad 
Mark Sensing for a detailed description.
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Block Editing
Block Editing

Introduction Multiple entries may be edited on the Process Program Grid in a specific column. 
This feature saves time during programming by allowing the whole column to be 
edited verses single entries on each command line.

Procedure Perform a block edit to the Process Program Grid as follows:

1. Load the Process Program to be edited. See Figure 7-2.

Figure 7-2

2. Select the column to be edited. The example in Figure 7-2 shows the Line 
Width column selected. Select the cells to be edited as follows:
a. Using the trackball, move the cursor over the cells to be edited. Press the 

left button on the trackball.
b. Press and hold the Shift key on the keyboard. Move the cursor vertically 

to the last cell to be edited in the column. Press the left button on the 
trackball. The example in Figure 7-1 shows lines 19 through 21 selected.

3. Change the values in the selected cells by using the number pad on the key-
board. Press Enter to change the values in the whole string selected. See Fig-
ure 7-3.

Note that the original value was 0.25 in Figure 7-2 and the cells were edited to 
0.28 under the Line Width shown in Figure 7-3.

Column to be
 Edited
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Block Editing
Figure 7-3

Edited column
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Block Editing
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Process ProgramsProcess ProgramsProcess ProgramsProcess Programs

Overview

Introduction This chapter describes how to create, load, and modify process programs, as well 
as the requirements for files created off-line.

Each process program contains a set of application specific file properties which 
need to be assigned. If you are importing ASCII text files, they need to be 
structured with a specific format.

This section also describes the use of fiducials and templates, which eliminate 
repetitive programming.

Before attempting any procedure in this section the system should be calibrated 
properly and you should be familiar with the following:

• System Startup and Shutdown
• Installing a Dispense Unit
• Setting up the Conveyors and Loading a Board(s)
• Toolbars and the Process Program Grid

Attention
When performing any procedure in this section, the command word “Select” 
refers to clicking the left trackball button.
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Overview
In This Chapter This chapter contains the following topics.

Topic Page

Overview 8-1

Creating A New Process Program 8-3

Assigning Properties 8-5

Importing Files 8-7

Inserting Program Commands 8-9

Saving The Process Program 8-10

Editing An Existing Process Program 8-11

Assigning Units Of Measure 8-12

Creating And Assigning Fiducials 8-13

Creating A Taught Fiducial 8-13

Configuring Synthetic Fiducials 8-17

Creating One Snap Fiducials 8-19

System Templates 8-21

Creating A Template 8-22

Dot, Line, And Move Templates 8-23

Weight Scale Templates 8-24

Filled And Unfilled Rectangle Templates 8-28

Creating A Diamond Shape 8-30

Pre-Dispense Templates 8-33

Array Templates 8-35

Renaming A Template 8-36

Editing Or Copying A Template 8-37

Running A Process Program 8-39

Optimizing A Process Program (Xyflex) 8-41

Optimizing A Process Program (XyflexPro) 8-43
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Creating A New Process Program
Creating A New Process Program

Introduction You need to be familiar with several tasks when creating process programs. The 
following sections describe each task:

• Creating the Process Program
• Assigning File Properties
• Creating and Assigning Fiducials
• System Templates, including the Weight Scale 
• Inserting Program Commands

Procedure 1. Select File>Process Programs.
A list box of existing process programs is displayed. See Figure 8-1.

Figure 8-1

2. Click the left trackball button to activate the Name: field.
3. Type a new program name of your choice in place of the existing name.
4. Select the New button.

A Comments: box is displayed. See Figure 8-2.
5. Enter any relative information about this new program. (Part Number, Board 

Size, Material, etc.) in the space provided.
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Creating A New Process Program
Figure 8-2

6. Select the Next button.
Several buttons and Properties fields are displayed. See Figure 8-3.

7. Assign program properties as required.
See the section titled - Assigning File Properties.

8. Select the Save button.
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Assigning Properties
Assigning Properties

Introduction Each Process Program that you create can be configured in terms of the 
dispensing application. The program is configured via a number of properties 
fields that are displayed during new program creation or via the Properties tab 
when displayed from a loaded program.
See Figure 8-3.

Property Fields The following are general field descriptions and guidelines.

Board Size - Specifies the length and width of the board.

Process Type - Select SMT or Underfill. This setting determines how the conveyor 
will pass boards through the system.
In Underfill mode, a carrier with multiple parts would be treated by the system as 
though it was a single part.

Process Mode - Sequential mode is used primarily for dispensing dots.
Each program command is assigned to a specific head, this allows for different 
combinations of needle and dispense properties. 

Selecting Parallel mode is used to dispense underfill, encapsulation or other 
applications where all heads dispense identical commands. 

Process Program Offset Defaults - Determines the position of the substrate 
relative to the board’s clamped position in the conveyor.

Figure 8-3
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Assigning Properties
Heat Timers - This is used if the system is equipped with heated chucks to set the 
duration of time (in seconds) that the substrate will remain at the Pre-heat or 
Post-heat stations.

Process Flags - The system has the ability to process various commands in batch 
mode. When their respective boxes are checked, all like commands (Locate, Z-
Sense) are all processed together at the beginning of program execution, 
regardless of their position in the program.

Dispense Unit Types - For each dispense head, select the type to be used. The 
choices in the drop down list are: None, Dot, Line, Heated Line, 3X Line, 3X 
Heated Line, Flux Jetter, or 645 Piston Pump. 

Dispense Unit Mode- This mode contains two settings which control how air is 
delivered to the dispense unit.
The two settings are:
Syringe Air On, Line Valve Pulsed - Used with Line and Dot Dispense Units for 
dispensing low viscosity materials.
Syringe Air Pulsed, Line Valve Open - Used for dispensing high viscosity materials 
or when constant air pressure is required to assure an adequate flow of material.

Park Position - This allows a user to set a specific park location for each head. 
The head moves to the park position following a dispense cycle. When taught 
properly, dispense head movement is minimized by teaching the Park Position in 
close proximity to the next dispense operation.
Refer to section titled - Setting the Park Position.

The selections that you make in the Properties view are saved with the program 
so that the correct parameters are applied automatically when the program is 
loaded.

See Chapters titled - SMT Application and Underfill/Encapsulation for more 
detailed information for these specific applications.

Setting File Properties After establishing the appropriate settings, select the Next> button, if you are 
creating a new process program. 
Select the Save button if you wish to apply changes to an existing program.
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Importing Files
Importing Files

Introduction The Import function allows you to utilize Process Program data created off-line. 
Process Program files can be imported from any accessible drive.
The following file types are supported:

• All Benchmark files (*.Cam), (*.txt), (*.*Template), (*.*Fid), (*.ChipDef), 
(*.BadMark)

• Camalot GFX software files can be imported but must be saved as .txt files.

Procedure Import a File as follows:

1. Select File>Import from the Machine screen. See Figure 8-4.

Figure 8-4

2. Select the Look In field and select the folder that contains the file to be 
imported. If necessary, use the drop down list to find the correct folder.

3. Select the files to be imported from the left-hand column.
In Figure 8-4 three files are selected.

4. Select the Add>> button to move the files over to the right-hand column 
under the field labeled Files To Import.

5. If a file was placed in the File To Import column inadvertently, select the file 
and then the <<Remove button.

6. Select the Import button when all the required files are in the File To Import 
column.

An indicator just to the right of the Import button will show the files being 
transferred. Figure 8-5 appears when all the files are imported.
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Importing Files
Figure 8-5

7. Select the OK button on the screen.
You are returned to the Import screen.

8. Repeat step 2 through step 7 for additional files to be imported or select 
Close to return to the Machine screen.
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Inserting Program Commands
Inserting Program Commands

Introduction Program commands can be entered into the Program Grid two different ways:

• Select from the Process Program Command toolbar. See Figure 8-6.

• Select the All Commands icon  from the Program Command toolbar. See 
Figure 8-6.

Figure 8-6

Add commands to the program by selecting a row in the first column of the 
Program Grid and selecting a Program Command icon or by inserting from the All 
Commands icon. New commands are added on the command line (row) following 
the one currently selected. Inserting a command activates the applicable fields in 
the Program Grid. You may leave the default values or enter new ones. 
See the Chapter titled - Toolbars And The Process Program Grid for detailed 
descriptions of all the system commands.

Program Commands ToolbarAll Commands Icon
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Saving The Process Program
Saving The Process Program

When you create a new dispense program and establish the appropriate settings, 
select the Next> button.

Select the Save button if you wish to apply changes to an existing program. See 
Figure 8-7.

When viewing an existing program on the Program Grid, changes or additions to 
the program are saved by selecting one of the following:

Figure 8-7

Save Program Changes Select

To modify the original file Save button

To create a new file name Save As button
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Editing An Existing Process Program
Editing An Existing Process Program

Procedure
1. Select File>Process Programs. 

A list of existing Process Programs appears. See Figure 8-8.
2. Select a program from the list.

Figure 8-8

3. Select the Edit button.
4. To view the program, select View>Process Program.

The program commands are displayed in the program grid.
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Assigning Units Of Measure
Assigning Units Of Measure

Introduction System settings and commands can be displayed in inches or millimeters.

Procedure To change the Units of Measure:

1. Select View>Configuration and select the Display Settings tab.
The Configuration view appears. See Figure 8-9.

2. Select Inches or Millimeters from the Display Units group.
3. Use the up and down arrows in the Decimal Precision field to establish the 

number of decimal places required. The range is from 0 to 5.
4. Select OK to return to the Machine screen.

Figure 8-9
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Creating And Assigning Fiducials
Creating And Assigning Fiducials

Attention
Before teaching any fiducials, be sure that the vision system is calibrated. Refer 
to the Chapter titled - Calibration And Offsets.

Introduction Fiducials are used by the system to offset programs to accommodate skewed 
boards or components. If the program utilizes fiducials, the fiducials must be 
taught before program creation. There are four different types of fiducials that 
can be defined based on your application:

Taught fiducials are user defined. Actual board details are captured by the system 
and used to offset programs in production. Taught fiducials must be defined by 
the user and are retained by the system for use in dispensing process programs.

Synthetic fiducials are industry standard board markings which are supplied with 
the Benchmark software. Although the form or shape of the fiducials is pre-
defined, you must setup the fiducial before it can be used.

Chip Definition fiducials are used in the underfill process to locate the edges and 
orientation of the chip. In underfill applications the dispensing takes place very 
close to the edge of the part and the dispensing needle is actually below the top 
of the part. Refer to chapter titled - Dispensing Underfill And Encapsulation for a 
detailed description and procedure.

One Snap fiducials are used to identify a component which are confined to a 
small image area. The system will take one snap shot of two taught areas on a 
component.

Creating A Taught Fiducial

Attention
If all of the fiducials you use are identical, you need only teach one, which can be 
applied to all reference points.

Procedure Before teaching a fiducial, you need to load a sample board(s) into the system.

Teach one or more fiducial reference marks on the process board as follows:

1. Select File>Locate. 
A list of previously created fiducials appears. See Figure 8-10.
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Creating A Taught Fiducial
Figure 8-10

2. Type a new name for the fiducial.
3. Select the New button.

A pop up list of fiducial types appears.
4. Select Taught from the list.

A comment box appears. See Figure 8-2.
5. Enter any relative information about this new file (Part Number, Board Size, 

Material, etc.) in the space provided.
6. Select the Next> button.

A vision window appears. See Figure 8-11.

Figure 8-11

Model Size

Search Area
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Creating A Taught Fiducial
Attention

A clear image with well defined edges is required in order to correctly identify 
fiducials. This is achieved by adjusting zoom, brightness, and contrast settings 
prior to teaching the fiducial.

7. If necessary, adjust camera focus and lighting to desired settings as follows:
a. Select the Camera Settings button. Camera Settings screen appears.

See Figure 8-12.

Figure 8-12

b. Adjust the Zoom, Brightness, and Contrast as desired by selecting the 
applicable up or down arrow for each field. After desired settings are com-
plete, select the Close button.

Attention
The Model Size and Search areas are represented in the vision window by green 
bounding boxes. The bounding boxes have square handles at each corner which 
are used to resize them. The model size box should be large enough so that the 
camera can distinguish the fiducial from the area surrounding it. The Search Area 
should be just large enough to account for the maximum possible skewing of the 
substrate.

8. If necessary, adjust the Model Size and/or Search Areas as follows 
(See Figure 8-11):
a. Place the pointer on any one of the square handles at the corners of the 

bounding box.
b. Click on a handle (a double headed arrow appears).
c. Using the trackball change the size of the box to properly surround the ref-

erence mark.
d. Click the left trackball button to accept the change.

9. Select the Center Regions button, this makes the Model Size and Search 
Area boxes concentric.

10. Select the Trackball button and use the trackball to align the intersection of 
the crosshairs with the center of the fiducial.

11. When the fiducial is properly centered, click the left trackball button.
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Creating A Taught Fiducial
Attention
The vision system validates each fiducial based on the quality of the image. A 
user specified Threshold value determines the minimum quality factor. Any value 
above the Threshold is accepted. Any value below the Threshold setting is 
rejected.
A typical Threshold setting is 75. A satisfactory score appraised by the vision 
system when the Teach button is selected is normally in the 90s.

12. Select the Threshold field and type in the desired value. See Figure 8-11.
13. Select the Teach button.

The Score, Contrast and Brightness values are displayed.
14. If the values are acceptable, select the Finish button.

You are returned to the list of fiducials.
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Configuring Synthetic Fiducials
Configuring Synthetic Fiducials

Introduction The system software provides a library of industry standard fiducial marks. You 
can use these marks to create fiducials based on your application.

Procedure To configure a synthetic fiducial:

1. Select File>Locate.
A list of previously created fiducials appears. See Figure 8-10.

2. Select the file listed in the Name field.
3. Type a new file name of your choice in place of the existing file name.
4. Select the New button.

A pop up list appears with the four types of fiducials.
5. Select Synthetic from the list.

A comment box appears. See Figure 8-2.
6. Enter any relative information about this new file (Part Number, Board Size, 

Material, etc.) in the space provided.
7. Select the Next button.

A Shape window and several fields and buttons are displayed on the screen.
See Figure 8-13.

Figure 8-13

8. Enter/select the appropriate settings to establish the characteristics of the 
new fiducial according to the table on the next page.
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Configuring Synthetic Fiducials
9. After specifying the properties for the new fiducial, select the Teach button.
10. Select the Test button.
11. Note the score value in the box to the right of the Test button.

A score of 90 or above is considered satisfactory.
12. If necessary modify the fiducial properties and retest until a satisfactory 

score is achieved.
13. Select the Finish button.

Field/Button Description

Shape Circle, Cross, Db left, Db right, Diamond, and Rectangle.

Dimensions Enter the dimensions of the fiducial.

Search Window You can define the search area numerically or as a 
percentage of the fiducial size.
If you select the Percentage button, the size of the search 
area is calculated, based on the dimensions of the fiducial 
and the value you specify in the % Larger field. The 
minimum value is 20%. The maximum is 100%.
If you select the Actual button, the Width, and Height 
fields are activated and you may specify exact dimensions 
for the search area. 

Foreground/
Background 

Defines the color scheme for the fiducial and background.

Camera Settings Displays Contrast and Brightness values currently in 
affect. Set to desired value using the up or down arrow.

Teach / Test When the Teach button is selected, the values entered in 
the above fields are saved to memory and the Test button 
is enabled.
By selecting the Test button, the system will produce a 
score of the model.

Scoring A good fiducial should yield a score of 90 or above.
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Creating One Snap Fiducials
Creating One Snap Fiducials

Introduction Using One Snap fiducials increases throughput because both fiducials associated 
with the part are located by the vision system simultaneously. Thus head 
movement is cut in half.

Procedure 1. Select File>Locate. 
A list of previously created fiducials appears. See Figure 8-14.

Figure 8-14

2. Type a new name for the fiducial.
3. Select the New button.

A pop up list of fiducial types appears.
4. Select One Snap from the list.

A comment box appears. Refer to Figure 8-2.
5. Enter any relative information about this new file (Part Number, Board Size, 

Material, etc.) in the space provided.
6. Select the Next> button.

A vision window appears as shown in Figure 8-11.
7. If necessary, make adjustments to the camera’s focus and lighting and to the 

Model Size and Search Area bounding boxes.
Refer to the section titled Creating A Taught Fiducial.

8. Select the Trackball button and use the trackball to position the camera so 
that both fiducials are visible in the vision window.

9. When properly positioned, click the left trackball button.
10. Using the handles drag and adjust the Search Area and Model Size bounding 

boxes so that they are centered over the first fiducial. See Figure 8-15.
11. Select the Teach button.
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Creating One Snap Fiducials
12. The Score, Contrast and Brightness values are displayed.
13. If the values are acceptable, select the Next button.

Figure 8-15

14. Select the Trackball button.
15. Using the handles drag and adjust the Search Area and Model Size bounding 

boxes so that they are centered over the second fiducial. See Figure 8-16.
16. Select the Teach button.

Figure 8-16

17. The Score, Contrast and Brightness values are displayed.
18. If the values are acceptable, select the Finish button.

Model Size

Search Area

Model Size

Search Area
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System Templates
System Templates

Introduction Templates allow the convenience of storing and applying dispense properties 
used in dispense routines.

Templates are generally applied to individual program commands, however some 
are applied to a group of commands.

There are several application-based template styles:

• Dot 
• Line
• Move
• Unfilled Rectangle
• Filled Rectangle
• Pre-Dispense Dot
• Pre-Dispense Line
• Array
• Weigh

Templates can be created during the programming process, or as a standalone 
function.
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Creating A Template
Creating A Template

Introduction All templates are created using the same general procedure regardless of the 
template type. The only difference between template types are the properties 
that are stored in the templates themselves.

Procedure 1. Select File>Template.
A screen appears with a list of existing templates.
See Figure 8-17.

Figure 8-17

2. Select the desired template type from the drop down Filter list.
The Name field is highlighted.

3. Type a file name of your choice over the highlighted file name.
4. Select the New button.

A comment box appears on the screen.
5. Enter any relative information about this template (Part Number, Board Size, 

Material, etc.) in the space provided.
6. Select the Next button.
7. A list of property fields and buttons, appropriate to template type is dis-

played.

Attention
The section titled Process Program Grid Fields contains detailed information on all 
dispensing properties.

8. After entering values for each field, select the Finish button.
The template data is saved in the database.

Specific template types are discussed in detail in subsequent sections of this 
chapter.
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Dot, Line And Move Templates
Dot, Line And Move Templates

Introduction Figure 8-18 illustrates the Dot, Line and Move template types.

The section titled Process Program Grid Fields in Chapter 7 contains detailed 
information on all dispensing properties.

Applying The Template 1. Insert or select an existing Dot, Line or Move command.
2. Use the scrollbar at the bottom of the Program Grid if necessary to display 

the Name column.
3. Place the pointer over the Name column cell on the command line and double 

click the left trackball button. A list of appropriate templates is displayed.
4. Select the desired template name from the drop down list.
5. Select the OK button.

The properties of the selected template are applied to the command.

Figure 8-18

Move Template

Dot Template

Line Template
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Weight Scale Templates
Weight Scale Templates

Introduction The Weight Scale template properties are used to establish and maintain precise 
and consistent dispense amounts.

Creating The Template 1. Select File>Template.
A screen appears with a list of existing templates.
See Figure 8-17.

2. Select the Weight Scale template type from the drop down Filter list.
3. Type a new file name in the Name field.
4. Select the New button.

A comment box appears on the screen.
5. Enter any relative information about this template (Part Number, Board Size, 

Material, etc.) in the space provided.
6. Select the Next button.
7. A list of property fields and buttons is displayed on the screen.

See Figure 8-19.

Figure 8-19

8. Enter the template properties.
See the section titled Weight Scale Template Properties.

9. Select the Finish button.

Weigh Template
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Weight Scale Templates
Weight Scale Template 
Properties

Weight Scale template properties are based on a specific process coupon and 
material.

The following table describes the individual property fields and buttons:

Field/Button Description

Target Weight The desired weight of the dispensed material. Determined 
by performing a sample test (dispense and weigh) on a 
process coupon (user defined) or with the Calculator.
See the section titled - Using The Weight Scale Calculator 
for more information.

Tolerance The amount of allowed deviation from the Target Weight. 
(Can be established when performing the sample test on 
the process coupon.)

Weigh Per Head 
Every

Controls the frequency of the weigh operation.
Times: The weight will be checked after a specified 
number of dispense occurrences.
A value of zero indicates that the user wants to ignore the 
Times factor and default to the Minutes control.

Minutes: The weight will be checked after a specified 
number of minutes has elapsed.
A value of zero indicates that the user wants to ignore the 
Minutes factor and default to the Times control.

The Times and Minutes are synchronized with each other. 
Whichever occurs first triggers a weigh sequence.

Pre-Dispense 
Template

 An optional Dot or Line pre-dispense command may be 
executed after a successful weigh sequence. 
This ensures that no residual material remains on the 
needle prior to dispensing on the actual product.
The Pre-dispense command will dispense onto the pre-
dispense plate. 
Select the Select Dot... or Select Line ... button to choose 
a pre-dispense template.

Calculate A pop-up calculator appears which is used to determine a 
Target Weight. See the section titled - Using The Weight 
Scale Calculator for more information.
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Weight Scale Templates
Using The Weight 
Scale Calculator

The Weight Scale Calculator provides an alternate means of establishing the 
target weight of a dispense sequence.

Selecting the Calculate ... button in the New Templates screen displays the 
Calculate Target Weight screen as shown in Figure 8-20.

Figure 8-20

The calculator fields are described as follows:

To perform a calculation:

1. Insert the proper information into the appropriate fields.
2. Select the OK button.

The calculation is performed.
3. If the value in the Calculated Weight field is acceptable, select the OK but-

ton.
The calculated weight is applied to the Target Weight field.

Field Description

Length Length of a particular program entity.

Height Height of a particular program entity.

Width Width of a particular program entity.

Density Density of the material that is being dispensed.

Calculated 
Weight

Calculated weight from the values entered in the above fields.  
This number automatically calculates when values are placed in 
fields for Length, Height, Width, or Density.
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Weight Scale Templates
Applying The Template A Weight Scale template is applied to a selected series of dispensing commands.

To insert a weight scale template into a Process Program:

1. Load a process program.
2. Select View>Process Program to display the Program Grid.
3. Using the trackball, select the command lines that will be subject to the 

weigh process.
In Figure 8-21, command lines 5 and 6 are selected. 

Figure 8-21

4. Select the Weigh Selected Commands icon  from the toolbar.
A list of Weight Scale templates appears.

5. Select the appropriate Weight Scale template.
6. Select the OK button.

A Begin Weigh command is inserted before the selected lines and an End 
Weigh command is inserted after the selected lines.

7. Use the scrollbar at the bottom of the Program Grid if necessary to display 
the Name column.
The name of the selected Weight Scale template appears in the Name field 
on the Begin Weigh command line.
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Filled And Unfilled Rectangle Templates
Filled And Unfilled Rectangle Templates

Introduction
The Filled Rectangle and Unfilled Rectangle templates contain the same dispense 
properties as the Line template type as well as some additional fields that are 
specific to these applications. See Figures 8-23 and 8-24.

The section titled - Process Program Grid Fields in Chapter 7 contains detailed 
information on all dispense properties.

Special Fields The table below describes the additional fields that are used with the Filled and 
Unfilled Rectangle templates.

Figure 8-22

Figure 8-22 illustrates the typical path of the dispense unit when the process 
program is run using the Rectangular Offset Start.

Field Description

X and Y Position Defines the first corner of a Filled or Unfilled rectangle.

X’ and Y’ Position Defines the second corner of a Filled or Unfilled rectangle.

X” and Y” Position Defines the third corner of a Filled or Unfilled rectangle.

Rect Offset Start Places the start point of the dispensed line between the 
first two corner points. This eliminates a buildup of 
material that can occur when the start and end points are 
in a corner. See Figure 8-22.

Fill Type
(Filled Rectangle Only)

This drop down list allows you to select a Spiral In, Spiral 
Out or Zig Zag dispense program.

Line Offset
(Filled Rectangle Only)

Assigns the spacing (offset) between each line that is 
used to create the fill.

X, Y Position
Rectangular Offset
Start Point X’, Y’ Position

X’’, Y’’ Position
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Filled And Unfilled Rectangle Templates
Figure 8-23

Figure 8-24

Applying The Template 1. Insert or select an existing Filled Rectangle or Unfilled Rectangle command.
2. Use the scrollbar at the bottom of the Program Grid if necessary to display 

the Name column.
3. Place the pointer over the Name column cell on the command line and double 

click the left trackball button.
A list of appropriate templates is displayed.

4. Select the desired template name from the drop down list.
5. Select the OK button.

The properties of the selected template are applied to the command.

Filled Rectangle

Unfilled Rectangle
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Creating A Diamond Shape
Creating A Diamond Shape

Procedure Create a diamond shape as follows:

1. Place the pointer on a line of the program grid where you wish to place a dia-
mond. Select Unfilled Rectangle from the top of the Process Program Com-
mands Toolbar . 

2. Type a file name of your choice over the highlighted file name.
3. Select the New button.

A comment box appears on the screen.
4. Enter any relative information about this template (Part Number, Board Size, 

Material, etc.) in the space provided.
5. Select the Next button.
6. A list of property fields and buttons, appropriate to template type is dis-

played.
7. Using the trackball, place the cursor over the grid of the template and right 

click.
A pop-up menu appears. See Figure 8-25.

Figure 8-25

8. Left click the trackball and a vision window appears.
9. Using the trackball and the vision window, drive the crosshair over to the 

first point of the diamond. See Figure 8-26. Select the left button to teach 
the first point.
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Creating A Diamond Shape
Attention
The system has the capability of dispensing in either a clockwise or 
counterclockwise direction. The software determines the dispensing direction 
from the second point. Figure 8-26 is an example dispensing in a clockwise 
direction.

10. Repeat step 4 for the second and third points.
The software calculates the placement of the line from point 3 to 4 and the line 
from point 4 to 1 without any operator input.

Figure 8-26

Running The Diamond 
Shape

Run the diamond shape template as follows:

1. Load a process program.
2. Place the cursor on the command line of the grid where the diamond shape is 

to be inserted.
3. Select Unfilled Rectangle from the top of the Process Program Commands 

Toolbar . 

4. Select the unfilled rectangle template previously created.
5. Select OK.

You are placed back in the program grid with the trackball active.

6. Move the crosshair over to a desired start point. Select the left trackball but-
ton.

7. Select the Start Operations button.
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Creating A Diamond Shape
Adding A Rectangular 
Offset To The Diamond 
Shape

Create a Rectangular Offset to the diamond shape as follows:

1. Create the Unfilled Rectangle template for a diamond shape. Refer to section 
titled - Creating A Diamond Shape.

Attention
The Rectangular Offset places the start point of the dispensed line between the 
first two points. This eliminates a buildup of material that can occur when the 
start and end points are in a corner. See Figure 8-27. 

Figure 8-27

2. Open the Unfilled Rectangle template with the diamond shape.
3. Select the Rect Offset Start field. Enter a desired value in the field (this 

dimension is from the first point).
4. Select the Finish button.

Rectangle Offset Starting
and Ending Point

Offset Dimension
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Pre-Dispense Templates
Pre-Dispense Templates

Introduction The Pre-Dispense templates contain the same dispense properties as the Dot and 
Line templates as well as some additional fields that are specific to these 
applications. See Figure 8-28.

The section titled - Process Program Grid Fields for detailed information on all 
dispense properties.

Property Fields The table below describes the additional fields that are contained in the Pre-
Dispense templates.

Figure 8-28

Field Description

Process Program 
Spacing X
Process Program 
Spacing Y

Establishes the offset between individual executions 
of the pre-dispense program.

Executions Per Cycle Defines how many dots/lines are dispensed per cycle.

Line Length
(Pre-Dispense Line only)

Defines the length of each line in a pre-dispense 
execution.

Pre-Dispense Dot

Pre-Dispense Line
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Pre-Dispense Templates
Applying The Template 1. Create or load a Process Program.
2. Insert or select an existing Pre-Dispense Dot or Pre-Dispense Line command.
3. Use the scrollbar at the bottom of the Program Grid if necessary to display 

the Name column.
4. Place the pointer over the Name column cell on the command line and double 

click the left trackball button.
A list of appropriate templates is displayed.

5. Select the desired template name from the drop down list.
6. Select the OK button.

The properties of the selected template are applied to the command.
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Array Templates
Array Templates

Introduction The Array template is used to create a matrix of equally spaced dots.

Property fields The Array template contains several unique property fields. See Figure 8-29.
The table below describes the specialized property fields that are used.

Figure 8-29

Applying The Template 1. Create or load a Process Program.
2. Insert or select an existing Array command.
3. Use the scrollbar at the bottom of the Program Grid if necessary to display 

the Name column.
4. Place the pointer over the Name column cell on the command line and double 

click the left trackball button.
A list of appropriate templates is displayed.

5. Select the desired template name from the drop down list.
6. Select the OK button.

The properties of the selected template are applied to the command.

Field Description

X and Y Position
X’ and Y’ Position
X” and Y” Position

Defines three corner points which determine the 
shape and dimensions of the matrix.

Number Of Rows
Number Of Columns

Establishes the number of dots within the matrix as 
well as the spacing of the dots.

Style Defines the dispensing sequence.
Zig Zag dispenses in a back and forth motion.
Raster dispenses in a single direction.

Array
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Renaming A Template
Renaming A Template

Procedure 1. Select File>Template.
The Template screen appears. See Figure 8-30.

2. Select the template file to be renamed.
The name template file name appears in the Name field.

3. Select the Rename button.
4. Type the new file name.
5. Hit the keyboard Enter key or select the Rename button.

Figure 8-30
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Editing Or Copying A Template
Editing Or Copying A Template

Introduction This section explains how to modify a template or create a new template from an 
existing one.

Procedure 1. Select File>Template
A list of existing templates appears. See Figure 8-31.

Figure 8-31

2. Select the template file to be edited.
3. Select the Edit button.

The screen displays a group of property fields. See Figure 8-32.

Figure 8-32
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Editing Or Copying A Template
4. Modify the property values as needed.
5. If you want to modify an existing template, select the Save button.
6. If want to create a new template using the current properties values:

a. Select the Save As button.
The Save As template screen appears. See Figure 8-33.

b. Enter the new template name in the Enter the New Name field.
c. Select the OK button to accept the new name.

7. Select the Close button.

Figure 8-33

Duplicating A Template 1. Select File>Templates
A list of existing templates appears. See Figure 8-31.

2. Select (highlight) the template file to be copied.
3. Select the Save As button.

A duplicate file name appears preceded by the words “Copy of”.
4. Type a name for the duplicate file.
5. Left click in a neutral (white)area of the file list or select the Close button.
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Running A Process Program
Running A Process Program

Introduction This section describes the procedure for loading and running a process program.

Attention
Before loading or running a Process Program make sure that the system is 
properly calibrated. Refer to the Chapter titled - Calibration And Offsets.

Procedure 1. Select File>Process Programs. 
A list of existing Process Programs appears. See Figure 8-34.

2. Select a program from the list.

Figure 8-34

3. Select the Load button.
4. Position a process board on the conveyor.
5. Select Operations> Conveyor Mode.

A pull down menu will appear showing the following:

Off

Automatic

Pass Through
6. Select Automatic mode.
7. Select the Start Operation button on the Machine screen. See Figure 8-35.
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Running A Process Program
If a SMEMA (Surface Mount Equipment Manufacturers Association) signal is 
confirmed (made) that the Upstream Board Available, the board will move to the 
dispense station, be raised, clamped, and the program will begin execution.

8. To pause the run, select the Pause button on the Machine screen.
9. To abort the run, select the Abort Process button on the Machine screen.

10. If you are already in the Program Grid, and you wish to run the program, 
repeat step 2 through step 5.

Figure 8-35

Start Operation

Pause

Abort Process

File Name of Loaded Process Program
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Optimizing A Process Program (Xyflex)
Optimizing A Process Program (Xyflex)

Introduction Optimizing a dot program ensures that the program dispenses with the least 
amount of head travel by distributing commands between multiple heads. This in 
turn provides increased throughput.

The Optimize function works with Dot, Move, Fiducial, New_Coord, and Old 
Coord commands. All other commands are dropped automatically from the output 
file. 

Procedure To optimize a program:

1. Select File>Process Programs.

Attention
The optimize function only supports files containing Dot commands.

2. From the list of existing process programs select the file to be optimized and 
select the Edit button.

The selected file appears on the Program Grid. See Figure 8-36.

Figure 8-36

3. Select the Tools icon  from the Program Commands Toolbar.
4. Select the Optimize command from the drop down list.

The Optimize screen appears. See Figure 8-37. 
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Optimizing A Process Program (Xyflex)
Figure 8-37

5. Select the Heads that will run the optimized program by placing a check in 
the appropriate Head number box.
This enables the Optimize button.

6. Enter the appropriate six digit, Needle Part Number for each Head.
The Panel box is only selected when you have multiple identical sub-boards. This 
will equalize and line balance the time spent dispensing on several heads.

The Divide box is selected when you have several new coordinates and want to 
divide the dispensing between multiple heads.

7. Select the Optimize button.
The loaded file is optimized and you are returned to the Program Grid.

8. If the software optimized the program to meet your needs, select the Save 
button.

9. If you do not like how the system optimized the program, select the Close 
and the program will return to its original state before optimizing.
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Optimizing A Process Program (XyflexPro)
Optimizing A Process Program (XyflexPro)

Introduction Optimizing a dot program ensures that the program dispenses with the least 
amount of head travel by distributing commands between multiple machines. This 
in turn provides increased throughput.

The Optimize function works with Dot, Move, Fiducial, New_Coord, and Old 
Coord commands. All other commands are dropped automatically from the output 
file.

Procedure To optimize a program:

1. Select File>Process Programs.

Attention
The optimize function only supports files containing Dot commands.

2. From the list of existing process programs select the file to be optimized and 
select the Edit button.

The selected file appears on the Program Grid. See Figure 8-36.

3. Select the Tools icon  from the Program Commands Toolbar.
4. Select the Optimize command from the drop down list.

The Optimize screen appears. See Figure 8-38.

Figure 8-38

Single Machine Optimize Screen
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Optimizing A Process Program (XyflexPro)
5. If you have a single XyflexPro machine, place a check in the Head I box.
This enables the Optimize button.

6. If your line is setup with multiple XyflexPros, place a check in the Optimize 
for Multiple Machines. See Figure 8-39.

7. Select the Machines that will run the optimized program by placing a check 
box in the appropriate Machine number box.
This enables the Optimize button.

8. Enter the appropriate six digit, Needle Part Number for each Head or 
Machine.

Figure 8-39

The Panel box is only selected when you have multiple identical sub-boards. This 
will equalize and line balance the time spent dispensing on several machines.

The Divide box is selected when you have several new coordinates and want to 
divide the dispensing between multiple machines.

9. Select the Optimize button.
The loaded file is optimized and you are returned to the Program Grid.

10. If the software optimized the program to meet your needs, select the Save 
button.

11. If you do not like how the system optimized the program, select the Close 
and the program will return to its original state before optimizing.

Multi-Machine Optimize Screen
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Overview

Introduction Security is based on user group hierarchies. The groups are comprised of one or 
more individuals with rights or restrictions to specific functions of the system. 

These groups are listed in CAM_groups where “groups” are the names given to 
those single or collective individuals (users) and where their level of responsibility 
are assigned.

Initial user privilege is issued from the Windows NT® Network Administrator’s 
level where the Administrator provides restricted access to the network. The 
network level is the only place where groups can be added or deleted.

The highest level group determines the system’s function access. This could be 
an engineer, manager, supervisor or chief responsible individual or group of 
individuals.

Attention
When performing any procedure in this section, the command word “Select” 
refers to the operator to use the trackball and click the left button.

In This Chapter This chapter contains the following topics.

Topic Page

User Groups 9-2

Privilege 9-2
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User Groups
User Groups

Creating Groups The following list is an example of groups:

• CAM_LINEENGINEER
• CAM_MAINTENANCE
• CAM_OPERATOR
• CAM_SUPERVISOR
• CAM_FIELDSERVICE

These groups are default groups, new groups may be created by the Windows 
NT® Network Administrator.

Each group whether comprised of one user or more, can then access the system 
once issued network rights. In this manner groups are created and users are 
assigned to the proper groups.

The machine restrictions are then controlled by a responsible system group, again 
comprised of a single individual or more.

Privileges

Security Screens After creating the User Groups and assigning users to the proper groups, 
privileges can be enabled for these groups using the Security 1 and Security 2 
tabs in the Configuration screen. See Figures 9-1 and 9-2.

Figure 9-1
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Privileges
Figure 9-2 

These screens allow you to turn on/off application level features for all users of a 
given CAM group. For example, you can configure the settings so that only users 
that are members of the CAM_SUPERVISOR group can change the security 
privileges.

To display the Configuration screen and display privileges, perform the following 
steps:

1. Select View>Configuration from the Machine screen. The Configuration 
screen will appear. There are two Security tabs titled Security 1 and Security 
2. The two are related and the reason for the second is lack of space in the 
first. For purpose of examples we will address them in order. Choose Secu-
rity 1.

2. Select the Group drop down list.
There are four collective privilege groups including the Security 2 tab. 

• Process Programs
• Diagnostics
• Miscellaneous
• Configuration 
• Calibrations

Each of these contain check boxes that enable or disable the functions described 
to their right.
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Privileges
Creating or Assigning 
Privileges

Selecting groups and assigning certain privileges allows the ability to fine tune 
each group’s ability to alter machine settings.

To create/assign privileges:

1. Select a User Group by placing the cursor on the group’s Cam_ name and left 
clicking.

2. Enable or disable a privilege by clicking left in the checkbox to the left of the 
privilege. A checked box enables a privilege, an unchecked box disables a 
privilege.

3. Click left on the OK button to save the changes and dismiss the screen.

Modifying Privileges To modify privileges:

1. Select a group from the desired security tabs.
2. Select the privilege box to modify. If unchecked and the desire is to enable it, 

click in the box to check it. 
3. To disable a checked box (or enabled privilege), left click in the box to 

remove the check mark.
4. Select the OK button to accept the changes and dismiss the screen. 
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Bad Mark SensingBad Mark SensingBad Mark SensingBad Mark Sensing

Overview

Introduction Bad mark sensing saves process time by identifying any bad part(s) on a 
substrate. Bad parts are identified with some sort of marking (black marker or 
equivalent) on the substrate and skipped over during program dispensing.

Attention
A bad mark sensing location may be inserted into any existing program. This 
command is placed within the program using the Process Program Grid.

Attention
When performing any procedure in this section, the command word “Select” 
refers to the operator to use the trackball and click the left button.

In This Chapter This chapter contains the following topics.

Topic Page

Overview 10-1

Identifying A Bad Mark In The Process Program Grid 10-2

Setting The Vision System For Batch Mode 10-4

Creating And Naming The Bad Mark File 10-6

Inserting The Bad Mark Template Into The Program 10-10
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Identifying A Bad Mark In The Process Program Grid
Identifying A Bad Mark In The Process Program Grid

Description Three choices of identification are used when identifying a bad mark in the 
Process Program Grid. This is set under the Mark Level field in the Process 
Program Grid. See Figure 10-1.

• Global
• Row
• Local

Attention
The vision system software will follow the sequence of Global then Row and end 
with Local. The use of Row may be eliminated from programming if an entire row 
is considered one part.

When the system is running a program all vision commands are processed first 
through the software. The Bad Mark sense commands are processed in the 
following order: Global, Row, and Local. 
The vision system is set to Vision Batch Mode to process this sequence in the 
order described. Refer to section titled - Setting the Vision System for Batch 
Mode.

Figure 10-1

Global - Used to identify that a bad mark exists on a board. When inserting a Bad 
Mark command into the process program the Global level is always the first level 
that the system will read. This is identified with the word Global under the 
column Mark Level (in the Process Program Grid). See Figures 10-2.

Row - Used to indicate that a bad mark(s) are within a row. This is identified with 
the word Row under the column Mark Level (in the Process Program Grid). 
Local - Used after a Row, to identify an individual component has a bad mark. 
This is identified with the word Local under the column Mark Level (in the Process 
Program Grid).
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Identifying A Bad Mark In The Process Program Grid
Figure 10-2 illustrates a typical board using Bad Mark sensing. Note that the 
board is marked (with a black marker or equivalent) at each reference point 
(Global, Row, and Local). Each of these points are taught and named and placed 
within the program (using the Process Program Grid).

Figure 10-2

Global Bad Mark Row Bad Mark Board Fiducial
Reference Mark

Row Bad Mark

Local Bad Mark
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Setting The Vision System For Batch Mode
Setting The Vision System For Batch Mode

Introduction Vision Batch Mode is a setting contained in the software, when enabled allows 
the software to process all related vision commands first within the program. This 
will minimize X and Y movements and is designed to maximize throughput. This 
setting is located on the Process Program Properties screen.

Attention
In order for the vision system to process any Bad Mark sense the setting for 
Process Flags - Vision Batch Mode must be enabled. This setting is found in the 
Properties tab screen. See Figure 10-3.

Local Bad Mark Batch is an optional selection which is determined by the location 
of the Bad Marks on a substrate. This is determined by the following:

• If the local bad marks are in close proximity of each other this selection 
would be enabled.

• If the local bad marks are scattered on the substrate this selection would not 
be enabled.

Prior to adding any Bad Mark commands into a program enable the Vision Batch 
Mode in the Process Flags Group. 

Procedure Select the Properties tab as follows:

1. Select the Properties tab from the top of the loaded process program. The 
Properties screen appears. See Figure 10-3.

Figure 10-3
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Setting The Vision System For Batch Mode
2. Select the Vision Batch Mode located in the Process Flags group. See Figure 
10-3.

3. If the bad marks are contained to one local area on the substrate, select the 
Local Bad Mark Batch.

4. Select the Save button.
5. Select the Close button.
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Creating And Naming The Bad Mark File
Creating And Naming The Bad Mark File

Introduction The bad mark files are stored in a library which allows the convenience of 
recalling when required to place into a program.

Procedure To create a Bad Mark File:

1. Select File>Bad Mark from the menu bar. The Bad Mark Template screen 
appears. See Figure 10-4.

Figure 10-4

2. Type a name for the new bad mark in the Name field.
The New button becomes enabled.

3. Select the New button.
The Bad Mark Template Comment screen appears. See Figure 10-5.
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Creating And Naming The Bad Mark File
Figure 10-5

Enter any relative information about this new file (Part Number, Board Size, 
Material, etc.) in the space provided.

4. Select the Next button.
A Bad Mark screen to teach the gray scale of a Blank Bad Mark appears. See 
Figure 10-6.

Figure 10-6
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Creating And Naming The Bad Mark File
Teaching the Blank Bad 
Mark

In determining whether to dispense a part, the system needs to determine if a 
part has been bad marked.

This is achieved by comparing the gray scale values of an area on or near the 
part. The gray scale values are measured with (marked) and without (blank) the 
Bad marking. From these two values a threshold is calculated. 

At run-time the vision system measures the gray scale area of each part and 
compares it to the above threshold to determine, whether to dispense the part or 
skip it.

Configuring the gray scale area requires:

• Adjustment of Contrast and Brightness
• Definition of the Gray Scale area (Search Area)
• Teaching the Gray Scale values

Teach the Blank Bad Mark gray scale as follows:

1. Select the Trackball button. While viewing the vision screen, move the 
crosshair over to a reference point that does not contain a bad mark. See Fig-
ure 10-7.

Figure 10-7

2. Adjust the Search Area so that the reference point is within the frame.
Decrease or enlarge search box by placing the cursor on any corner of the box.

3. Select the Teach button.
The vision system measures a gray scale within the Search Area. These values 
are displayed under the Teach button.

0= darkest shade of gray. (Gray Scale)

100= lightest shade of gray. (Gray Scale)

A value close to 100 (Gray Scale) is desired when teaching the Blank Bad Mark. 
See Figure 10-7.

4. If the Gray scale value is acceptable, select the Next button.

Search Area
10-8 XyflexPro Operation And Programming Guide, Benchmark 4.2



. .
 . 

. .BA D  MAR K  S ENS ING

Creating And Naming The Bad Mark File
A Bad Mark screen to teach the gray scale of a Marked Bad Mark appears. See 
Figure 10-8.

Teaching the Marked 
Bad Mark

Teach the Marked Bad Mark gray scale as follows:

1. Select the Trackball button. While viewing the vision screen, move the 
crosshair over to the same reference point (taught during the Blank Bad 
Mark) that contains a Bad Mark. See Figure 10-8.

Figure 10-8

2. Adjust the search area so that the reference point is within the frame.
Decrease or enlarge search box by placing the pointer on any corner of the box.

3. Select the Teach button.
The vision system measures a gray scale within the Search Area. These values 
are displayed under the Teach button.

0= darkest shade of gray. (Gray Scale)

100= lightest shade of gray. (Gray Scale)

Values displayed in the Marked Gray Scale are typically lower than those in the 
taught in the Blank Gray Scale.

4. If the Gray Scale value is acceptable, select the Finish button.

Search Area
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Inserting The Bad Mark Template Into The Process Program
Inserting The Bad Mark Template Into The Process Program

Introduction A Bad Mark sense template may be placed within any program. This command 
line is typically placed near the beginning of the program (one of the first few 
commands). The reason for this placement, is to notify the vision system right 
away whether a Bad Mark exists (normally a Global mark) on the board which will 
save process time.

Procedure Insert a Bad Mark template into the program as follows:

1. Load an existing program that you wish to place a Bad Mark in. Figure 10-9 
illustrates a typical program containing Bad Marks.

Figure 10-9

2. Place a Bad Mark command by selecting the line before any dispense com-
mand.
The command line becomes highlighted.

3. Select the Bad Mark icon  from the Process Program Commands toolbar.
The library of previously created Bad Mark files appears.

4. Select the Bad Mark file that is to be inserted into the loaded program.
5. Select the OK button.

The selected Bad Mark file appears in the process program grid prior to a 
dispensing command line.

6. Select the Bad Mark Level (Global, Row, or Local) for each bad mark com-
mand line placed within the program. See Figure 10-9.

7. Select the Save button on the Process Program Grid. 
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SPC Data

Overview

Introduction The system is equipped to record SPC (Statistical Process Control) data of certain 
events selected from the SPC Data tab menu on the Configuration screen. Each 
event that is selected from the menu is logged onto a text file (.txt) and may be 
analyzed offline as an Excel® file.

Attention
When performing any procedure in this section, the command word “Select” 
refers to the operator to use the trackball and click the left button.

In This Chapter This chapter contains the following topics.

Topic Page

Overview 11-1

Setting The SPC Data Log 11-2

Viewing SPC Data 11-4

Downloading SPC Data 11-5
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Setting The SPC Data Log
Setting The SPC Data Log

Procedure Set the SPC Data log as follows:

1. Select View>Configuration>SPC Data tab from the Machine screen. See 
Figure 
11-1.

Figure 11-1

2. Select the Enable data logging field. This makes all the SPC Data fields 
active.

3. Select the Data log directory field. This field is where the logged information 
(selected from the menu) is stored as a text (.txt) file. The example displayed 
has the information being logged going to c:\Camfiles\SPCData.

4. Select the File Cleanup Interval field.
The File Cleanup Interval is the amount of time before the files are purged. This 
duration of time is in days. The minimum number is 1 and up to a maximum of 30 
days. This example shows 14 days in the field.

5. Select a number from 1 to 30 using the up or down arrow.
6. Select the Time base for time stamp field.

The Time base for time stamp is divided into two categories. The first is Local 
Time which is on the local computer terminal. The second is GMT/UTS which is 
Greenwich Mean Time or Universal Time Stamp.

7. Select one of the time stamps described above using the left button on the 
trackball.

8. Select the Events to log menu list.
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Setting The SPC Data Log
The Events to log menu is a list of trackable events listed in alphabetical order. A 
minimum of one event must be checked. However, multiple events may be 
checked to track.

9. Select a minimum of one event from the menu by placing a check in the 
desired event using the left button on the trackball. The selected event or 
events will be logged onto a (.txt) file and viewed offline as a Excel® file.

10. Select OK to accept the entered information for the SPC Data Log and to 
close the screen.

Selecting the Cancel button aborts the process.
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Viewing SPC Data

Description The system will create a (.txt) file if the SPC Data log is enabled. This file must be 
downloaded onto a disk and viewed offline using Excel® software.

Figure 11-2 shows a typical file created on the SPC Data log.

01/20/2000, 09:57:43, Start Button, 0

01/20/2000, 09:57:43, Program Started, 4, 1, 1

01/20/2000, 09:57:43, Program Started, 4, 2, 1

01/20/2000, 09:57:43, Program Started, 4, 3, 1

01/20/2000, 09:57:43, Program Started, 4, 4, 1

01/20/2000, 09:57:43, Board leaves segment, 7, 3, 1

01/20/2000, 09:57:43, Segment Cycle Time, 8, 3, 1, 0.01

01/20/2000, 09:57:43, Program Complete, 5, 3, 1

01/20/2000, 09:57:43, Board leaves segment, 7, 1, 1

01/20/2000, 09:57:43, Segment Cycle Time, 8, 1, 1, 0.04

01/20/2000, 09:57:43, Program Complete, 5, 1, 1

01/20/2000, 09:57:43, Board leaves segment, 7, 2, 1

01/20/2000, 09:57:43, Segment Cycle Time, 8, 2, 1, 0.03

01/20/2000, 09:57:43, Program Complete, 5, 2, 1

01/20/2000, 09:57:43, Board leaves segment, 7, 4, 1

01/20/2000, 09:57:43, Segment Cycle Time, 8, 4, 1, 0.03

01/20/2000, 09:57:43, Program Complete, 5, 4, 1

Figure 11-2
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Downloading SPC Data

Procedure Place the SPC DATA file onto a disk as follows:

1. Insert a floppy or a ZIP disk into the computer.
2. Using the trackball move the cursor to the Start button on the bottom left- 

hand corner of the monitor. Select the left button on the trackball.
3. Move the cursor to the right and find the NT Explorer. Go to the data log 

directory that was established in Figure 11-1. This example shows c: \ Cam-
files \ SPC Data.

4. Copy the file that you want to view onto the floppy or Zip disk already 
inserted in the computer.

5. Remove disk from the computer and place in an standalone computer.
6. On the standalone computer, start up the Excel® Application.
7. Select File, Open from the top of the screen.
8. Select the file to be viewed from the disk. The Text Import Wizard will 

appear. See Figure 11-3.

Figure 11-3

9. Select the Delimited radio button. 
10. Select the Next >button. 
Page two of the Wizard appears. See Figure 11-4.
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Downloading SPC Data
Figure 11-4

11. Select the Comma box in the Delimiters group.
12. Select the Finish button. The file from the disk is now pasted into the Excel® 

Application. See Figure 11-5. The column width may be expanded by click-
ing and holding the vertical line at the top of the desired column.
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Downloading SPC Data
Figure 11-5

Figure 11-5 displays the imported file displayed in the Excel® Application. The 
columns are labeled to identify the data listed. Each column may be sorted as 
desired. 

Additional columns not shown that may be tracked for SPC Data are as follows:

• Template
• Attempt Number
• Desired Weight
• Measured Weight
• Percent Tolerance
• Scale Factor

Date

Time
Events to Log

Event ID

Head

Lane

Segment
Cycle
Time
XyflexPro Operation And Programming Guide, Benchmark 4.2 11-7



11
SP C DA TA

Downloading SPC Data
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Network Communications

Overview

Introduction This chapter describes the networking issues that must be considered when 
setting up a “Remote” connection that connects to a CAMALOT system running 
the Benchmark® software. The Benchmark® software is designed to run under the 
Windows NTTM operating system (OS) and utilizes the networking and security 
features built into the OS.

There are two different configurations of the Windows NTTM operating system; 
Windows NT Workstation and Windows NT Server.

The descriptions in this chapter provide you with the fundamental concepts 
needed to configure two computers using the Benchmark® software.

Attention
Do not change the “name” of the system NT computer. Changing the computer 
name under NT will adversely affect the operation of the system after being 
mapped.

In This Chapter This chapter contains the following topics.

Topic Page
Overview 12-1

Networking Configurations 12-3

Benchmark® Software 12-5

Configuring The Benchmark® Software For 
Remote UI’s

12-9
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Overview
Windows NT 
Workstation

Windows NT Workstation is the OS (Operating System) generally used by stand-
alone computers (i.e. computers that are not connected to a network), computers 
on a network which act as “peers” (including computers that belong to a 
“workgroup”), and by computers that act as “clients” to a “domain”.

A domain is a group of servers that share common security policy and user 
account databases (Windows NT Resource Kit - Windows NT Networking Guide).

Windows NT Server The Windows NT Server is essentially a superset of the Windows NT Workstation 
OS and provides additional services such as the ability to create and manage 
“domains”, provide centralized mail services, etc.
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Networking Configurations
Networking Configurations

Stand Alone 
Configuration

Each computer running Windows NT Workstation has a local database of user 
accounts and a local database of security policies (or permissions granted to 
users and/or user-groups). In order to “log on” to this computer, the user must 
enter a user name and password that matches an account in the user account 
database. See Figure 12-1.

Figure 12-1

Two NT Workstations 
in a Peer-to-Peer 
Configuration

In a “peer-to-peer” configuration, each user logs onto their local machine (A) 
which requires that they have a user account in the local user account database. 
This gains them access to whatever local resources they’ve been given 
permissions to access locally.

When the user subsequently attempts to access a resource on a different 
computer (B), for example he attempts to access a “shared” drive on the second 
computer, his user name and password are forwarded to the computer (B) for 
“authentication”. If the user name and password match a user account on the 
target computer (B), then the user can access the resources that have been 
permitted by the security policy database on the target computer (B). See Figure 
12-2.

Figure 12-2

Security policy database

User account database

A

B

Security policy database
User account database

Security policy database
User account database
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Networking Configurations
NT Workstation and 
NT Server 
Configuration

In a “client-server” configuration, each user can either log onto their local 
machine or log onto a domain.  By selecting the name of the local computer as 
the “Domain” at the logon screen, the user is logging on to the local computer.  
By selecting any other name they are logging on to the selected domain.

When logging on locally, the user account must exist in the local user account 
database (as described in previous sections).

When logging onto a domain, the user name & password must exist in the 
“server’s” user account database. In this scenario, the user will be permitted to 
access the domain’s resources based on the permissions granted in the server’s 
security policy database. See Figure 12-3.

Figure 12-3

A

B

Security policy database

Security policy database

User account database

User account database
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Benchmark® Software
Benchmark® Software

Introduction The Benchmark® software consists of two primary components: a client 
component and a server component. The client component (Benchmark.exe) is 
essentially the user-interface (UI). The server component (ServerBenchmark.exe) 
is essentially the hardware control portion. There’s an additional component 
(VisionBenchmark.exe) which provides the “vision” services (e.g. program-
recognition); this component is considered to be an extension of the server 
component.

The UI can be run on the same computer as the Benchmark-Server or it can be 
run on a different computer that’s connected to the computer running the 
Benchmark-Server by a network connection (which can include a modem 
connection).

The Benchmark-Server is designed to run as a “service” on the computer that 
controls the hardware (e.g. a machine). A single Benchmark-Server can support 
multiple UI’s (i.e. one local UI and multiple remote UI’s). Running as a service has 
the following benefits:

• Services can be run under a specific user account which means that they can 
run with different (generally higher) privileges than the typical user. The 
Benchmark-Server runs (by default) under the “system account” which 
means that it has “administrative” privileges.

• Services do not stop running when the user logs off the computer. This 
allows a user to log onto the computer, start the CAMALOT system (via the 
UI), and log off leaving the system in the desired mode of operation.

• Services can be configured to start automatically when the computer is pow-
ered on.

The Benchmark® software is designed to run under version 4.0 (with Service Pack 
4) of the Windows NT Workstation operating system.

Stand Alone 
Configuration

When the computer in a CAMALOT system boots (generally following powering 
on the system), the Benchmark-Server will automatically start up as a service. By 
default, it will run under the “system account” (i.e. the user account with a user 
name of “Administrator”). A user then logs onto the local machine at the system 
terminal.

Attention
When performing remote connections, it is important to have a two-way 
connection. One connection from the UI to the Benchmark-Server and the second 
from the Benchmark-Server to the UI.

When the user subsequently runs the UI (which will generally happen 
automatically when the user logs onto the machine) and “connects” the UI to the 
local Benchmark-Server, there is NOT an attempt (by the program) to “log on” 
since both components are already running on the same computer. The UI is able 
to connect to the Benchmark-Server AND the Benchmark-Server is able to 
connect to the UI. See Figures 12-4 and 12-5.
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Benchmark® Software
Figure 12-4

Figure 12-5

Trackball
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Benchmark® Software
Software in a Peer-to-
Peer Configuration

As described in the previous section, when the computer in a CAMALOT system 
boots, the Benchmark-Server will automatically start up as a service. In order to 
allow a remote client (i.e. a copy of the UI running on a different computer) to 
“connect” to this server, the Benchmark-Server MUST run under an account that 
also exists on the client’s computer. This is necessary in order to allow the server 
to connect “back” to the client’s computer; if the account (i.e. user name & 
password) does not exist on the (remote) client’s computer, then the attempt by 
the server to “log onto” the remote computer will be denied by the operating 
system.

Similarly, the account (i.e. user name & password) under which the remote UI is 
running MUST also exist on the computer running the Benchmark-Server. If the 
account does not exist on the (Benchmark-Server) computer, then the attempt by 
the UI to “log onto” the Benchmark-Server computer will be denied by the 
operating system.

It is NOT necessary for these accounts to have identical permissions on both 
computers; they simply need to be present so that the “log on” process (which 
occurs automatically when 2 computers attempt to “communicate” for the first 
time) can succeed, thereby allowing the UI and Benchmark-Server to 
communicate.

Figure 12-6 and Figure 12-7 illustrate a configuration with a local and remote UI 
connected to the same Benchmark-Server.

Figure 12-6

Security policy database
User account database

Security policy database
User account database
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Benchmark® Software
Figure 12-7
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Interface

Benchmark
Server
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Configuring The Benchmark® Software For Remote UI’s
Configuring The Benchmark® Software For Remote UI’s

Procedure In order to configure the Benchmark® software so a remote UI can connect to a 
Benchmark-Server, perform the following procedure.

1. Configure the Benchmark-Server to run under a new account:
a. Using the “User Manager” program, add a user account with “Administra-

tor” level privileges. This will become the account under which the Bench-
mark-Server will run which is why “Administrator” level privileges are 
required. The new account should have a password that never expires 
(See User Manager for details).

b. Go to Start > Settings > Control Panel > Services screen.
c. Click on the service named CAMALOT Benchmark Server.
d. Click on the Startup button.
e. Select the “This Account” radio button and enter the user name (as the 

account) and password that was created in substep a. The account speci-
fied MUST have “Administrator” level privileges or the service will not 
start.

Attention
The Benchmark-Server is now configured to run under the new account. The 
computer must be rebooted OR the service must be stopped (if running) and then 
restarted for the change to take affect.

 2. Using the “User Manager” program, add a user account that matches the 
user account under which the remote UI will be run. Repeat this step for 
each account that will be used when running the UI at the remote computer. 
The Passwords must be the same on each machine.

On the Remote 
Computer

Using the “User Manager” program, add a user account that matches the user 
account under which the Benchmark-Server is running.

This account does NOT need to have “Administrator” privileges on the client 
machine.

For example, if in step 1.a. in the previous section a user account with a name of 
“Benchmark” and a password of “camalot” was created, then create a local 
account with the same username and password; this will allow the Benchmark-
Server to “log on” to this computer when it attempts to establish a connection 
“back” to the UI.
XyflexPro Operation And Programming Guide, Benchmark 4.2 12-9



12
NETWORK  COMMUN IC AT IO NS

Configuring The Benchmark® Software For Remote UI’s
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Applications

Overview

Introduction The SMT (Surface Mount Technology) application is designed for accurate and 
highly-repeatable dispensing of surface mount epoxies, glues, and solder pastes 
through use of different leadscrews, needle combinations, and material syringes.

In This Chapter This chapter contains the following topics.

Topic Page
Overview 13-1

SMT/Semiconductor Process Program Grid 13-2

Typical SMT Application 13-6

Optimizing A Process Program (Xyflex) 13-9

Optimizing A Process Program (XyflexPro) 13-11
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SMT/SemiConductor Process Program Grid
SMT/SemiConductor Process Program Grid

Introduction The Process Program Grid is used to create a program and allows you to specify 
values and settings for the dispensing commands.

Vertical and horizontal scroll bars are provided at the bottom and right side of the 
screen since there are too many fields to display simultaneously.  You may also 
alter the field display by dragging the vertical bar between the field column names 
to change the width of the field or hide it altogether.  A right click on the mouse 
will restore the grid by selecting Restore Grid Columns.

To create and name a new process program, refer to Chapter titled - Creating and 
Managing Process Programs.

Setting The System 
For SMT

Select the process program grid as follows:

1. Select View>Process Programs from the menu on the Main screen.
The list of existing process programs appears. See Figure 13-1.

Figure 13-1

2. Select the file listed in the Name field.
3. Type a new file name of your choice over the existing file name.

The New button becomes enabled.

4. Select the New button.

The view area changes to a comment box. See Figure 13-2.
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SMT/SemiConductor Process Program Grid
5. Enter any relative information about this new file (Part Number, Board Size, 
Material, etc.) in the space provided.

Figure 13-2

6. Select the Next button. The view area changes to the Properties view. See 
Figure 13-3.

Figure 13-3

SMT Radio Button
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SMT/SemiConductor Process Program Grid
The system Properties screen (Figure 13-3) allows you to assign application 
specific attributes to a process program; for instance a glue dot SMT program 
would have different properties than an Underfill application.

7. Select the SMT radio button in the Process Type field. See Figure 13-3.
8. Select the Save button.
9. Select the Commands Tab.

The Process Program Grid appears. See Figure 13-4.

SMT/Semiconductor 
Process Program Grid 
Fields

The fields used for SMT/Semiconductor are described below. The fields used for 
this process differ from those used for Underfill.

Grid Fields Description

Command Displays the command necessary to program a dispense 
program. New program commands are always inserted 
after the current selected step in the program. Each 
command is executed in the order specified

X Position Displays the X location that a command will be executed.

Y Position Displays the Y location that a command will be executed.

Theta Performs a rotation of a program section. Used with the 
New Coordinate command.

Head Specifies the head that is used when dispensing a 
particular dispense program command.

Dot Size Determines the amount of dispense valve auger rotation, 
when a dispense command is executed.  Measured in 
degrees of rotation.

Lift Height Sets the distance (up height) that the cartridge moves (in 
the dispense unit) between dispense commands.  Correct 
lift height causes the material to snap-off cleanly.  
Minimum lift height will yield a higher throughput.  This 
height is relative to the dispense height.

Dispense Height Distance from Home position of Z to the board. 
This is taught by just contacting the needle to the 
substrate.

Name Displays the file name that is associated with a Fiducial, 
Template, or Array command.

Reference 
Designator

Identifies a specific component on the process board.  The 
identifier is normally printed on the board, provided there 
is space.
For example: C101, R203, and U7. 
The reference designator provides a means to search for a 
specific component.

Shape Code Defines a generic component type.  Each component has a 
shape code based on its physical configuration and 
dimensions.
For example: 1206 resistor
There is one part number for each resistor component.
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SMT/SemiConductor Process Program Grid
Dot Dwell Determines the amount of time (in Milliseconds) that the 
dispense unit will stay in the down position after a dot is 
dispensed.  This allows the dispense material time to 
finish flowing from the needle.  The dwell time starts 
when the Dot Size ends.  More viscous materials do not 
flow as easily a less viscous materials.  Less dwell 
increases throughput.  Reduce dwell after establishing 
well formed, correct size dots.

Transition Up 
Height

Sets the distance for which the head will run at a slow 
speed when raising from a dispense operation.  Used to 
eliminate tailing tendency of some dispense materials.

Transition Down Sets the distance for which the head will run at slow 
speed when lowering to a dispense operation.  Used to 
precisely position the needle when working at small 
dispense heights.

RPM Determines the rotation speed (in revolutions per minute) 
of the leadscrew in the dispensing unit while dispensing.
The default value is 360 RPM.

Dispense On Down Allows a dot to be dispensed on the down stroke of the 
cartridge in the dispense unit.  Provides a head start for 
flow of material for high speed dispensing.  Dispense unit 
motor starts turning before reaching the dispense area.  
Dot starts to form before needle approaches board.  
Reduces amount of dwell needed.

Optimize Reduces the amount of head travel to improve throughput.  
This is normally performed for any SMT process.  
Refer to Chapter titled - Creating and Managing Process 
Programs for detailed description on Optimizing.

Grid Fields Description
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Typical SMT Application
Typical SMT Application

Introduction The process board must be loaded before any commands can be placed in the 
process program grid. Refer to Chapter titled - Conveyors and Heated Chucks.

The following is a typical example of SMT/Semiconductor program. See Figure 
13-4.

Figure 13-4

This sample board is broken into four quadrants and we will dispense eight dots 
in each quadrant. After dispensing eight dots in each quadrant, we will rotate the 
program (Theta) 90 degrees because of the layout of the board.

The first two commands in the program are normally the fiducials. By using 
fiducials the system can offset the program for misaligned boards. For best 
results, fiducial reference marks should be diagonally opposed. Refer to Chapter 
titled - Creating and Managing Process Programs for detailed description on 
Fiducials.

Breakdown Of 
Commands

This above example lists the first two lines in the Command line as follows:

Command X Position Y Position

1 LOCATE - 0.63 5.05

2 LOCATE 5.66 1.08
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Typical SMT Application
Command lines 3 through 10 are used as dispense points for DOTs. This is listed 
in the process program grid as follows:

The same parameters for Dot Size, Lift Height, Dispense Height, and RPM are 
repeated on Command Lines 3 through 10.

This is listed in the process program grid next to the DOT Command Lines 3 
through 10 as follows:

Command line 11 moves the whole dispense program to a new coordinate on the 
board and turns the program (Theta) 90 degrees. This is listed in the process 
program grid under the Command Line as follows:

Command X Position Y Position

3 Dot 5.34 0.88

4 Dot 5.28 0.87

5 Dot 5.28 0.90

6 Dot 5.34 0.90

7 Dot 5.34 1.25

8 Dot 5.28 1.25

9 Dot 5.28 1.28

10 Dot 5.33 1.28

Dot Size Lift Height Dispense 
Height

RPM

200 0.12 0.24 150

Command X Position Y Position Theta

11NEW_COOD 5.46 1.40 90.00
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Typical SMT Application
Figure 13-5 illustrates how the rotation of the program occurs.

Figure 13-5

The program ends with the OLD_COORD and an END command after all four 
quadrants of the board have been dispensed upon.

Running The Process 
Program

Once you have inserted all program commands and made the necessary 
adjustments, you can run (dispense) the program.

To run the program:

Select the  (Start) button from the Main screen or select:
Operations>Start from the menu.

Pause Or Aborting The 
Process Program

1. Select the  (Pause) button to pause dispensing
or select Operations> Pause from the menu.

2. Select the  (Resume) button to resume dispensing
or select Operations>Resume from the menu.

3. Select the  (Abort) button to abort the program
or select Operations>Abort from the menu.

Original Coordinate New Coordinate 
And Rotation 
(Theta 90o
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Optimizing A Process Program (Xyflex)
Optimizing A Process Program (Xyflex)

Introduction Optimizing a dot program ensures that the program dispenses with the least 
amount of head travel by distributing commands between multiple heads. This in 
turn provides increased throughput.

The Optimize function works with Dot, Move, Fiducial, New_Coord, and Old 
Coord commands. All other commands are dropped automatically from the output 
file. 

Procedure To optimize a program:

1. Select File>Process Programs.

Attention
The optimize function only supports files containing Dot commands.

2. From the list of existing process programs select the file to be optimized and 
select the Edit button.

The selected file appears on the Program Grid. See Figure 13-6.

Figure 13-6

3. Select the Tools icon  from the Program Commands Toolbar.
4. Select the Optimize command from the drop down list.

The Optimize screen appears. See Figure 13-7. 
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Optimizing A Process Program (Xyflex)
Figure 13-7

5. Select the Heads that will run the optimized program by placing a check in 
the appropriate Head number box.
This enables the Optimize button.

6. Enter the appropriate six digit, Needle Part Number for each Head.
The Panel box is only selected when you have multiple identical sub-boards. This 
will equalize and line balance the time spent dispensing on several heads.

The Divide box is selected when you have several new coordinates and want to 
divide the dispensing between multiple heads.

7. Select the Optimize button.
The loaded file is optimized and you are returned to the Program Grid.

8. If the software optimized the program to meet your needs, select the Save 
button.

9. If you do not like how the system optimized the program, select the Close 
and the program will return to its original state before optimizing.
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Optimizing A Process Program (XyflexPro)
Optimizing A Process Program (XyflexPro)

Introduction Optimizing a dot program ensures that the program dispenses with the least 
amount of head travel by distributing commands between multiple machines. This 
in turn provides increased throughput.

The Optimize function works with Dot, Move, Fiducial, New_Coord, and Old 
Coord commands. All other commands are dropped automatically from the output 
file.

Procedure To optimize a program:

1. Select File>Process Programs.

Attention
The optimize function only supports files containing Dot commands.

2. From the list of existing process programs select the file to be optimized and 
select the Edit button.

The selected file appears on the Program Grid. See Figure 13-6.

3. Select the Tools icon  from the Program Commands Toolbar.
4. Select the Optimize command from the drop down list.

The Optimize screen appears. See Figure 13-8.

Figure 13-8

Single Machine Optimize Screen
XyflexPro Operation And Programming Guide, Benchmark 4.2 13-11



13
D ISP ENS I NG S MT  AP P L ICA T IONS

Optimizing A Process Program (XyflexPro)
5. If you have a single XyflexPro machine, place a check in the Head I box.
This enables the Optimize button.

6. If your line is setup with multiple XyflexPros, place a check in the Optimize 
for Multiple Machines. See Figure 13-9.

7. Select the Machines that will run the optimized program by placing a check 
box in the appropriate Machine number box.
This enables the Optimize button.

8. Enter the appropriate six digit, Needle Part Number for each Head or 
Machine.

Figure 13-9

The Panel box is only selected when you have multiple identical sub-boards. This 
will equalize and line balance the time spent dispensing on several machines.

The Divide box is selected when you have several new coordinates and want to 
divide the dispensing between multiple machines.

9. Select the Optimize button.
The loaded file is optimized and you are returned to the Program Grid.

10. If the software optimized the program to meet your needs, select the Save 
button.

11. If you do not like how the system optimized the program, select the Close 
and the program will return to its original state before optimizing.

Multi-Machine Optimize Screen
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Encapsulation

Overview

Introduction This chapter describes XyflexPro programming for Encapsulation and Underfill 
applications. It also illustrates how to use Multi-Pass programming to increase 
productivity and maximize throughput.

Attention
It is extremely important to set the values in the Properties screen correctly for 
the intended application whenever a new file is created. Otherwise, incorrect 
dispensing will occur. Refer to Chapter titled - Creating & Managing Process 
Programs.

In This Chapter This chapter contains the following topics.

Topic Page

Overview 14-1

Underfill Applications 14-2

Creating Chip Definitions 14-5

Chipline Start And End Offsets 14-10

Underfill Sample Program 14-12

Encapsulation Applications 14-14

Using The Weight Scale For The Underfill Process 14-16
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Underfill Applications
Underfill Applications

Introduction The XyflexPro Benchmark software includes several features that aid in the 
programing of the Underfill application. In order to use XyflexPro commands 
effectively, it is necessary to understand how the Underfill application is handled 
by the Benchmark software.

Process Description When underfilling a chip, 2 or more lines of material are dispensed parallel and in 
close proximity (.003 -.005 inch, to one edge of the chip). The underfill 
application requires very accurate positioning of the dispense needle during the 
dispense cycle because the needle is so close to the edge of the chip laterally, 
and below the top surface of the chip vertically. Seemingly minor errors in 
positioning could cause the needle to contact the side of the chip.

Underfill programs are created and executed in segments. After the first line is 
dispensed, the timing of each additional application of material is critical. The 
material must have sufficient time to wick underneath the die before the next 
application, so as to prevent formation of air pockets. 

After the underfill segments are completed, a series of lines or fillets can be 
dispensed to finish off the remaining three edges. Ordinarily this is the final 
segment of the program.

To provide the required accuracy, XyflexPro uses a chip definition, which you 
create, to define the length and width of the chip. The chip definition also 
includes a set of vertical and horizontal calipers which the system uses to 
establish a search area. This enables the system to offset and/or rotate the 
dispensed segments accordingly. See the Section titled - Creating Chip 
Definitions for detailed instructions on creating chip definitions. 

In creating the program file, chips are positioned based on an X/Y coordinate 
representing the center of the chip. During program execution, the vision system 
will go to the specified X/Y coordinate and using the chip definition information, 
find the edges of the chip and adjust the dispense as necessary.

Typically in underfill, chips are brought into the dispensing area via a carrier such 
as an Auer boat containing multiple parts. Maximum productivity is achieved by 
dispensing each segment of the program on all or some of the parts on the carrier 
so as to make use of the waiting time that is required between segments.
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Underfill Applications
Commands And Fields The following are commands that are associated with the underfill application:

See Chapter titled - Tool Bars and the Process Program Grid for additional field 
information.

Chipline - used to dispense individual line segments. The command is similar to a 
regular LINE command except that there are no X/Y coordinates.

Length Offset Start- field, determines the start point of the line. A positive 
number would cause a line length equal to the chip dimension plus (+) the 
amount specified. A negative number would cause a line equal to the chip 
dimension minus (-) the amount specified. See Figure 14-4 and 14-5. Refer to 
section titled - Chipline Start and End Offsets to set this position. 

Length Offset End- field, determines the end point of the line. A positive number 
would cause a line length equal to the chip dimension plus (+) the amount 
specified. A negative number would cause a line equal to the chip dimension 
minus (-) the amount specified. See Figure 14-4 and 14-5. Refer to section titled - 
Chipline Start and End Offsets to set this position.

Position Offset -field, determines the gap between the edge of the chip and the 
center of the needle.

Link Line Last - field, - X indicates the last in a series of consecutive Chiplines. 
This feature insures a continuous line by preventing the needle from being lifted 
between segments.

Pass - used to delineate the individual segments of a dispense program. This 
allows individual segments to be executed via a callout (DOPASS) within the 
program. 

Each PASS command is identified by a sequential number and all commands after 
the PASS up to the next PASS command are considered part of the set.

Dopass - used to callout one or more groups of commands that were defined by 
the PASS command. The system will execute the commands based on the 
numbers in the First Pass Num and Last Pass Num fields. In Figure 1 the DOPASS 
command at line 1 instructs the system to execute all commands defined by Pass 
1 then Pass 2. 

TIMER - delays the execution of a program segment until a prescribed amount of 
time has elapsed as determined by the Timer Timeout field. This means that the 
CHIPLINE command on line 14 (2nd pass of the underfill) will not be dispensed on 
this chip unless 10.00 seconds have elapsed since the CHIPLINE command on 
line 10 (1st pass of the underfill) was dispensed. Careful use of the TIMER 
command can maximize throughput by eliminating excessive wait times between 
passes.

LOCATE - This command is used two ways:

1. To find fiducials
2. To position the center of a part to be underfilled and to identify the chip def-

inition that is to be used for the dispense routine. Upon program execution, 
the system will go to the X/Y coordinate of the LOCATE command. The 
vision system then attempts to locate the edges of the chip based on the 
profile of the chip definition selected in the Name field.

New_COORD_1 - used to step and repeat applications such as underfill. Inserting 
the command allows you to create an offset at the beginning of each execution of 
the program or execution blocks.
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Underfill Applications
OLD_COORD - restores the original offsets that were in affect prior to using the 
New_COORD_1 command.

BREAK - is a timer used to control the maximum time allowed between Passes. In 
doing so, it also determines how many parts will be dispensed within the current 
Pass. Using the BREAK command effectively, prevents applications problems 
caused by premature curing of the material.

The Break Timer duration is assigned in the Timer Timeout field.

When a Pass on the first part is completed, the Break Timer is reset to 0 and a 
new countdown begins. Dispensing on subsequent parts will continue as long as 
the Break Timer has not expired.

If/when the Break Timer expires, the system returns to the first part and begins to 
dispense the next pass and the process is repeated.

ZSENSE - is used to determine the substrate height at the point where dispensing 
is to occur. This assures consistent needle distance from the substrate for every 
part.
14-4 XyflexPro Operation And Programming Guide, Benchmark 4.2



. .
 . 

. .D IS PE NS ING  UNDERF I L L  AND  ENCA P SULA T ION

Creating Chip Definitions
Creating Chip Definitions

Introduction When dispensing for underfill applications, each chip must be defined individually 
in terms of its width and length. XyflexPro uses an invisible set of calipers to 
determine where edges of the part are located and to establish if the chip is 
skewed. This information is used to offset and rotate the program so that the 
underfill lines are dispensed at the proper distance from the chip edge, and to 
make sure the lines are parallel to the chip.

When you create a chip definition the Locate screen is used to enter the 
dimensions of the chip as well as lighting information in the dispense area.

Locate Screen The Locate screen is used to set the parameters of the chip. 

1. Select File>Locate. 
A list of previously created chip files appear.

2. Select the file listed in the Name field.
3. Type a new file name of your choice over the existing file name.

The New button becomes enabled.

4. Select the New button.
A pop up list appears with all four types of fiducials.

5. Select Chip Def from the list to assign the fiducial type.

The view area changes to a comment box. 

Enter any relative information about this new file (Part Number, Board Size, 
Material, etc.) in the space provided.

6. Select the Next button and Figure 14-1 appears.
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Creating Chip Definitions
Figure 14-1

The Locate screen fields are defined as follows:

Chip:

Chip Width (A, Figure 14-2) - The Width describes the chip size from side to side. 
Chip width must be within the Min and Max fields dimensions.
Chip Length - The Length describes the chip size from front to back. Chip length 
must be within the Min and Max fields dimensions.

Fore/Background - Select the appropriate combination based on your application.

Model Size

Search Area
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Creating Chip Definitions
Figure 14-2

Horizontal Calipers :

Breadth (F, Figure 14-2) - The Breadth value is the dimension of the caliper that is 
parallel to the edge of the chip.
The horizontal breadth = the percentage of the length of the chip (B, Figure 14-2) 
that you specify.

Extension (E, Figure 14-2) - The Extension value is the dimension of the caliper 
that is perpendicular to the edge of the chip.
The horizontal extension = the percentage of the length of the chip (A, Figure 
14-2) that you specify.

Percentage/Actual Buttons - You can specify caliper dimensions either as a 
specific size or as a percentage of the chip size.

Vertical Calipers:

Breadth (C, Figure 14-2) - The Breadth value is the dimension of the caliper that is 
parallel to the edge of the chip.
The vertical breadth = the percentage of the length of the chip (A, Figure 14-2) 
that you specify.

Extension (D, Figure 14-2) - The Extension value is the dimension of the caliper 
that is perpendicular to the edge of the chip.
The vertical extension = the percentage of the length of the chip (B, Figure 14-2) 
that you specify.

Percentage/Actual Buttons - You can specify caliper dimensions either as a 
specific size or as a percentage of the chip size.

Vertical Caliper

Vertical Caliper
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H
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XyflexPro Operation And Programming Guide, Benchmark 4.2 14-7



14
D ISP ENS I NG UNDER F I L L  A ND  ENCA PS ULAT ION

Creating Chip Definitions
Image:

Camera Settings- When selected a popup menu appears which adjusts Zoom, 
Brightness, Contrast, and Displays the Needle Gauge (when required).

Trackball- This button allows the camera to be moved in the X and Y direction.

Teach- Selecting this button will produce a score of the chip in the camera’s 
view.

Center Regions- Selecting this button centers the Model Size and Search Areas 
over the chip in the vision window.

Threshold Score (%) - This number is used by the vision system to determine if 
contrast and brightness are acceptable. 35 is the default value and generally 
should not require adjustment.

Scoring - When the Teach button is selected a score is produced and compared 
against the value that was entered in the Threshold Score field.

Selecting the Finish button saves the data and you are returned to the list of chip 
definition files.
Cancel merely exits the screen. No changes are made.

Display Vision Window During Test- If this box is checked, allows the vision 
window to be displayed when the Teach button is selected.

Creating a New Chip 
Definition

To create a new chip definition:

1. Position a sample chip under the camera in the dispense area.
2. Select File>Locate from the menu. 

A list of previously created chip files appear.
3. Select the file listed in the Name field.
4. Type a new file name of your choice over the existing file name.

The New button becomes enabled.

5. Select the New button.
A pop up list appears with all four types of fiducials.

6. Select Chip Def from the list to assign the fiducial type.

The view area changes to a comment box. 

Enter any relative information about this new file (Part Number, Board Size, 
Material, etc.) in the space provided.

7. Select the Next button and Figure 14-1 appears.
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Creating Chip Definitions
8. If necessary, adjust camera focus and lighting to desired settings as follows:

Attention
A clear image with well defined edges is required in order to correctly identify 
fiducials. This is achieved by adjusting zoom, brightness, and contrast settings 
prior to teaching the fiducial.

a. Select the Camera Settings button. A popup menu appears. See 
Figure 14-3.

Figure 14-3

b. Adjust the Zoom, Brightness, and Contrast as desired by selecting the 
applicable up or down arrow for each field. After desired settings are com-
plete, select the Close button. 

9. If necessary, adjust the Model Size and Search Areas (green calipers) as fol-
lows (See Figure 14-1):
a. Place the pointer on one of the square handles on any corner of the box. 
b. Select the handle (a double headed arrow will appear, at any corner) using 

the trackball change the size of the box over the fiducial.
c. Select the left button on the trackball to accept the change. 

10. Select the Center Regions button, this centers the Model and Search boxes 
around the chip.

11. Select the Teach button.
The system will produce a score of the model and will be displayed. See Figure 
14-1. An acceptable value is normally in the high 90’s to 100.

12. Select the Finish button if the values of the model are acceptable.
You are returned to the list of fiducials.
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Chipline Start And End Offsets
Chipline Start And End Offsets

Introduction The Chipline command allows you to control the start and end point of the line 
using extensions at each end of the chip. Two columns in the Process Program 
Grid accommodate this feature.

Setting the Length 
Offset Start and End 
Dimension

Set the Offset Start and Offset End dimension for a Chipline as follows:

1. Place the cursor on a line of the process program grid where you wish to 

place a Chipline. Select the Chip Line icon  from the top of the Process 

Program Grid. See Figure 14-4.

Figure 14-4

2. Select the Length Offset Start field on the Chipline command line. Enter a 
positive or negative offset start value. Refer to Figure 14-5 to determine if 
you require a positive or negative extension. This is determined by the dis-
pensing direction of the dispense unit.

3. Select the Length Offset End field on the Chipline command line. Enter a pos-
itive or negative offset end value. Refer to Figure 14-5 to determine if you 
require a positive or negative extension. This is determined by the dispensing 
direction of the dispense unit.

Modify the Start and End Offsets as required to achieve the desired results.
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Chipline Start And End Offsets
Figure 14-5

+ - +-

+ - +-

Dispense Unit flow direction

Length Offset Start

Length Offset End

Extension

Extension

Dispense Unit flow direction

Length Offset End
Extension

Length Offset Start
Extension
XyflexPro Operation And Programming Guide, Benchmark 4.2 14-11



14
D ISP ENS I NG UNDER F I L L  A ND  ENCA PS ULAT ION

Underfill Sample Program
Underfill Sample Program

Introduction The commands listed below represent the programming required to underfill the 
sample parts in Figure 14-6. 

The sample program was created to dispense the underfill of five chips per Auer 
boat.

Each part requires two applications of material for the actual underfill and a fillet 
line around the 3 remaining edges of the chip.

Commands The following is a step-by-step explanation of the initial program settings and the 
commands for dispensing the first chip.

Command Description

1 DOPASS Establishes that Passes 1 and 2 are executed sequentially.

2 BREAK Create a timer that establishes a maximum dispensing gap 
of 20 seconds between Pass 2 and Pass 3 on any chip.

3 DOPASS Establish execution of Pass 3.

4 
NEW_COORD_1

Assign a new offset value that coincides with the first 
location of the first part in the carrier.

5-6 LOCATE Find 2 local fiducials to compensate for skewing of the 
substrate in the carrier.

7 LOCATE Assign X/Y coordinates for the center of the first chip. Find 
the edges and positioning of the chip based on the chip 
definition in the NAME field.

10 ZSENSE Measure the height of the substrate so as to insure correct 
dispense height.

9 PASS(1) Mark the beginning of the first program segment.

10 CHIPLINE Dispense a line of material along the edge of the chip 
designated by the Start Corner and End Corner fields.
Shorten or lengthen the line according to the values in the 
Length Offset field.
Position the line away from the edge of the chip as specified 
in the Position Offset field.

11 TIMER Create a timer for the first application of material. Assign a 
Timer Timeout value of 0 so that the time elapsed between 
the first and second material application will not include the 
time used by commands 4 - 10.

12 PASS(2) Marks the beginning of the second program segment.

13 TIMER Create a timer to ensure a settling time of 10 seconds 
between Pass 1 and Pass 2.

14 CHIPLINE Dispense a second line of material along the edge of the chip 
designated by the Start Corner and End Corner fields.
Shorten or lengthen the line according to the values in the 
Length Offset field.
Position the line away from the edge of the chip as specified 
in the Position Offset field.
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Underfill Sample Program
The above program commands represent the first chip in the carrier. 
Commands 4 - 20 are copied and pasted to the program for the second chip. 
(commands 22-37, not shown).

The only modification required for subsequent chips is to teach the correct X/Y 
coordinate in the NEW_COORD_1 command which offsets the program to the 
location of the next chip.

Figure 14-6

15 TIMER Create a timer specifically for the application of fillet lines. 
Assign a Timer Timeout value of 0 so that the time 
consumed by the second underfill application will not impact 
the TIMER on line 17 below.

16 PASS(3) Marks the beginning of the third and final segment.

17 TIMER Create a timer which will ensure a gap of 15 seconds after 
the last underfill segment before executing the following 
CHIPLINE commands. (Lines 18 - 20)

18-20 CHIPLINE Dispense fillet lines around 3 edges of the chip designated 
by the Start Corner and End Corner fields.
Shorten or lengthen the line according to the values in the 
Length Offset field.
Position the line away from the edge of the chip as specified 
in the Position Offset field.
Do not raise the needle until after the third CHIPLINE so as 
to create a continuous line.

Command Description
XyflexPro Operation And Programming Guide, Benchmark 4.2 14-13
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Encapsulation Applications
Encapsulation Applications

Introduction Dispensing encapsulation programs require the use of the Filled and Unfilled 
Rectangle templates. If you are not familiar with the procedures for creating 
templates see Chapter titled - Creating & Managing Process Programs.

Inserting an Unfilled Rectangle is useful particularly for Dam and Fill applications. 
A Dam of material is dispensed surrounding the part to be encapsulated. The 
purpose of the dam is to contain the fill material to the specific area to be filled.

Usually the Dam material is of higher viscosity then the Fill material so that when 
it is dispensed it will stand up high enough to contain the fill material which is 
generally heated and has a lower viscosity.

Procedure To insert an unfilled rectangle:

1. Place the cursor on the command line of the Process Program Grid where 
you wish to place the unfilled rectangle.

2. Select the  icon from the Process Program Grid toolbar.

The list of previously created Unfilled Rectangle templates appears.

3. Select the desired template from the list.
4. Select the OK button.

The Unfilled Rectangle command is inserted on the command line. Notice that the 
template name appears in the Name field of the process program grid.

If you want to use a different template you can double click the left trackball 
button while pointing at the Name field. The list of previously created Unfilled 
Rectangle templates appears. You can then select from the list and select the OK 
button.
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Encapsulation Applications
Filled Rectangles The Filled Rectangle is used particularly for Dam and Fill and Globtop applications. 
In Globtop applications a fill is dispensed directly in the desired location. In the 
Dam and Fill application a Dam is dispensed around the area to be encapsulated 
prior to dispensing the fill. The purpose of the dam is to contain the fill material to 
that specific area.

Usually the Fill material is a lower viscosity and typically would involve the use of 
a heated dispense unit.

Procedure To insert a filled rectangle:

1. Place the cursor on the command line of the Process Program Grid where 
you wish to place the filled rectangle.

2. Select the filled rectangle  icon from the Process Program Grid toolbar.
The list of previously created Filled Rectangle templates appears.

3. Select the desired template from the list.
4. Select the OK button.

The Filled Rectangle command is inserted on the command line. Notice that the 
template name appears in the Name field of the process program grid.

If you want to use a different template you can double click the left trackball 
button while pointing at the Name field. The list of previously created Filled 
Rectangle templates appears. You can then select from the list and select the OK 
button.
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Using The Weight Scale For The Underfill Process
Using The Weight Scale For The Underfill Process

Introduction The weight scale commands require special attention when using the underfill 
process. The placement of the commands is critical within the Process Program 
Grid. This critical placement is to ensure the sensitive timing necessary in the 
underfill process.

For more detailed description of the weight scale screens and fields refer to 
Chapter titled - Creating and Managing Process Programs.

Example Program This example program will place 5 Chiplines on 6 coupons.

The above example has six coupons to be underfilled. The bottom part of the 
illustration shows the typical movement of the line dispense unit to perform this 
process.

Six Coupons

First two Chipline 
commands

Last three Chipline
commands
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Using The Weight Scale For The Underfill Process
Figure 14-7 lists the commands used to perform this process on the six coupons.

Placement of the weight scale commands are critical. Note that the 
BEGIN_WEIGH command is placed before the first dispense command (placed on 
Line 27, noted by the letter A). The END_WEIGH is placed after the last dispensed 
command (placed on Line 39 of the Process Program Grid, noted by the Letter B).

Figure 14-7

Procedure Place the weigh command into the Process Program Grid as follows:

1. To place the weigh command into the program, highlight the first Chipline 
command (line 26) and all the commands down until the last Chipline com-
mand (line 38).

2. Select the weight scale template icon  from the Process Program Grid 
toolbar. A BEGIN WEIGH and an END WEIGH command will automatically 
appear before and after the selected lines to be weighed.

The system will perform a weigh prior to the first Chipline command and will be 
matched against the previously set Weigh template.

For more detailed description of the weight scale screens and fields refer to the 
Option titled- 725- Weight Scale.

A

B
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Using The Weight Scale For The Underfill Process
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Glossary

A
Alarms There are several alarm types. Some alarms are informative, and alert the 

operator to a condition such as a low material supply. Other alarms require more 
immediate attention, such as those that indicate a machine failure or process 
error. In some cases a triggered alarm will automatically cause the machine to 
stop.

The corrective action for any particular alarm depends on what type of alarm it is. 

Each alarm condition is assigned a severity based on one of four types. They are: 
Operator, Equipment, Material and Warning.

Array Template See XyflexPro Templates.

Auger See Leadscrew.

Automatic Correction 
Vision

The Auto Correction Vision System enables the XyflexPro system to 
automatically compensate for misaligned patterns by comparing the misaligned 
fiducial (see Fiducials) location with the location in memory. It also allows the 
operator to see, using the monitor display, the exact point at which the needle 
will dispense.

Automatic Needle 
Calibrator

The Automatic Needle Calibrator provides automatic calibration of the needle 
length to maintain a consistent needle gap relative to the tip of the touch probe 
(see Touch Probe). The calibrator also adjusts for any deviation of the position of 
the needle tip when the needle is replaced.

B
Bad Mark Sensing Bad mark sensing saves process time by identifying any bad part(s) on a 

substrate. Bad parts are identified with some sort of marking (black marker or 
equivalent) on the substrate and skipped over during program dispensing.

Benchmark® Software Benchmark software consists of two basic components: the client component 
which is essentially the user interface (UI), and the server component which is 
the hardware control portion. There’s an additional component which provides 
the “vision” services (such as pattern recognition); this component is considered 
to be an extension of the server component.

It is designed to work under Windows NT® (see Windows NT operating system 
(See OS) utilizing the networking and security features of the OS).
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C
Camera
Calibration Camera calibration is used to teach the system the relationship between the 

camera’s view of the dispense area (in pixels) to the amount of physical 
movement of the dispense unit.

Cartridge Device for dealing out portions of liquid or semi-liquid (dispense) material utilizing 
an internal rotating device (see Leadscrew).

Command Displays the command necessary to program a dispense pattern. New pattern 
commands will always be inserted after the current highlighted step in the pattern 
and will be executed in the order specified.

Converge When the dispense material at the weight scale meet the set goal (which includes 
the target weight and tolerance). 

CPU Central Processing Unit –Computer.

D
Dispense Height The distance the needle just contacts the board and the tip of the needle (this is 

considered Board Zero). Dimension is established from Home position of the Z-
axis. This is taught by just contacting the needle to the substrate.

Dispense On Down Allows a dot to begin to be dispensed on the down stroke of the dispense unit.

Dispense Unit A device that administers or deals out liquid or semi-liquid parts or portions.

Dot Dwell Determines the amount of time dispense unit stays in the down position after a 
dot is dispensed. This allows the dispense material time to finish flowing from 
needle. The dwell starts when the Dot Size ends.

Dot Size Determines the amount of dispense valve auger rotation, when a dispense 
command is executed. Measured in degrees of rotation.

Dot Template See XyflexPro Templates.

DU See Dispense Unit.

E
Emergency Stop Palm 
Switches

Three switches are provided on the XyflexPro for the fastest and most effective 
means to halt machine operation, should a malfunction occur. All electrical power 
and air pressure to the machine is terminated when pressed except the 
uninterrupted power supply (see UPS). The computer stays on until an operator 
shuts it down or until the computer’s automatic shutdown feature activates.

Encapsulation The process of completely covering a printed board component with dispensed 
material.

End Corner Determines where dispensing will end in an underfill application. Values range 
from zero (0) to three (3) clockwise, with zero indicating the upper right corner. 
This field is used with an underfill application.

E-Stops See Emergency Stop Palm Switches.
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F
Fiducials Also refereed to as “reference” points are used by the XyflexPro system to offset 

and accommodate skewed boards or components. There are four types:

Taught fiducials – are user defined. Actual board details are captured and used to 
off set patterns in production.

Synthetic fiducials – are industry standard board markings which are supplied 
with the XyflexPro Benchmark software. Although the form and shape of 
fiducials are pre-defined, they must be set up before the can be used.

Chip fiducials – are defined fiducials used in the underfill process to locate 
precisely the edges and orientation of the chip.

One Snap fiducials - are defined fiducials normally used on small components. 
This allows the vision system to take one snap shot to capture two reference 
points, which in turn increases throughput by minimizing head movement.

Filled Rectangle 
Template

Stores specific X and Y coordinates, used with:

Dam and Fill applications – In Dam and Fill applications a dam is dispensed around 
the area to be encapsulated prior to dispensing the fill. The purpose of the dam is 
to contain the fill material to a specific area. 

Globtop Applications – In globtop applications a fill is dispensed directly into the 
desired location.

See Underfill.

See Unfilled Rectangle.

First Pass Num Indicates which Pass group will be executed first. A Do Pass command triggers a 
specific Pass group or groups. This field is used with an underfill application.

Fixture Offset Distance (offset) between camera and the fixture (process board).

G
Gantry Rail and beam movable support system traveling in the X and Y axis. This system 

supports the XyflexPro dispense unit Z axis components. These are referred to as 
the X and Y gantry axii.

H
Hard stops Switching device to stop magazine travel.

Head Part of the XyflexPro machine that holds the dispense unit and travels in the up 
and down “Z” axis.

Heated Chucks Heated chucks are an option used to heat the substrate to a set temperature.

Heated Line Dispense 
Unit

Liquid and semi-liquid precision dispensing device. This is designed for 
encapsulation and underfill dispensing operations with the capability of pre-
heating the dispense material prior to dispensing.
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I
Initialization Process System program designed to prime the machine at startup before running.

L
Last Pass Num Indicates which Pass group will be executed last.  A Do Pass command triggers a 

specific Pass group or groups.  This field is used with an underfill application.

Leadscrew Referred to as an auger. - Located inside the dispensing cartridge and is one of 
the methods utilized in dispensing material onto substrate. Leadscrews contain 
loosely pitched screw like threads to move the dispensing material along. The 
greater the pitch, the larger the dispensed volume. Conversely the smaller the 
pitch, the less material is dispensed. The leadscrew pitch is determined by the 
material being dispensed. Coarser and stickier material needs a looser pitch. 
Leadscrew rotation speed, time, air pressure and needle gauge also factor into 
how much material is dispensed – controlled via the software User Interface.

Length Offset Establishes how a line of material will be dispensed relative to the length of the 
part. A value of zero (0) would indicate a line equal to the length of the part 
(corner to corner). A positive number would indicate a line beyond the length of 
the part (offset from the corners).  A negative number would indicate a line short 
of the length of the part (offset from the corners).  This field is used with an 
underfill application.

Lift Height Sets the height the head moves between dispense commands.

Line Delay Determines the amount of auger rotation that the system delays the XY motion 
prior to the start of dispensing a Line command.  During the delay, air pressure is 
applied to the head and the dispensing unit motor turns.  Line Delay allows time 
for higher viscosity materials to start coming out of the needle.

Line Off Advance Determines the amount of travel distance to turn off material to the dispensing 
unit prior to the end of a Line command.  Line Off Advance allows low viscosity 
materials time to stop flowing from the needles.

Line Dispense Unit A liquid and semi-liquid precision dispensing device designed for encapsulation 
and underfill dispensing operations. (See Encapsulation, see Underfill).

Line Template See XyflexPro Templates.

Line Width Specifies the volume of material dispensed in a line.

Link Line Last Establishes when the cartridge in the dispense unit will lift after connecting 
multiple Linkline commands together.

Lockout/Tagout A switch provided to safely disable all power and air from the machine for 
maintenance purposes.  Unlike the emergency palm switch, the Lockout/Tagout 
switch will also instantly remove power from the UPS (see UPS).

Luer Lock Locking fittings with corresponding male/female ends that join a feed tube to a 
syringe or cartridge.

Luer Lock Fitting A joining fitting that accepts Luer Locks (see Luer Lock).
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M
Move Template See XyflexPro Templates.

MSDS Material Safety Data Sheets are provided by manufacturers and distributors of 
hazardous substances.

N

Name Displays the file name that is associated with a Locate or Template command.

Needle Gap Needle gap is the specifically measured space between the very tip of the needle 
and the surface of the substrate.  Deviation from a specified dimension will cause 
dispensed lines or dots undesirable shapes and coverage.

Needle Gauge Needle bore dimension (ID, inside dimension). Appropriate needle gauge is 
determined by the relation to material to be dispensed.

Needle-to-Camera 
Offset

The distance which is taught or programmed to compensation for the distance 
from needle to camera.

O
Offsets Offsets are measured distances (via software) that compensate for the displaced 

distances between one device, usually a sensor or dispense unit, and another. 
These define and establish that the coordinate of one is recognized by the other.

Examples are; needle to camera distance (offset), camera to sensor offset.

Optimize Used to rearrange sequence of dispense pattern commands to ensure most 
efficient path for X- and Y-axes to travel.

OS Operating System – system software upon which specific computer applications 
can be run.

P
Park Position The park position is the “X” and “Y” coordinates for the dispense head to move 

to while the next board is being loaded.

Pass Num The specific number assigned to a Pass group of commands.  This field is used 
with an underfill application.

Pattern Files Dispensing pattern files that are application specific. These files are either created 
on the local XyflexPro computer or introduced as imported CAD based data.

Pixels The smallest image-forming unit of a video display.
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Pneumatic Dump
Valve The Pneumatic Dump Valve works in conjunction with the three emergency stop 

palm switches. Whenever a emergency stop switch is pressed, the dump valve 
opens, discharging all air pressure safely from within the machine.

Position Offset Establishes how far away a line of material will be dispensed relative to the edge 
of a part.

Pre-Dispense Dot 
Template

See XyflexPro Templates.

Pre-Dispense 
LineTemplate

See XyflexPro Templates.

Pre-Dispense
Station Pre-dispensing is a submenu that is programmed that serves as a dispensing 

primer to assure consistent dots or lines on the substrates. This ensures that 
there is no residual material on the needle prior to dispensing on the actual 
product. The submenu is repeated after specified number of substrate cycles. 

Process Programs These are files containing the values and parameters created for a particular 
process run.

Purge The method of normally expelling material from the dispense unit when a new 
syringe is installed (to remove air) or to expel aged material.

R
Reference Designator Identifies a specific component on the process board.  Some examples of this are 

C101, R203, and U7.  These are normally printed on the board, provided there is 
space.  The reference designator enables the user to search for a specific 
component.

RPM Determines the rotation speed (in revolutions per minute) of a dispense unit while 
dispensing.

S
Shape Code Defines a generic component type.  Each component has a shape code based on 

its physical configuration and dimensions.  One example of this is for 1206 
resistor.  There is one part number for each resistor value.

SMEMA A handshaking signal standard established by the Surface Mount Equipment 
Manufacturer’s Association for the communication between feed and receive 
devices in the semiconductor/PCB industry.

Start Corner Determines where dispensing will start in an underfill application. Values range 
from zero (0) to three (3) clockwise, with zero indicating the upper right corner. 
This field is used with an underfill application.

SPC Data The XyflexPro system is equipped to record SPC (Statistical Process Control) data 
of certain events selected from the SPC Data tab menu on the Configuration 
screen. Each event that is selected from the menu is logged onto a text file (.txt) 
and may be analyzed offline as an Excel® file.
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Syringe A small container, much like a hypodermic syringe, filled with liquid or semi-liquid 
dispense material. 

Syringe Adapter Adapter that connects the dispense unit’s air supply (from the top of the DU) to 
the top of the syringe.  See Syringe.

Syringe Low Level 
Limit Switch

The Syringe low level limit switch is used to set material limits in a syringe. This 
alerts the operator when material limits are getting low in the syringe by an alarm 
condition on the monitor.

T
Target Weight This is the ideal weight to achieve and maintain for a particular process pattern. 

This is set when using the optional weight scale.

Templates Templates allow the convenience of storing and recalling dispense parameters 
used for dispense routines.

Theta Performs a rotation of a block of commands contained within a NewCoord 
command.

Timer Timeout The amount of time assigned to a XyflexPro timer command. A Timer command 
assures that a specified amount of time has passed between the execution of one 
command and the execution of the next. This field is used with an underfill 
application.

Tolerance The amount of deviation allowed from the Target Weight and still be able to 
Converge. This is set when using the optional weight scale.

Touch Probe The Touch Probe sensor allows the dispense head to maintain an appropriate and 
consistent dispense height when varying heights on the substrate are 
encountered.

Trackball A graphic user interface pointing and selection device. Similar to a PC mouse but 
remains stationary while a ball above the device is rotated for cursor/pointer 
navigation. Selections are made with attached selection buttons.

Transition Down Sets the distance for which head will run at slow speed when lowering to a 
dispense operation.  Used to eliminate overshoot in the Z-axis.

Transition Up Height Sets the distance for which head will run at slow speed when raising from a 
dispense operation.  Used to eliminate tailing tendency of some dispense 
materials.

U
Underfill Underfilling is the process of dispensing material under a component such that it 

wicks under that component from one end to the other. This is done in critically 
timed application pattern segments to allow this wicking process to take place 
without the formation of air pockets. The dispense needle is placed very close to 
the surface of the component.

Unfilled Rectangle 
Template

Useful particularly for dam and fill applications. A dam of material is dispensed 
surrounding the part to be encapsulated. The purpose of the dam is to contain the 
fill material to the specific area to be filled. 
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Usually the dam material is of higher viscosity than the fill material so that when 
it is dispensed it will stand up high enough to contain the fill material which is 
generally heated and has a lower viscosity.

UI User Interface – software controls.

UPS Uninterrupted Power Supply.  A backup power source for the internal computer. 
If the main power fails, it allows time to perform a controlled computer 
shutdown.

V
Vision Window Window in Benchmark software that allows camera viewing.

W
Weight Scale This optional measurement system is used to ensure exactness and consistency 

in the amount of material deposited. The system software performs the 
adjustments as required to meet a Target Weight.

Weight Template The template used with the weight scale to set the Target Weight and Tolerance. 
This template is placed in the program by inserting a command line in the Pattern 
Grid.

Windows NT® Operating system for networks and network security.

Windows NT® Server Operating system generally used by network shared services.

Windows NT® 
Workstation

Operating system generally used as a stand alone computer not connected to a 
network.

X
X Axis Side to side (left to right) travel.

X Position Specifies the X-axis dispense position.

X’ Position Specifies the X end position for a Line or Linkline command.

XyflexPro Templates XyflexPro templates allow the convenience of storing and recalling often used 
dispense routines.

Dot - Contain settings for all the basic dispensing parameters that are related to 
the SMT process.

Line - Contain settings for all the basic dispensing parameters that are related to 
Underfill or Encapsulation process.

Move - Contain settings related to moving the dispense unit.

Unfilled Rectangle - Store specific X and Y coordinates.

Filled Rectangle - Store specific X and Y coordinates.

Predispense Dot - Store information related to the execution of pre-dispense.

Predispense Line - Store information related to the execution of pre-dispense.
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Array - Template are used to create a pattern of multiple equally spaced dots 
within a defined space (matrix).

Weight - The template used with the weight scale to set the Target Weight and 
Tolerance. This template is placed in the program by inserting a command line in 
the Pattern Grid.

Y
Y Axis Forward and backward (front to back) travel.

Y Position Specifies the Y-axis dispense position. 

Y’ Position Specifies the Y end position for a Line or Linkline command.

Z
Z Axis Up and down travel.
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	System Startup
	Introduction
	Use extreme caution if the system is reset without a full Power Down. Motion from the Lift Chuck ...
	This procedure is for normal system startup of the XyflexPro. It is assumed that the system was p...
	Procedure
	1. Push the green Machine On push-button (identified by an I)(located on the right front panel) t...
	2. Open the front door to gain access to the Uninterruptible Power Source (UPS) and Computer. See...
	Figure 4-1

	3. Press the round Power On push-button (identified by an I) on the front panel of the UPS.
	4. The computer starts up. If the computer does not start up, press the Power On push-button loca...
	5. Press Ctrl + Alt + Delete keyboard keys together when prompted. A login window appears.


	All users must be assigned a user name and password in order to access the Benchmark software. If...
	6. Type your user name and password and press Enter. The Benchmark Main screen will appear. See F...
	Figure 4-2

	7. Select File >Connection. The Connection dialog box appears. See Figure 4- 3.
	Figure 4-3

	8. Select the following: Connect as Local - Master radio button and the Enable automatic connecti...
	9. Select OK.
	Figure 4-4

	10. Select the Initialize button.
	Figure 4-5

	11. Unlock the safety door and remove and replace the purge cups at each head as described on the...
	12. When all the purge cups have been replaced and the safety door is down and locked, press the ...


	Safety Door Lock/Unlock
	Introduction
	Door Lock/Unlock Icon
	Figure 4-6

	Unlocking the Safety Door Manually
	1. Insert the tapered end of the manual release tool into the access hole in the right side of th...
	Figure 4-7

	2. Push the tool straight in until the end engages the lock mechanism.
	3. While lifting the door, move the tool straight down until the lock releases.
	4. Raise the safety door.


	System Shutdown
	System Disconnect
	1. Make sure safety door is closed and locked.
	2. Select File>Disconnect from the Machine screen.
	Figure 4-8


	The operator has a choice at this point either to leave the system alone (idle) at this screen fo...
	Powering Down the System
	1. Exit the Benchmark software by clicking on the X in the upper right-hand corner of the screen.
	2. Select the Windows NT® Start menu (located in the lower left-hand corner).
	3. Select Shut Down from the menu.
	4. Select Shut down the computer? radio button from the list. See Figure 4-9.
	Figure 4-9



	If the computer is reset without having fully powered down the machine, motion from the Lift Chuc...
	Figure 4-10
	5. Press the white Machine Off push button on the right front panel. See Figure 4-11.
	6. Turn Off the UPS with the round Push button. See Figure 4-1.
	Figure 4-11



	E-Stop And Recovery
	Introduction
	If the UPS is not turned off, the battery will gradually discharge until normal system power is r...
	Recovery Procedure
	1. Turn the E-STOP switch clockwise while pulling it out. (If E-STOP was used.)
	2. Press the blue Reset button on the right front system panel. See Figure 4-11.
	3. Startup the XyflexPro normally. Refer to section titled - System Startup.



	Routine Maintenance
	Dispense Units
	Be sure the applicable Material Safety Data Sheet (MSDS) Warnings are observed.
	Conveyor Rails
	Conveyors And Heated Chucks



	Overview
	Introduction
	Use extreme care when working around Conveyor Hard Stops, Lift Chucks, and Edge clamps. These com...
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	Adjusting Conveyor Hard Stops
	Procedure
	1. Loosen the socket head cap screw and position stop along the slide. Position stop so that the ...
	2. Tighten the cap screw after the stop is set at the desired location between the front and rear...
	Figure 5-1
	Figure 5-2



	Adjusting Conveyor Width
	Procedure
	1. Select View > Diagnostics or select the Diagnostics icon. Select the Conveyor Maintenance tab....
	Figure 5-3

	2. Place the process board onto the conveyor belts. Determine whether or not the conveyor rail wi...
	3. Select the Jog Increment field. Enter a value that will jog the rear rail either open or close.
	4. Press the Jog button until the conveyor width opening matches the process board width.
	5. Select the Close button to close the Diagnostics screen.


	Setting Conveyor Speed
	Introduction

	Loading Boards Onto The Conveyor
	Conveyor Modes
	Procedure
	1. Select Operations>Conveyor Mode>Automatic from the Machine screen. See Figure 5-4.
	2. The conveyor mode may also be selected as follows:
	a. Move cursor from the Machine screen down to the Conveyor Status window, located in the lower r...
	b. Click the right button on the trackball and a pop-up list of conveyor modes will appear.
	c. Click the left or right button to select the Automatic mode.
	Figure 5-4
	Figure 5-5

	3. Select View > Diagnostics or select the Diagnostics icon from the Machine screen.
	4. Select the Conveyor Maintenance tab. See Figure 5-3.
	5. Select the Heads to which you want to load boards by placing a check in the Hold/Release Board...
	6. Place a board onto the conveyor upstream of Head 1 so that the upstream (input) sensor is made.
	7. Select Upstream Board Available from the Conveyor Message To Send list box.

	The Motor On button may be pressed at any time to activate the conveyor. This is normally used to...
	8. Select the Send Message button.


	Setting The Heated Chuck Temperature
	Introduction
	Temperature Controller (only visible through system software)
	Figure 5-6


	Procedure
	1. Select View>Configuration>Temperature tab from the Machine screen. Each heated chuck temperatu...
	Figure 5-7

	2. Select the arrow next to the Controllers drop down box. Scroll down the list until the desired...
	3. Check the Enable Communications box) to supply heat to chuck in the Controllers field.
	4. Select the Setpoint field. Using the keyboard enter the desired temperature.
	5. Select the Alarm Range field. Using the keyboard enter the desired temperature deviation from ...
	6. Select the OK button.
	7. Repeat step 2 through step 6 for the remaining heated chucks.

	Heated Chuck Alarm Condition
	Color Display
	Message
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	Camera Calibration
	Introduction
	Procedure
	Selecting the Cancel button at any point aborts the procedure.
	1. Be sure that the safety door is closed and locked.
	2. Select Calibrate>Camera. The Camera Calibration screen appears. See Figure 6-1.
	Figure 6-1

	3. Read the on-screen notes regarding the calibration and select the Next> button. A selection bo...
	Figure 6-2

	4. Select Head 1 in the selection box, and select the Next> button. A vision window appears in th...
	Figure 6-3

	5. Select the Trackball button.
	6. Using the trackball, move the crosshairs in the Vision window to the center of a unique refere...
	7. If necessary, adjust the camera focus and lighting to desired settings as follows:
	a. Select the Camera Settings button. The Camera Settings screen appears. See Figure 6-4.
	b. Adjust the Zoom, Brightness, and Contrast as desired by selecting the applicable up or down ar...
	c. After desired settings are complete, select the Close button.
	Figure 6-4

	8. If necessary, adjust the Model Size and/or Search Areas as follows. See Figure 6-3.

	The Model Size and Search areas are represented in the vision window by green bounding boxes. The...
	a. Place the pointer on any one of the square handles at the corners of the bounding box.
	b. Click on a handle (a double headed arrow appears).
	c. Using the trackball change the size of the box to properly surround the reference mark.
	d. Click the left trackball button to accept the change.
	9. Select the Next> button. The system attempts the Camera Calibration with the above information.
	Calibration Successful
	Figure 6-5

	Calibration Error
	Figure 6-6



	Manual Calibration Of Camera-To-Needle Offset
	Introduction
	Head Selection And Dispense Properties
	Selecting the Cancel button at any point aborts the process.
	1. Select Calibrate>Camera-to-Needle Offset or select the Camera-to-Needle Offset icon (if enable...

	If the Camera-to-Needle Offset icon does not appear on the Configurable toolbar, refer to chapter...
	Figure 6-7
	2. Read the on-screen notes and select the Next> button. A selection box is displayed in the Came...
	Figure 6-8

	3. Select the Head you wish to calibrate from the list or select the check box below the list if ...
	4. Select the Next> button. Two buttons are displayed in the Camera-to-Needle Offset screen. You ...
	Figure 6-9

	5. If you want to use another location, see the section titled - Teaching An Alternate Test Dot L...
	6. Select the Next> button. A group of dispense properties fields is displayed in the Camera-to-N...
	Figure 6-10

	7. Adjust the dispense properties values for the Dot Size, Lift Height, Dispense Height (0 if usi...
	8. Verify the modified dispense properties by selecting the Dispense a Test Dot button.
	9. Repeat steps 7-8 until the test dot is acceptable.
	10. Select the Next> button. The Dispensing Test Dot screen appears. See Figure 6-11. The test do...
	Figure 6-11

	11. Proceed to the next section titled - Performing The Calibration.
	Performing The Calibration
	1. From the Dispensing Test Dot screen, select the Next> button to start the calibration. The nee...
	2. Refer to the sections titled - Calibration Successful or Calibration Error.

	Calibration Successful
	Figure 6-12
	1. Select the Next> button to display the newly calculated X and Y Camera-to- Needle Offset value...
	2. Select the Save button to accept the new calibration coordinates. You are returned to the Mach...
	Figure 6-13


	Calibration Error
	Figure 6-14
	1. Select the Find Dot Manually button. Camera Settings and Trackball buttons are displayed in th...
	Figure 6-15

	2. Select the Trackball button and align the crosshairs in the vision window over the center of t...
	3. When the crosshairs are properly aligned, click the left trackball button. This teaches the X ...
	4. Select the Save button.

	Teaching An Alternate Test Dot Location
	1. Select the Use other location radio button from the Camera-to-Needle Offset screen. See Figure...
	2. Select the Trackball button.
	3. Position the camera crosshairs over the desired location.
	4. When the crosshairs are positioned correctly, click the left trackball button.
	5. Select the Next> button.



	Calibration Of Camera-To-Needle Offset (Automatic)
	Introduction
	Procedure
	1. Select Calibrate>Camera-to-Needle Offset Auto or select the Camera-to- Needle Offset Automatic...
	2. The test dot dispense location must be clean in order for the vision system to properly evalua...
	Figure 6-16

	3. Select the Next> button to perform the calibration. A vision window is displayed briefly while...
	Figure 6-17



	Setting Dispense Head Park Position
	Introduction
	Figure 6-18

	Procedure
	1. Create or load a process program.
	2. Navigate to the Properties screen:
	3. Select a head from the Select Head field.
	4. Select a Dispense Unit from the Dispense Unit Type field.
	5. Select the Trackball XY button, the vision window appears next to the properties screen.
	6. Using the trackball, position the cross-hairs to the desired position and click the left track...
	7. Select the Save button.
	8. Select the Close button.


	Teaching Fixture Position Offset
	Introduction
	Procedure
	1. Load a board onto the conveyor into the dispense zone.
	2. Select View>Diagnostics The Diagnostics screen appears.
	3. Select the Motion Control tab. The Motion Control screen appears. See Figure 6-19.
	Figure 6-19

	4. Select Head 1 from the Moveable Part field.
	5. Select Fixture Position from the Set Commanded Position field.
	6. Select the Trackball X and Y button. A vision window with a set of crosshairs appears. The tra...

	The X and Y coordinates are shown in the Actual Position column and change when the head is moved...
	7. Using the trackball, align the intersection of the crosshairs with the front- right corner of ...
	Figure 6-20

	8. When the crosshairs are aligned properly, click the left button on the trackball (this teaches...
	9. If further adjustment is required, select the Trackball button in the vision window and repeat...
	10. Select the Close button in the vision window.
	11. Select the Save Actual Position as Commanded Position button. The new Fixture Position is sto...
	12. Select the Close button to close the Diagnostics screen.


	Setup Of The Pre-Dispense Station
	Introduction
	Procedure
	1. Select Calibrate>Pre-Dispense Plate(s). The Pre-dispense plate calibration screen appears as s...
	Figure 6-21

	2. Read the on-screen notes and select the Next> button
	3. Using the keyboard, enter the number of dispense plates (1 or 2) in the box provided.
	4. Select the Next> button. A vision window appears in the Pre-dispense plate calibration screen....
	Figure 6-22


	The starting point for the Pre-Dispense Station is always set on the Back-Left corner of plate 1....
	5. If necessary, adjust the camera focus and lighting to desired settings as follows:
	a. Select the Camera Settings button. The Camera Settings screen appears. See Figure 6-23.
	Figure 6-23
	b. Adjust the Zoom, Brightness, and Contrast as desired by selecting the applicable up or down ar...


	6. Select the Trackball button.
	7. Using the trackball, move the crosshairs to a position near the Back- Left corner of plate 1. ...
	8. Click the left trackball button to teach this point. If further adjustment is required, select...
	Figure 6-24

	9. Select the Next> button.
	10. Using the trackball, move the crosshairs to a position near the Front- Right corner of plate ...
	11. Click the left trackball button to teach this point. If further adjustment is required, selec...
	12. Select the Next> button.
	13. Using the trackball, move the crosshairs to a position near the Back-Left corner of plate 2. ...
	14. If further adjustment is required, select the Trackball button and repeat step 13.
	15. Select the Next> button. The current and newly calculated Pre-dispense coordinates are shown ...
	16. Select the Save button to accept the new Pre-dispense coordinates. You are returned to the Ma...
	Figure 6-25



	Teaching The Camera-To-ZSense Offset
	Introduction
	Camera-to-ZSense Offset
	1. Load a sample board at the dispense position on the conveyor.
	2. Select Calibrate>Camera-to-ZSense Offset. The Camera-to-ZSense Offset screen appears. See Figu...
	Figure 6-26

	3. Read the on-screen notes, and select the Next> button.
	4. A vision window appears in the Camera-to-ZSense Offset screen. See Figure 6-27.
	Figure 6-27

	5. If necessary, adjust the camera focus and lighting to the desired settings as follows:
	a. Select the Camera Settings button. The Camera Settings screen appears. See Figure 6-28.
	Figure 6-28
	b. Adjust the Zoom, Brightness, and Contrast as desired by selecting the applicable up or down ar...


	6. Select the Trackball button.
	7. Using the trackball, center the crosshairs over a reference mark such as a fiducial on the sam...
	8. Click the left trackball button when the crosshairs are properly positioned.
	9. If further adjustment is required, select the Trackball button and repeat steps 6 and 7.

	When the Next> button is selected the head moves over and fires the ZSense device. The safety doo...
	10. Select the Next> button. The system attempts to align the ZSense with the reference point you...
	11. If the Zsense is not aligned properly with the reference mark:
	a. Select the Trackball button in the Camera-to-ZSense Offset screen. See Figure 6-29.
	Figure 6-29
	b. Using the trackball, visually align the ZSense with the reference point.
	c. Click the left trackball button.


	12. Select the Next> button after the correct the ZSense location is taught. The current and newl...
	13. Select the Save button to accept the new calibration offset.
	Figure 6-30



	Setting The Location Of The Weight Scale (Option)
	Introduction
	Procedure
	Selecting the Cancel button at any point aborts the procedure.
	1. Select Calibrate>Weight Scale Position. The Weight scale(s) calibration screen appears. See Fi...
	Figure 6-31

	2. Read the on-screen notes, and select the Next> button. Trackball and TrackballZ buttons are di...
	Figure 6-32


	Prior to teaching any coordinates for the Weight Scale, be sure the sliding glass cover is in the...
	3. Select the Trackball button.
	4. Using the trackball, move the dispense unit over the sliding glass cove r. The needle tip shou...
	Figure 6-33

	5. When the needle tip is in the desired location click the left trackball button.
	6. Select the Trackball Z button. Using the trackball, lower the needle of the dispense unit thro...
	Figure 6-34

	7. Click the left trackball button.
	8. Select the Next> button in the Weight scale(s) calibration screen. The current and newly calib...
	Figure 6-35

	9. Select the Save button to accept the new calibration coordinates.


	Teaching The Needle Calibrator Sensor Position
	Introduction
	Procedure
	1. Select View>Diagnostics.
	2. Select the Motion Control tab from the Machine screen. The Motion Control screen appears. See ...
	Figure 6-36

	3. At the Moveable Part drop down list, select the head you wish to teach.
	4. In the Set Commanded Position field, select Needle Calibrator Sensor Position.
	5. Select the Trackball X and Y button. A vision window with a set of crosshairs appears and the ...
	6. Using the trackball, move the head until the intersection of the crosshairs is aligned over th...
	Figure 6-37


	As you move the head with the trackball, the current X and Y coordinates are updated in the Move ...
	7. When the crosshairs are positioned correctly, select the left trackball button.
	8. If further adjustment is required, select the Trackball button in the vision window and repeat...
	9. Select the Close button in the vision window.
	10. Select the Save Actual Position as Commanded Position button. The system saves the new sensor...
	11. Select the Close button to close the Diagnostics screen. You are returned to the Machine screen.


	Conveyor Speed Calibration
	Introduction
	Procedure
	1. Select Operations>Conveyor Mode>Off from the Machine screen.
	2. Load a board onto the output sensor of an upstream machine.
	3. Close and lock the safety door(s).
	4. Select View>Diagnostics. The Diagnostics screen appears.
	5. Select the Conveyor Maintenance tab. The Conveyor Maintenance screen appears. See Figure 6-38.
	Figure 6-38

	6. Select the Start Speed Test message in the Select Conveyor Message To Send list box.

	The Motor On button may be pressed at any time to activate the conveyor. This is normally used to...
	7. Select the Send Message button. After approximately 2 seconds, the board that was placed in th...
	8. Select the Close button to close the Diagnostics screen. You are returned to the Machine screen.


	Teaching The Purge Cup Position
	Introduction
	Procedure
	1. Select Calibrate>Purge Cup Position. See Figure 6-39.
	Figure 6-39
	Figure 6-40

	2. Read the on screen notes and select the Next> button.
	Figure 6-41

	3. Select the desired Head from the list and select the Next> button.
	Figure 6-42


	Prior to teaching any coordinates for the Purge Cup, be sure the sliding glass cover is in the cl...
	4. Select the Trackball button.
	5. Using the trackball, move the dispense unit over the sliding glass cove r. The needle tip shou...
	Figure 6-43

	6. When the needle tip is in the desired location click the left trackball button.
	7. Select the Trackball Z button.
	8. Using the trackball, lower the needle of the dispense unit as necessary to contact the cone st...
	9. Click the left trackball button.
	10. Select the Next> button in the calibration screen. The current and newly calibrated locations...
	Figure 6-44

	11. Select the Save button to accept the new coordinates.


	Teaching The Syringe/DU Change Position
	Introduction
	Procedure
	1. Select Calibrate>Syringe/DU Change Position. See Figure 6-45.
	Figure 6-45
	Figure 6-46

	2. Read the on screen notes and select the Next> button.
	Figure 6-47

	3. Select the desired Head from the list and select the Next> button.
	Figure 6-48

	4. Select the Trackball button.

	When moving and removing the dispense unit or syringe be careful not to damage the needle. Hold t...
	5. Using the trackball, move the dispense unit towards the front of the machine in a convienent l...
	6. When the DU is in the desired location click the left trackball button.
	7. Select the Next> button. The current and newly calibrated locations are displayed in the Syrin...
	Figure 6-49

	8. Select the Save button to accept the new coordinates.
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	Main Machine Toolbar
	Introduction
	Toolbar Icons

	Configurable Toolbar
	Introduction
	Figure 7-1

	Displaying Icons
	1. Select the button(s) to be displayed and select the Add>> or Add ALL>> button.
	2. Select the OK button.

	Removing Icons
	1. Select the button(s) to be removed and select the <<Remove or <<Remove All button.
	2. Select the OK button.

	Rearranging Icons
	1. Select the button(s) to be rearranged and select the Move Up or Move Down button as desired.
	2. Select the OK button.

	Toolbar Icons
	Only those individuals assigned privileges are allowed to perform or change system calibrations a...

	Process Program Grid
	Description

	Process Program Commands Toolbar
	Description
	Toolbar Icons

	Process Program Grid Fields
	Introduction
	Field Definitions

	Block Editing
	Introduction
	Procedure
	1. Load the Process Program to be edited. See Figure 7-1.
	Figure 7-2

	2. Select the column to be edited. The example in Figure 7-1 shows the Line Width column selected...
	a. Using the trackball, move the cursor over the cells to be edited. Press the left button on the...
	b. Press and hold the Shift key on the keyboard. Move the cursor vertically to the last cell to b...

	3. Change the values in the selected cells by using the number pad on the keyboard. Press Enter t...
	Figure 7-3
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	Creating A New Process Program
	Introduction
	Procedure
	1. Select File>Process Programs. A list box of existing process programs is displayed. See Figure...
	Figure 8-1

	2. Click the left trackball button to activate the Name: field.
	3. Type a new program name of your choice in place of the existing name.
	4. Select the New button. A Comments: box is displayed. See Figure 8-2.
	5. Enter any relative information about this new program. (Part Number, Board Size, Material, etc...
	Figure 8-2

	6. Select the Next button. Several buttons and Properties fields are displayed. See Figure 8-3.
	7. Assign program properties as required. See the section titled - Assigning File Properties.
	8. Select the Save button.


	Assigning Properties
	Introduction
	Property Fields
	Figure 8-3

	Setting File Properties

	Importing Files
	Introduction
	Procedure
	1. Select File>Import from the Machine screen. See Figure 8-4.
	Figure 8-4

	2. Select the Look In field and select the folder that contains the file to be imported. If neces...
	3. Select the files to be imported from the left-hand column. In Figure 8-4 three files are selec...
	4. Select the Add>> button to move the files over to the right-hand column under the field labele...
	5. If a file was placed in the File To Import column inadvertently, select the file and then the ...
	6. Select the Import button when all the required files are in the File To Import column.
	Figure 8-5

	7. Select the OK button on the screen. You are returned to the Import screen.
	8. Repeat step 2 through step 7 for additional files to be imported or select Close to return to ...


	Inserting Program Commands
	Introduction
	Figure 8-6


	Saving The Process Program
	Save Program Changes
	Select
	Figure 8-7


	Editing An Existing Process Program
	Procedure
	1. Select File>Process Programs. A list of existing Process Programs appears. See Figure 8-8.
	2. Select a program from the list.
	Figure 8-8

	3. Select the Edit button.
	4. To view the program, select View>Process Program. The program commands are displayed in the pr...


	Assigning Units Of Measure
	Introduction
	Procedure
	1. Select View>Configuration and select the Display Settings tab. The Configuration view appears....
	2. Select Inches or Millimeters from the Display Units group.
	3. Use the up and down arrows in the Decimal Precision field to establish the number of decimal p...
	4. Select OK to return to the Machine screen.
	Figure 8-9



	Creating And Assigning Fiducials
	Before teaching any fiducials, be sure that the vision system is calibrated. Refer to the Chapter...
	Introduction


	Creating A Taught Fiducial
	If all of the fiducials you use are identical, you need only teach one, which can be applied to a...
	Procedure
	1. Select File>Locate. A list of previously created fiducials appears. See Figure 8-10.
	Figure 8-10

	2. Type a new name for the fiducial.
	3. Select the New button. A pop up list of fiducial types appears.
	4. Select Taught from the list. A comment box appears. See Figure 8-2.
	5. Enter any relative information about this new file (Part Number, Board Size, Material, etc.) i...
	6. Select the Next> button. A vision window appears. See Figure 8-11.
	Figure 8-11



	A clear image with well defined edges is required in order to correctly identify fiducials. This ...
	7. If necessary, adjust camera focus and lighting to desired settings as follows:
	a. Select the Camera Settings button. Camera Settings screen appears. See Figure 8-12.
	Figure 8-12
	b. Adjust the Zoom, Brightness, and Contrast as desired by selecting the applicable up or down ar...



	The Model Size and Search areas are represented in the vision window by green bounding boxes. The...
	8. If necessary, adjust the Model Size and/or Search Areas as follows (See Figure 8-11):
	a. Place the pointer on any one of the square handles at the corners of the bounding box.
	b. Click on a handle (a double headed arrow appears).
	c. Using the trackball change the size of the box to properly surround the reference mark.
	d. Click the left trackball button to accept the change.

	9. Select the Center Regions button, this makes the Model Size and Search Area boxes concentric.
	10. Select the Trackball button and use the trackball to align the intersection of the crosshairs...
	11. When the fiducial is properly centered, click the left trackball button.

	The vision system validates each fiducial based on the quality of the image. A user specified Thr...
	12. Select the Threshold field and type in the desired value. See Figure 8-11.
	13. Select the Teach button. The Score, Contrast and Brightness values are displayed.
	14. If the values are acceptable, select the Finish button. You are returned to the list of fiduc...


	Configuring Synthetic Fiducials
	Introduction
	Procedure
	1. Select File>Locate. A list of previously created fiducials appears. See Figure 8-10.
	2. Select the file listed in the Name field.
	3. Type a new file name of your choice in place of the existing file name.
	4. Select the New button. A pop up list appears with the four types of fiducials.
	5. Select Synthetic from the list. A comment box appears. See Figure 8-2.
	6. Enter any relative information about this new file (Part Number, Board Size, Material, etc.) i...
	7. Select the Next button. A Shape window and several fields and buttons are displayed on the scr...
	Figure 8-13

	8. Enter/select the appropriate settings to establish the characteristics of the new fiducial acc...
	Field/Button
	Description
	9. After specifying the properties for the new fiducial, select the Teach button.
	10. Select the Test button.
	11. Note the score value in the box to the right of the Test button. A score of 90 or above is co...
	12. If necessary modify the fiducial properties and retest until a satisfactory score is achieved.
	13. Select the Finish button.



	Creating One Snap Fiducials
	Introduction
	Procedure
	1. Select File>Locate. A list of previously created fiducials appears. See Figure 8-14.
	Figure 8-14

	2. Type a new name for the fiducial.
	3. Select the New button. A pop up list of fiducial types appears.
	4. Select One Snap from the list. A comment box appears. Refer to Figure 8-2.
	5. Enter any relative information about this new file (Part Number, Board Size, Material, etc.) i...
	6. Select the Next> button. A vision window appears as shown in Figure 8-11.
	7. If necessary, make adjustments to the camera’s focus and lighting and to the Model Size and Se...
	8. Select the Trackball button and use the trackball to position the camera so that both fiducial...
	9. When properly positioned, click the left trackball button.
	10. Using the handles drag and adjust the Search Area and Model Size bounding boxes so that they ...
	11. Select the Teach button.
	12. The Score, Contrast and Brightness values are displayed.
	13. If the values are acceptable, select the Next button.
	Figure 8-15

	14. Select the Trackball button.
	15. Using the handles drag and adjust the Search Area and Model Size bounding boxes so that they ...
	16. Select the Teach button.
	Figure 8-16

	17. The Score, Contrast and Brightness values are displayed.
	18. If the values are acceptable, select the Finish button.


	System Templates
	Introduction

	Creating A Template
	Introduction
	Procedure
	1. Select File>Template. A screen appears with a list of existing templates. See Figure 8-17.
	Figure 8-17

	2. Select the desired template type from the drop down Filter list. The Name field is highlighted.
	3. Type a file name of your choice over the highlighted file name.
	4. Select the New button. A comment box appears on the screen.
	5. Enter any relative information about this template (Part Number, Board Size, Material, etc.) i...
	6. Select the Next button.
	7. A list of property fields and buttons, appropriate to template type is displayed.

	The section titled Process Program Grid Fields contains detailed information on all dispensing pr...
	8. After entering values for each field, select the Finish button. The template data is saved in ...


	Dot, Line And Move Templates
	Introduction
	Applying The Template
	1. Insert or select an existing Dot, Line or Move command.
	2. Use the scrollbar at the bottom of the Program Grid if necessary to display the Name column.
	3. Place the pointer over the Name column cell on the command line and double click the left trac...
	4. Select the desired template name from the drop down list.
	5. Select the OK button. The properties of the selected template are applied to the command.
	Figure 8-18



	Weight Scale Templates
	Introduction
	Creating The Template
	1. Select File>Template. A screen appears with a list of existing templates. See Figure 8-17.
	2. Select the Weight Scale template type from the drop down Filter list.
	3. Type a new file name in the Name field.
	4. Select the New button. A comment box appears on the screen.
	5. Enter any relative information about this template (Part Number, Board Size, Material, etc.) i...
	6. Select the Next button.
	7. A list of property fields and buttons is displayed on the screen. See Figure 8-19.
	Figure 8-19

	8. Enter the template properties. See the section titled Weight Scale Template Properties.
	9. Select the Finish button.

	Weight Scale Template Properties
	Field/Button
	Description

	Using The Weight Scale Calculator
	Figure 8-20
	Field
	Description
	1. Insert the proper information into the appropriate fields.
	2. Select the OK button. The calculation is performed.
	3. If the value in the Calculated Weight field is acceptable, select the OK button. The calculate...


	Applying The Template
	1. Load a process program.
	2. Select View>Process Program to display the Program Grid.
	3. Using the trackball, select the command lines that will be subject to the weigh process. In Fi...
	Figure 8-21

	4. Select the Weigh Selected Commands icon from the toolbar. A list of Weight Scale templates app...
	5. Select the appropriate Weight Scale template.
	6. Select the OK button. A Begin Weigh command is inserted before the selected lines and an End W...
	7. Use the scrollbar at the bottom of the Program Grid if necessary to display the Name column. T...


	Filled And Unfilled Rectangle Templates
	Introduction
	Special Fields
	Field
	Description
	Figure 8-22
	Figure 8-23
	Figure 8-24


	Applying The Template
	1. Insert or select an existing Filled Rectangle or Unfilled Rectangle command.
	2. Use the scrollbar at the bottom of the Program Grid if necessary to display the Name column.
	3. Place the pointer over the Name column cell on the command line and double click the left trac...
	4. Select the desired template name from the drop down list.
	5. Select the OK button.


	Creating A Diamond Shape
	Procedure
	1. Place the pointer on a line of the program grid where you wish to place a diamond. Select Unfi...
	2. Type a file name of your choice over the highlighted file name.
	3. Select the New button. A comment box appears on the screen.
	4. Enter any relative information about this template (Part Number, Board Size, Material, etc.) i...
	5. Select the Next button.
	6. A list of property fields and buttons, appropriate to template type is displayed.
	7. Using the trackball, place the cursor over the grid of the template and right click.
	Figure 8-25

	8. Left click the trackball and a vision window appears.
	9. Using the trackball and the vision window, drive the crosshair over to the first point of the ...

	The system has the capability of dispensing in either a clockwise or counterclockwise direction. ...
	10. Repeat step 4 for the second and third points.
	Figure 8-26

	Running The Diamond Shape
	1. Load a process program.
	2. Place the cursor on the command line of the grid where the diamond shape is to be inserted.
	3. Select Unfilled Rectangle from the top of the Process Program Commands Toolbar .
	4. Select the unfilled rectangle template previously created.
	5. Select OK.
	6. Move the crosshair over to a desired start point. Select the left trackball button.
	7. Select the Start Operations button.

	Adding A Rectangular Offset To The Diamond Shape
	1. Create the Unfilled Rectangle template for a diamond shape. Refer to section titled - Creating...


	The Rectangular Offset places the start point of the dispensed line between the first two points....
	Figure 8-27
	2. Open the Unfilled Rectangle template with the diamond shape.
	3. Select the Rect Offset Start field. Enter a desired value in the field (this dimension is from...
	4. Select the Finish button.


	Pre-Dispense Templates
	Introduction
	Property Fields
	Field
	Description
	Figure 8-28


	Applying The Template
	1. Create or load a Process Program.
	2. Insert or select an existing Pre-Dispense Dot or Pre-Dispense Line command.
	3. Use the scrollbar at the bottom of the Program Grid if necessary to display the Name column.
	4. Place the pointer over the Name column cell on the command line and double click the left trac...
	5. Select the desired template name from the drop down list.
	6. Select the OK button.


	Array Templates
	Introduction
	Property fields
	Field
	Description
	Figure 8-29


	Applying The Template
	1. Create or load a Process Program.
	2. Insert or select an existing Array command.
	3. Use the scrollbar at the bottom of the Program Grid if necessary to display the Name column.
	4. Place the pointer over the Name column cell on the command line and double click the left trac...
	5. Select the desired template name from the drop down list.
	6. Select the OK button.


	Renaming A Template
	Procedure
	1. Select File>Template. The Template screen appears. See Figure 8-30.
	2. Select the template file to be renamed. The name template file name appears in the Name field.
	3. Select the Rename button.
	4. Type the new file name.
	5. Hit the keyboard Enter key or select the Rename button.
	Figure 8-30



	Editing Or Copying A Template
	Introduction
	Procedure
	1. Select File>Template A list of existing templates appears. See Figure 8-31.
	Figure 8-31

	2. Select the template file to be edited.
	3. Select the Edit button. The screen displays a group of property fields. See Figure 8-32.
	Figure 8-32

	4. Modify the property values as needed.
	5. If you want to modify an existing template, select the Save button.
	6. If want to create a new template using the current properties values:
	a. Select the Save As button. The Save As template screen appears. See Figure 8-33.
	b. Enter the new template name in the Enter the New Name field.
	c. Select the OK button to accept the new name.

	7. Select the Close button.
	Figure 8-33


	Duplicating A Template
	1. Select File>Templates A list of existing templates appears. See Figure 8-31.
	2. Select (highlight) the template file to be copied.
	3. Select the Save As button. A duplicate file name appears preceded by the words “Copy of”.
	4. Type a name for the duplicate file.
	5. Left click in a neutral (white)area of the file list or select the Close button.


	Running A Process Program
	Introduction
	Before loading or running a Process Program make sure that the system is properly calibrated. Ref...
	Procedure
	1. Select File>Process Programs. A list of existing Process Programs appears. See Figure 8-34.
	2. Select a program from the list.
	Figure 8-34

	3. Select the Load button.
	4. Position a process board on the conveyor.
	5. Select Operations> Conveyor Mode. A pull down menu will appear showing the following:
	6. Select Automatic mode.
	7. Select the Start Operation button on the Machine screen. See Figure 8-35.
	8. To pause the run, select the Pause button on the Machine screen.
	9. To abort the run, select the Abort Process button on the Machine screen.
	10. If you are already in the Program Grid, and you wish to run the program, repeat step 2 throug...
	Figure 8-35




	Optimizing A Process Program (Xyflex)
	Introduction
	Procedure
	1. Select File>Process Programs.

	The optimize function only supports files containing Dot commands.
	2. From the list of existing process programs select the file to be optimized and select the Edit...
	Figure 8-36

	3. Select the Tools icon from the Program Commands Toolbar.
	4. Select the Optimize command from the drop down list.
	Figure 8-37

	5. Select the Heads that will run the optimized program by placing a check in the appropriate Hea...
	6. Enter the appropriate six digit, Needle Part Number for each Head.
	7. Select the Optimize button.
	8. If the software optimized the program to meet your needs, select the Save button.
	9. If you do not like how the system optimized the program, select the Close and the program will...


	Optimizing A Process Program (XyflexPro)
	Introduction
	Procedure
	1. Select File>Process Programs.

	The optimize function only supports files containing Dot commands.
	2. From the list of existing process programs select the file to be optimized and select the Edit...
	3. Select the Tools icon from the Program Commands Toolbar.
	4. Select the Optimize command from the drop down list.
	Figure 8-38

	5. If you have a single XyflexPro machine, place a check in the Head I box. This enables the Opti...
	6. If your line is setup with multiple XyflexPros, place a check in the Optimize for Multiple Mac...
	7. Select the Machines that will run the optimized program by placing a check box in the appropri...
	8. Enter the appropriate six digit, Needle Part Number for each Head or Machine.
	Figure 8-39

	9. Select the Optimize button.
	10. If the software optimized the program to meet your needs, select the Save button.
	11. If you do not like how the system optimized the program, select the Close and the program wil...
	System Administration And Security


	Overview
	Introduction
	When performing any procedure in this section, the command word “Select” refers to the operator t...
	In This Chapter
	Topic
	Page



	User Groups
	Creating Groups

	Privileges
	Security Screens
	Figure 9-1
	Figure 9-2
	1. Select View>Configuration from the Machine screen. The Configuration screen will appear. There...
	2. Select the Group drop down list.

	Creating or Assigning Privileges
	1. Select a User Group by placing the cursor on the group’s Cam_ name and left clicking.
	2. Enable or disable a privilege by clicking left in the checkbox to the left of the privilege. A...
	3. Click left on the OK button to save the changes and dismiss the screen.

	Modifying Privileges
	1. Select a group from the desired security tabs.
	2. Select the privilege box to modify. If unchecked and the desire is to enable it, click in the ...
	3. To disable a checked box (or enabled privilege), left click in the box to remove the check mark.
	4. Select the OK button to accept the changes and dismiss the screen.
	Bad Mark Sensing


	Overview
	Introduction
	A bad mark sensing location may be inserted into any existing program. This command is placed wit...
	When performing any procedure in this section, the command word “Select” refers to the operator t...
	In This Chapter
	Topic
	Page



	Identifying A Bad Mark In The Process Program Grid
	Description
	The vision system software will follow the sequence of Global then Row and end with Local. The us...
	Figure 10-1
	Figure 10-2


	Setting The Vision System For Batch Mode
	Introduction
	In order for the vision system to process any Bad Mark sense the setting for Process Flags - Visi...
	Procedure
	1. Select the Properties tab from the top of the loaded process program. The Properties screen ap...
	Figure 10-3

	2. Select the Vision Batch Mode located in the Process Flags group. See Figure 10-3.
	3. If the bad marks are contained to one local area on the substrate, select the Local Bad Mark B...
	4. Select the Save button.
	5. Select the Close button.



	Creating And Naming The Bad Mark File
	Introduction
	Procedure
	1. Select File>Bad Mark from the menu bar. The Bad Mark Template screen appears. See Figure 10-4.
	Figure 10-4

	2. Type a name for the new bad mark in the Name field. The New button becomes enabled.
	3. Select the New button.
	Figure 10-5

	4. Select the Next button.
	Figure 10-6


	Teaching the Blank Bad Mark
	1. Select the Trackball button. While viewing the vision screen, move the crosshair over to a ref...
	Figure 10-7

	2. Adjust the Search Area so that the reference point is within the frame.
	3. Select the Teach button.
	4. If the Gray scale value is acceptable, select the Next button.

	Teaching the Marked Bad Mark
	1. Select the Trackball button. While viewing the vision screen, move the crosshair over to the s...
	Figure 10-8

	2. Adjust the search area so that the reference point is within the frame.
	3. Select the Teach button.
	4. If the Gray Scale value is acceptable, select the Finish button.


	Inserting The Bad Mark Template Into The Process Program
	Introduction
	Procedure
	1. Load an existing program that you wish to place a Bad Mark in. Figure 10-9 illustrates a typic...
	Figure 10-9

	2. Place a Bad Mark command by selecting the line before any dispense command. The command line b...
	3. Select the Bad Mark icon from the Process Program Commands toolbar.
	4. Select the Bad Mark file that is to be inserted into the loaded program.
	5. Select the OK button.
	6. Select the Bad Mark Level (Global, Row, or Local) for each bad mark command line placed within...
	7. Select the Save button on the Process Program Grid.
	SPC Data


	Overview
	Introduction
	When performing any procedure in this section, the command word “Select” refers to the operator t...
	In This Chapter
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	Setting The SPC Data Log
	Procedure
	1. Select View>Configuration>SPC Data tab from the Machine screen. See Figure 11-1.
	Figure 11-1

	2. Select the Enable data logging field. This makes all the SPC Data fields active.
	3. Select the Data log directory field. This field is where the logged information (selected from...
	4. Select the File Cleanup Interval field.
	5. Select a number from 1 to 30 using the up or down arrow.
	6. Select the Time base for time stamp field.
	7. Select one of the time stamps described above using the left button on the trackball.
	8. Select the Events to log menu list.
	9. Select a minimum of one event from the menu by placing a check in the desired event using the ...
	10. Select OK to accept the entered information for the SPC Data Log and to close the screen.


	Viewing SPC Data
	Description
	Figure 11-2


	Downloading SPC Data
	Procedure
	1. Insert a floppy or a ZIP disk into the computer.
	2. Using the trackball move the cursor to the Start button on the bottom left- hand corner of the...
	3. Move the cursor to the right and find the NT Explorer. Go to the data log directory that was e...
	4. Copy the file that you want to view onto the floppy or Zip disk already inserted in the computer.
	5. Remove disk from the computer and place in an standalone computer.
	6. On the standalone computer, start up the Excel® Application.
	7. Select File, Open from the top of the screen.
	8. Select the file to be viewed from the disk. The Text Import Wizard will appear. See Figure 11-3.
	Figure 11-3

	9. Select the Delimited radio button.
	10. Select the Next >button.
	Figure 11-4

	11. Select the Comma box in the Delimiters group.
	12. Select the Finish button. The file from the disk is now pasted into the Excel® Application. S...
	Figure 11-5

	Network Communications


	Overview
	Introduction
	Do not change the “name” of the system NT computer. Changing the computer name under NT will adve...
	In This Chapter
	Topic
	Page

	Windows NT Workstation
	Windows NT Server


	Networking Configurations
	Stand Alone Configuration
	Figure 12-1

	Two NT Workstations in a Peer-to-Peer Configuration
	Figure 12-2

	NT Workstation and NT Server Configuration
	Figure 12-3


	Benchmark® Software
	Introduction
	Stand Alone Configuration
	When performing remote connections, it is important to have a two-way connection. One connection ...
	Figure 12-4
	Figure 12-5
	Software in a Peer-to- Peer Configuration
	Figure 12-6
	Figure 12-7



	Configuring The Benchmark® Software For Remote UI’s
	Procedure
	1. Configure the Benchmark-Server to run under a new account:
	a. Using the “User Manager” program, add a user account with “Administrator” level privileges. Th...
	b. Go to Start > Settings > Control Panel > Services screen.
	c. Click on the service named CAMALOT Benchmark Server.
	d. Click on the Startup button.
	e. Select the “This Account” radio button and enter the user name (as the account) and password t...


	The Benchmark-Server is now configured to run under the new account. The computer must be reboote...
	2. Using the “User Manager” program, add a user account that matches the user account under which...
	On the Remote Computer
	Dispensing SMT Applications



	Overview
	Introduction
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	SMT/SemiConductor Process Program Grid
	Introduction
	Setting The System For SMT
	1. Select View>Process Programs from the menu on the Main screen.
	Figure 13-1

	2. Select the file listed in the Name field.
	3. Type a new file name of your choice over the existing file name.
	4. Select the New button.
	5. Enter any relative information about this new file (Part Number, Board Size, Material, etc.) i...
	Figure 13-2

	6. Select the Next button. The view area changes to the Properties view. See Figure 13-3.
	Figure 13-3

	7. Select the SMT radio button in the Process Type field. See Figure 13-3.
	8. Select the Save button.
	9. Select the Commands Tab.

	SMT/Semiconductor Process Program Grid Fields
	Grid Fields
	Description


	Typical SMT Application
	Introduction
	Figure 13-4

	Breakdown Of Commands
	Command
	X Position
	Y Position
	Command
	X Position
	Y Position
	Dot Size
	Lift Height
	Dispense Height
	RPM
	Command
	X Position
	Y Position
	Theta
	Figure 13-5


	Running The Process Program
	Pause Or Aborting The Process Program
	1. Select the (Pause) button to pause dispensing or select Operations> Pause from the menu.
	2. Select the (Resume) button to resume dispensing or select Operations>Resume from the menu.
	3. Select the (Abort) button to abort the program or select Operations>Abort from the menu.


	Optimizing A Process Program (Xyflex)
	Introduction
	Procedure
	1. Select File>Process Programs.

	The optimize function only supports files containing Dot commands.
	2. From the list of existing process programs select the file to be optimized and select the Edit...
	Figure 13-6

	3. Select the Tools icon from the Program Commands Toolbar.
	4. Select the Optimize command from the drop down list.
	Figure 13-7

	5. Select the Heads that will run the optimized program by placing a check in the appropriate Hea...
	6. Enter the appropriate six digit, Needle Part Number for each Head.
	7. Select the Optimize button.
	8. If the software optimized the program to meet your needs, select the Save button.
	9. If you do not like how the system optimized the program, select the Close and the program will...


	Optimizing A Process Program (XyflexPro)
	Introduction
	Procedure
	1. Select File>Process Programs.

	The optimize function only supports files containing Dot commands.
	2. From the list of existing process programs select the file to be optimized and select the Edit...
	3. Select the Tools icon from the Program Commands Toolbar.
	4. Select the Optimize command from the drop down list.
	Figure 13-8

	5. If you have a single XyflexPro machine, place a check in the Head I box. This enables the Opti...
	6. If your line is setup with multiple XyflexPros, place a check in the Optimize for Multiple Mac...
	7. Select the Machines that will run the optimized program by placing a check box in the appropri...
	8. Enter the appropriate six digit, Needle Part Number for each Head or Machine.
	Figure 13-9

	9. Select the Optimize button.
	10. If the software optimized the program to meet your needs, select the Save button.
	11. If you do not like how the system optimized the program, select the Close and the program wil...
	Dispensing Underfill And Encapsulation


	Overview
	Introduction
	It is extremely important to set the values in the Properties screen correctly for the intended a...
	In This Chapter
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	Underfill Applications
	Introduction
	Process Description
	Commands And Fields
	1. To find fiducials
	2. To position the center of a part to be underfilled and to identify the chip definition that is...


	Creating Chip Definitions
	Introduction
	Locate Screen
	1. Select File>Locate. A list of previously created chip files appear.
	2. Select the file listed in the Name field.
	3. Type a new file name of your choice over the existing file name.
	4. Select the New button.
	5. Select Chip Def from the list to assign the fiducial type.
	6. Select the Next button and Figure 14-1 appears.
	Figure 14-1
	Figure 14-2


	Creating a New Chip Definition
	1. Position a sample chip under the camera in the dispense area.
	2. Select File>Locate from the menu. A list of previously created chip files appear.
	3. Select the file listed in the Name field.
	4. Type a new file name of your choice over the existing file name.
	5. Select the New button.
	6. Select Chip Def from the list to assign the fiducial type.
	7. Select the Next button and Figure 14-1 appears.
	8. If necessary, adjust camera focus and lighting to desired settings as follows:

	A clear image with well defined edges is required in order to correctly identify fiducials. This ...
	a. Select the Camera Settings button. A popup menu appears. See Figure 14-3.
	Figure 14-3
	b. Adjust the Zoom, Brightness, and Contrast as desired by selecting the applicable up or down ar...

	9. If necessary, adjust the Model Size and Search Areas (green calipers) as follows (See Figure 1...
	a. Place the pointer on one of the square handles on any corner of the box.
	b. Select the handle (a double headed arrow will appear, at any corner) using the trackball chang...
	c. Select the left button on the trackball to accept the change.

	10. Select the Center Regions button, this centers the Model and Search boxes around the chip.
	11. Select the Teach button.
	12. Select the Finish button if the values of the model are acceptable.


	Chipline Start And End Offsets
	Introduction
	Setting the Length Offset Start and End Dimension
	1. Place the cursor on a line of the process program grid where you wish to place a Chipline. Sel...
	Figure 14-4

	2. Select the Length Offset Start field on the Chipline command line. Enter a positive or negativ...
	3. Select the Length Offset End field on the Chipline command line. Enter a positive or negative ...
	Figure 14-5



	Underfill Sample Program
	Introduction
	Commands
	Command
	Description
	Figure 14-6



	Encapsulation Applications
	Introduction
	Procedure
	1. Place the cursor on the command line of the Process Program Grid where you wish to place the u...
	2. Select the icon from the Process Program Grid toolbar.
	3. Select the desired template from the list.
	4. Select the OK button.

	Filled Rectangles
	Procedure
	1. Place the cursor on the command line of the Process Program Grid where you wish to place the f...
	2. Select the filled rectangle icon from the Process Program Grid toolbar.
	3. Select the desired template from the list.
	4. Select the OK button.


	Using The Weight Scale For The Underfill Process
	Introduction
	Example Program
	Figure 14-7

	Procedure
	1. To place the weigh command into the program, highlight the first Chipline command (line 26) an...
	2. Select the weight scale template icon from the Process Program Grid toolbar. A BEGIN WEIGH and...
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